aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilippe Chaintreuil <gentoo_bugs_peep@parallaxshift.com>2022-04-21 16:23:33 -0400
committerPhilippe Chaintreuil <gentoo_bugs_peep@parallaxshift.com>2022-04-21 16:23:58 -0400
commitebfc9b8b3d61f79208e7695b6c82ce9135daa3c0 (patch)
tree142752d2f3a45b298c616b8957aad866161780a8 /net-mail
parentdev-python/clufter fix manifest (diff)
downloadguru-ebfc9b8b3d61f79208e7695b6c82ce9135daa3c0.tar.gz
guru-ebfc9b8b3d61f79208e7695b6c82ce9135daa3c0.tar.bz2
guru-ebfc9b8b3d61f79208e7695b6c82ce9135daa3c0.zip
net-mail/dovecot-fts-xapian: bump to 1.5.5
Signed-off-by: Philippe Chaintreuil <gentoo_bugs_peep@parallaxshift.com>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/dovecot-fts-xapian/Manifest1
-rw-r--r--net-mail/dovecot-fts-xapian/dovecot-fts-xapian-1.5.5.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/net-mail/dovecot-fts-xapian/Manifest b/net-mail/dovecot-fts-xapian/Manifest
index 998897ac3..45d9eafdd 100644
--- a/net-mail/dovecot-fts-xapian/Manifest
+++ b/net-mail/dovecot-fts-xapian/Manifest
@@ -1,2 +1,3 @@
DIST dovecot-fts-xapian-1.5.2.tar.gz 2985120 BLAKE2B 25ab535a93bbc6c0ce6c50cf01916b3349c7a34d9746ea1f87e1bf45eaa643370a3f6a5e967a168b29d0bd601f3dddbff43dd75eab64f4d62d5277f78374cf9f SHA512 afbdd9866d61104d22875eb326a2a893ef0b252e6a493c939db8a29f2d7460a70c8e7648729840ea89d60c374ce75bb34a9c90e7ca2d9c4a9239fa3b2f5905a4
DIST dovecot-fts-xapian-1.5.4.tar.gz 33101 BLAKE2B f2bf7c2cee8930cb8791035d434468537decd72f0643b308f437ad634affa555c486ac4524a1b63b7cc06304e77c431f1e846497b6080c07911a82c20c602c8d SHA512 773579959c79142ab3a24ceaa7da7fd68a9c7dde4439bd613112fc02f4b23d4d7fd258563f771dbe06db4000f9be6a219bd88b07f57521ae45246029af58570d
+DIST dovecot-fts-xapian-1.5.5.tar.gz 33228 BLAKE2B b8e86b3655a6b7291961cfbd39d6ef93ab2e2fbb049e97ebd07b473eb5fc5ecf91950343adfa9c267791442d581ebea47416d8e674d7f3019091fbd69b6e60f1 SHA512 229362207bfa7bb13b1ded4d8b2a2aef7a4a72306e140dc4bd5778991220b27d296ca3659993856f83c80c437f7feadebad1e3ac06f8120a6e45b69f6dbb1ecb
diff --git a/net-mail/dovecot-fts-xapian/dovecot-fts-xapian-1.5.5.ebuild b/net-mail/dovecot-fts-xapian/dovecot-fts-xapian-1.5.5.ebuild
new file mode 100644
index 000000000..2949d81cb
--- /dev/null
+++ b/net-mail/dovecot-fts-xapian/dovecot-fts-xapian-1.5.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Dovecot FTS plugin backed by Xapian"
+HOMEPAGE="https://github.com/grosjo/fts-xapian"
+SRC_URI="https://github.com/grosjo/fts-xapian/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="static-libs"
+
+RDEPEND="
+ dev-libs/icu:=
+ >=dev-libs/xapian-1.4:=
+ net-mail/dovecot:=
+ "
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/fts-xapian-${PV}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-dovecot="${EPREFIX}/usr/$(get_libdir)/dovecot" \
+ $( use_enable static-libs static )
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}