aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilippe Chaintreuil <gentoo_bugs_peep@parallaxshift.com>2022-04-15 08:43:42 -0400
committerPhilippe Chaintreuil <gentoo_bugs_peep@parallaxshift.com>2022-04-15 08:48:58 -0400
commitf32486254b541cb7663bc07ab254421e9421e138 (patch)
tree32c47745974e5c6800f47c26417957093c26a97b /net-mail
parentnet-wireless/rtl8192eu: Add support 5.18 kernel (diff)
downloadguru-f32486254b541cb7663bc07ab254421e9421e138.tar.gz
guru-f32486254b541cb7663bc07ab254421e9421e138.tar.bz2
guru-f32486254b541cb7663bc07ab254421e9421e138.zip
net-mail/dovecot-fts-xapian: bump to 1.5.4
Signed-off-by: Philippe Chaintreuil <gentoo_bugs_peep@parallaxshift.com>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/dovecot-fts-xapian/Manifest1
-rw-r--r--net-mail/dovecot-fts-xapian/dovecot-fts-xapian-1.5.4.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/net-mail/dovecot-fts-xapian/Manifest b/net-mail/dovecot-fts-xapian/Manifest
index 13d7d28a2..998897ac3 100644
--- a/net-mail/dovecot-fts-xapian/Manifest
+++ b/net-mail/dovecot-fts-xapian/Manifest
@@ -1 +1,2 @@
DIST dovecot-fts-xapian-1.5.2.tar.gz 2985120 BLAKE2B 25ab535a93bbc6c0ce6c50cf01916b3349c7a34d9746ea1f87e1bf45eaa643370a3f6a5e967a168b29d0bd601f3dddbff43dd75eab64f4d62d5277f78374cf9f SHA512 afbdd9866d61104d22875eb326a2a893ef0b252e6a493c939db8a29f2d7460a70c8e7648729840ea89d60c374ce75bb34a9c90e7ca2d9c4a9239fa3b2f5905a4
+DIST dovecot-fts-xapian-1.5.4.tar.gz 33101 BLAKE2B f2bf7c2cee8930cb8791035d434468537decd72f0643b308f437ad634affa555c486ac4524a1b63b7cc06304e77c431f1e846497b6080c07911a82c20c602c8d SHA512 773579959c79142ab3a24ceaa7da7fd68a9c7dde4439bd613112fc02f4b23d4d7fd258563f771dbe06db4000f9be6a219bd88b07f57521ae45246029af58570d
diff --git a/net-mail/dovecot-fts-xapian/dovecot-fts-xapian-1.5.4.ebuild b/net-mail/dovecot-fts-xapian/dovecot-fts-xapian-1.5.4.ebuild
new file mode 100644
index 000000000..2949d81cb
--- /dev/null
+++ b/net-mail/dovecot-fts-xapian/dovecot-fts-xapian-1.5.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Dovecot FTS plugin backed by Xapian"
+HOMEPAGE="https://github.com/grosjo/fts-xapian"
+SRC_URI="https://github.com/grosjo/fts-xapian/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="static-libs"
+
+RDEPEND="
+ dev-libs/icu:=
+ >=dev-libs/xapian-1.4:=
+ net-mail/dovecot:=
+ "
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/fts-xapian-${PV}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-dovecot="${EPREFIX}/usr/$(get_libdir)/dovecot" \
+ $( use_enable static-libs static )
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}