aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Persson Forsberg <cat@catcream.org>2023-11-23 16:53:25 +0100
committerAlfred Persson Forsberg <cat@catcream.org>2023-11-23 18:44:05 +0100
commita644a1dc4961991a4f4a25fe3cf32238f736342b (patch)
tree2f357c8a7d16c418f5ad7c9aa2365c96fac89913 /net-p2p
parentsys-kernel/ugrd: Added 0.9.1 which now depends on dev-python/zenlib (diff)
downloadguru-a644a1dc4961991a4f4a25fe3cf32238f736342b.tar.gz
guru-a644a1dc4961991a4f4a25fe3cf32238f736342b.tar.bz2
guru-a644a1dc4961991a4f4a25fe3cf32238f736342b.zip
net-p2p/monero: add USE=hw-wallet
Signed-off-by: Alfred Persson Forsberg <cat@catcream.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/monero/monero-0.18.3.1.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/net-p2p/monero/monero-0.18.3.1.ebuild b/net-p2p/monero/monero-0.18.3.1.ebuild
index 6c810793c..567c589b3 100644
--- a/net-p2p/monero/monero-0.18.3.1.ebuild
+++ b/net-p2p/monero/monero-0.18.3.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -19,7 +19,7 @@ fi
LICENSE="BSD MIT"
SLOT="0"
-IUSE="+daemon readline +tools +wallet-cli +wallet-rpc"
+IUSE="+daemon hw-wallet readline +tools +wallet-cli +wallet-rpc"
REQUIRED_USE="|| ( daemon tools wallet-cli wallet-rpc )"
RESTRICT="test"
@@ -36,6 +36,11 @@ DEPEND="
net-libs/czmq:=
net-libs/miniupnpc
readline? ( sys-libs/readline:0= )
+ hw-wallet? (
+ dev-libs/hidapi
+ dev-libs/protobuf:=
+ virtual/libusb:1
+ )
"
RDEPEND="${DEPEND}"
BDEPEND="virtual/pkgconfig"
@@ -49,7 +54,7 @@ src_configure() {
# TODO: Update CMake to install built libraries (help wanted)
-DBUILD_SHARED_LIBS=OFF
-DMANUAL_SUBMODULES=ON
- -DUSE_DEVICE_TREZOR=OFF
+ -DUSE_DEVICE_TREZOR=$(usex hw-wallet ON OFF)
)
use elibc_musl && mycmakeargs+=( -DSTACK_TRACE=OFF )