aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Alirzaev <l29ah@riseup.net>2023-10-02 02:00:48 +0200
committerSergey Alirzaev <l29ah@riseup.net>2023-10-02 02:00:48 +0200
commitba6264cbdb2e50e74706512bd5d0761bd9061aa0 (patch)
tree32e665807e7d68cbe48ccc07a5122a8fb1c6c8c6 /net-p2p
parentgames-action/classicube: add 1.3.6, drop 1.3.5-r1 (diff)
downloadguru-ba6264cbdb2e50e74706512bd5d0761bd9061aa0.tar.gz
guru-ba6264cbdb2e50e74706512bd5d0761bd9061aa0.tar.bz2
guru-ba6264cbdb2e50e74706512bd5d0761bd9061aa0.zip
net-p2p/monero: add 0.18.3.0
Signed-off-by: Sergey Alirzaev <l29ah@riseup.net>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/monero/Manifest1
-rw-r--r--net-p2p/monero/monero-0.18.3.0.ebuild117
2 files changed, 118 insertions, 0 deletions
diff --git a/net-p2p/monero/Manifest b/net-p2p/monero/Manifest
index e3680bb8a..04b5e0792 100644
--- a/net-p2p/monero/Manifest
+++ b/net-p2p/monero/Manifest
@@ -7,4 +7,5 @@ DIST monero-0.18.1.1.tar.gz 11609864 BLAKE2B 45591a856d251b6d11dc9eac987852fc413
DIST monero-0.18.1.2.tar.gz 11609034 BLAKE2B 3186a1038e9dd8f204a506df28c526bf3e0e5f788ad2d6b512f02735162a479be3f46d309d4e6888f30f962d68ecaf269888c8c0b21a066cad78b3c06f8cfc83 SHA512 d112f34b2fe6720c324560dd523badb68f08d03183d4bbbe7e1aa95f641cde4a1c4fa4042f1d47f9920f799269cc9620150136ebbef6dd66fcd4df0336c0d7f3
DIST monero-0.18.2.0.tar.gz 11624875 BLAKE2B e8dc2e89c664cb218d900ce0803dd1716f1ee363bbddb232fbd22570818c9a9ca307df04808ffef1eb30ee6097fbe243f6977dfad181f57b9169f22d4819f145 SHA512 19625d8e6ee3e9f27ba06eb6027ef21571a2ae8261c9e32f6e74d2f7adf8c73e9dfe34516cd456426274c41ce941e1e5b7eba9f9d20492b99decbd9262aec434
DIST monero-0.18.2.2.tar.gz 11640001 BLAKE2B 04b19e760b09636d7862af2a071128a28006d2829f08039cf55cfa1fd7d054b1382dbbcfc7f0ed381fcbd358e75ec437467349c7f250510e99e06527d1209da6 SHA512 78d4f7fee4eb37ba4837bc392c5869e21c9ea1e9bd9e95f768003bc833302935121c315fb3b4fcbe8f07a9513f928e9e9146dc7ca8892a3db2eb14cfe1371727
+DIST monero-0.18.3.0.tar.gz 14004133 BLAKE2B 9318721474aa5783b79f495ab50b28f5c5e0c0157ddd68c742c3e0866f83863f58106e826036a1604b47462e1307cf60f0ffb3cff6501bf578541b8a9568fb00 SHA512 85b37bb890afa8ea2c12dde9ea3ad654fcfbaccae9feb4033b3f345ee0497fce506f461e0de32d1620b2182ba33ffdb83886f92ebdf6fb39bc4473cc0122cff1
DIST monero-8682.patch 1053 BLAKE2B 6252ee36961d41e6c7161004f2b3ddb0916a2dc91b91eed0e500a9681040366eb7e696abc91b138484bc735da5eb13f0a79ec1ded6f3c36dd3c8f8565113d7cf SHA512 2960a937ec04bc96a3564d2c730ca53cd1369f26d47567cd08c8e90abaf126f336a083e297b4240b5fae22ab3ad3cb45d741f2f48364d30f1442df393109a6eb
diff --git a/net-p2p/monero/monero-0.18.3.0.ebuild b/net-p2p/monero/monero-0.18.3.0.ebuild
new file mode 100644
index 000000000..6c810793c
--- /dev/null
+++ b/net-p2p/monero/monero-0.18.3.0.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake systemd
+
+DESCRIPTION="The secure, private, untraceable cryptocurrency"
+HOMEPAGE="https://github.com/monero-project/monero"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/monero-project/monero.git"
+ EGIT_SUBMODULES=()
+else
+ SRC_URI="https://github.com/monero-project/monero/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="BSD MIT"
+SLOT="0"
+IUSE="+daemon readline +tools +wallet-cli +wallet-rpc"
+REQUIRED_USE="|| ( daemon tools wallet-cli wallet-rpc )"
+RESTRICT="test"
+
+DEPEND="
+ acct-group/monero
+ acct-user/monero
+ dev-libs/boost:=[nls]
+ dev-libs/libsodium:=
+ dev-libs/openssl:=
+ dev-libs/randomx
+ dev-libs/rapidjson
+ dev-libs/supercop
+ net-dns/unbound:=[threads]
+ net-libs/czmq:=
+ net-libs/miniupnpc
+ readline? ( sys-libs/readline:0= )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.18.1.2-unbundle-dependencies.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ # TODO: Update CMake to install built libraries (help wanted)
+ -DBUILD_SHARED_LIBS=OFF
+ -DMANUAL_SUBMODULES=ON
+ -DUSE_DEVICE_TREZOR=OFF
+ )
+
+ use elibc_musl && mycmakeargs+=( -DSTACK_TRACE=OFF )
+
+ cmake_src_configure
+}
+
+src_compile() {
+ local targets=()
+ use daemon && targets+=(daemon)
+ use tools && targets+=(blockchain_{ancestry,blackball,db,depth,export,import,prune,prune_known_spent_data,stats,usage})
+ use wallet-cli && targets+=(simplewallet)
+ use wallet-rpc && targets+=(wallet_rpc_server)
+ cmake_build ${targets[@]}
+}
+
+src_install() {
+ einstalldocs
+
+ # Install all binaries.
+ find "${BUILD_DIR}/bin/" -type f -executable -print0 |
+ while IFS= read -r -d '' line; do
+ dobin "$line"
+ done
+
+ if use daemon; then
+ dodoc utils/conf/monerod.conf
+
+ # data-dir
+ keepdir /var/lib/monero
+ fowners monero:monero /var/lib/monero
+ fperms 0755 /var/lib/monero
+
+ # log-file dir
+ keepdir /var/log/monero
+ fowners monero:monero /var/log/monero
+ fperms 0755 /var/log/monero
+
+ # /etc/monero/monerod.conf
+ insinto /etc/monero
+ doins "${FILESDIR}/monerod.conf"
+
+ # OpenRC
+ newconfd "${FILESDIR}/monerod.confd" monerod
+ newinitd "${FILESDIR}/monerod.initd" monerod
+
+ # systemd
+ systemd_dounit "${FILESDIR}/monerod.service"
+ fi
+}
+
+pkg_postinst() {
+ if use daemon; then
+ elog "Start the Monero P2P daemon as a system service with"
+ elog "'rc-service monerod start'. Enable it at startup with"
+ elog "'rc-update add monerod default'."
+ elog
+ elog "Run monerod status as any user to get sync status and other stats."
+ elog
+ elog "The Monero blockchain can take up a lot of space (80 GiB) and is stored"
+ elog "in /var/lib/monero by default. You may want to enable pruning by adding"
+ elog "'prune-blockchain=1' to /etc/monero/monerod.conf to prune the blockchain"
+ elog "or move the data directory to another disk."
+ fi
+}