aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-10-09 13:50:53 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-10-09 13:50:53 +0500
commit6efb684592b8e1e8403ea5eca2bf4a160bc2beef (patch)
tree3f98b726af6fec781e4d2934e9ec6f1ee3866302 /sci-misc
parentdev-libs/boinc-zip: add 7.20.2 (diff)
downloadguru-6efb684592b8e1e8403ea5eca2bf4a160bc2beef.tar.gz
guru-6efb684592b8e1e8403ea5eca2bf4a160bc2beef.tar.bz2
guru-6efb684592b8e1e8403ea5eca2bf4a160bc2beef.zip
sci-misc/boinc-wrapper: use system libboinc
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/boinc-wrapper/boinc-wrapper-7.20.2-r1.ebuild40
-rw-r--r--sci-misc/boinc-wrapper/files/Makefile.gentoo17
2 files changed, 57 insertions, 0 deletions
diff --git a/sci-misc/boinc-wrapper/boinc-wrapper-7.20.2-r1.ebuild b/sci-misc/boinc-wrapper/boinc-wrapper-7.20.2-r1.ebuild
new file mode 100644
index 000000000..1392fc813
--- /dev/null
+++ b/sci-misc/boinc-wrapper/boinc-wrapper-7.20.2-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+BOINC_SUBMODULE="samples/wrapper"
+inherit boinc
+
+DESCRIPTION="Wrapper to use non-BOINC apps with BOINC"
+HOMEPAGE="https://boinc.berkeley.edu/trac/wiki/WrapperApp"
+
+KEYWORDS="~amd64 ~arm64 ~x86"
+LICENSE="LGPL-3+ regexp-UofT"
+SLOT="0"
+
+RDEPEND="
+ >=sci-misc/boinc-7.20
+ >=dev-libs/boinc-zip-7.20
+"
+DEPEND="${RDEPEND}"
+
+DOCS=( job.xml )
+
+boinc_require_source
+
+boinc_override_config "${FILESDIR}"/config.override.h
+
+src_prepare() {
+ boinc_src_prepare
+ cp "${FILESDIR}"/Makefile.gentoo "${S}" || die
+}
+
+src_compile() {
+ emake -f Makefile.gentoo
+}
+
+src_install() {
+ einstalldocs
+ dobin boinc-wrapper
+}
diff --git a/sci-misc/boinc-wrapper/files/Makefile.gentoo b/sci-misc/boinc-wrapper/files/Makefile.gentoo
new file mode 100644
index 000000000..f023fa557
--- /dev/null
+++ b/sci-misc/boinc-wrapper/files/Makefile.gentoo
@@ -0,0 +1,17 @@
+PKGS = \
+ libboinc \
+ libboinc_api \
+ libboinc_zip
+
+REGEXP_OBJS = \
+ regexp.o \
+ regsub.o \
+ regerror.o \
+ regexp_memory.o \
+ regexp_report.o
+
+CXXFLAGS += $(shell pkg-config --cflags $(PKGS)) -I../..
+LIBS += $(shell pkg-config --libs $(PKGS))
+
+boinc-wrapper: wrapper.o $(REGEXP_OBJS)
+ $(CXX) $(CXXFLAGS) $(CPPFLAGS) -o $@ $^ $(LIBS) $(LDFLAGS)