aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-09-29 22:59:53 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-10-03 20:30:42 +0200
commit5ba23bcee0dc5d3902fdcb493fddd5b7f5285f52 (patch)
treeeffbfded8f73f9cff11e6efda79c64f91981ebd0 /sys-auth
parentdev-python/pysaml2: add 7.0.1, drop 6.1.0 (diff)
downloadguru-5ba23bcee0dc5d3902fdcb493fddd5b7f5285f52.tar.gz
guru-5ba23bcee0dc5d3902fdcb493fddd5b7f5285f52.tar.bz2
guru-5ba23bcee0dc5d3902fdcb493fddd5b7f5285f52.zip
sys-auth/keystone: add 20.0.0.0_rc1, drop 18.0.0
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/keystone/Manifest4
-rw-r--r--sys-auth/keystone/keystone-20.0.0.0_rc1.ebuild (renamed from sys-auth/keystone/keystone-18.0.0.ebuild)89
2 files changed, 51 insertions, 42 deletions
diff --git a/sys-auth/keystone/Manifest b/sys-auth/keystone/Manifest
index a93d9075ae..3ab51e8c4d 100644
--- a/sys-auth/keystone/Manifest
+++ b/sys-auth/keystone/Manifest
@@ -1,2 +1,2 @@
-DIST keystone-18.0.0.tar.gz 1679326 BLAKE2B 714df5a1d7c6d601d1743a2dd3bac57c1006aeb9361241edf4205c583b6df6763411c27aa0d420aa94ee2a8cc581678013cc27ae8a97747f903d61fc852afb6e SHA512 48aa9aae46e0f61596222aa37def152cdb48876afb7edc1eadf84ea91c8bd2f6bfd645d64e9bfb82cf9d041d7ae432c34d25e34130b32b4815d9a73cea903ffc
-DIST keystone.conf.sample-18.0.0 107458 BLAKE2B c1d826acdd671638fc4542864811bda8baa237cfbf24438fa0cedc12e6f29047178cfb1b837c0aef035410848ce3e473e58b51f0eadee4c61eb75f214c65c35a SHA512 6488a1c3eac0d1376db0950cda65c62ba04dc03d896a6c0465ea09b870e5d077ed5012a84657defb9f63db25ce320c884f72c4083e4a233f18930120194ba73b
+DIST keystone-20.0.0.0rc1.tar.gz 1729520 BLAKE2B 69d870dacf786a8e7ef8474027e83e15950432d232f221715f850ae731dcc6d6620684c6118d95333d674de1a7e2790919ffc1f09e553e25b2eedb999c5c38d3 SHA512 9ff450d80270f9fe037f0e21f8322de10a0f80c51b59226b8c62f3dc8b07e5af49c63aa33c6682203e295c1eb54842332a02c9ad7b4e9dd64653d1ee4536944e
+DIST keystone.conf.sample-20.0.0.0_rc1 107458 BLAKE2B c1d826acdd671638fc4542864811bda8baa237cfbf24438fa0cedc12e6f29047178cfb1b837c0aef035410848ce3e473e58b51f0eadee4c61eb75f214c65c35a SHA512 6488a1c3eac0d1376db0950cda65c62ba04dc03d896a6c0465ea09b870e5d077ed5012a84657defb9f63db25ce320c884f72c4083e4a233f18930120194ba73b
diff --git a/sys-auth/keystone/keystone-18.0.0.ebuild b/sys-auth/keystone/keystone-20.0.0.0_rc1.ebuild
index c30bc0bea7..2dd4e531de 100644
--- a/sys-auth/keystone/keystone-18.0.0.ebuild
+++ b/sys-auth/keystone/keystone-20.0.0.0_rc1.ebuild
@@ -1,37 +1,32 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-PYTHON_COMPAT=( python3_8 )
+EAPI=8
+
DISTUTILS_USE_SETUPTOOLS=rdepend
+MYP="${P/_/}"
+PYTHON_COMPAT=( python3_8 )
inherit distutils-r1
DESCRIPTION="The Openstack authentication, authorization, and service catalog"
-HOMEPAGE="https://launchpad.net/keystone"
-if [[ ${PV} == *9999 ]];then
- inherit git-r3
- SRC_URI="https://dev.gentoo.org/~prometheanfire/dist/openstack/keystone/victoria/keystone.conf.sample -> keystone.conf.sample-${PV}"
- EGIT_REPO_URI="https://github.com/openstack/keystone.git"
- EGIT_BRANCH="stable/victoria"
-else
- SRC_URI="https://dev.gentoo.org/~prometheanfire/dist/openstack/keystone/victoria/keystone.conf.sample -> keystone.conf.sample-${PV}
- https://tarballs.openstack.org/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64"
-fi
+HOMEPAGE="
+ https://opendev.org/openstack/keystone
+ https://launchpad.net/keystone
+ https://pypi.org/project/keystone
+"
+SRC_URI="
+ https://dev.gentoo.org/~prometheanfire/dist/openstack/keystone/victoria/keystone.conf.sample -> keystone.conf.sample-${PV}
+ https://tarballs.openstack.org/${PN}/${MYP}.tar.gz
+"
+S="${WORKDIR}/${MYP}"
+KEYWORDS="~amd64"
LICENSE="Apache-2.0"
SLOT="0"
-IUSE="+sqlite ldap memcached mongo mysql postgres test"
-RESTRICT="!test? ( test )"
-REQUIRED_USE="|| ( mysql postgres sqlite )"
+IUSE="+sqlite ldap memcached mongo mysql postgres"
-CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
- !~dev-python/pbr-2.1.0"
-DEPEND="
- ${CDEPEND}"
RDEPEND="
- ${CDEPEND}
>=dev-python/webob-1.7.1[${PYTHON_USEDEP}]
>=dev-python/flask-1.0.2[${PYTHON_USEDEP}]
>=dev-python/flask-restful-0.3.5[${PYTHON_USEDEP}]
@@ -41,7 +36,6 @@ RDEPEND="
)
mysql? (
>=dev-python/pymysql-0.7.6[${PYTHON_USEDEP}]
- !~dev-python/pymysql-0.7.7[${PYTHON_USEDEP}]
>=dev-python/sqlalchemy-1.3.0[${PYTHON_USEDEP}]
)
postgres? (
@@ -56,17 +50,16 @@ RDEPEND="
>=dev-python/bcrypt-3.1.3[${PYTHON_USEDEP}]
>=dev-python/scrypt-0.8.0[${PYTHON_USEDEP}]
>=dev-python/oslo-cache-1.26.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-6.8.0[${PYTHON_USEDEP}]
>=dev-python/oslo-context-2.22.0[${PYTHON_USEDEP}]
>=dev-python/oslo-messaging-5.29.0[${PYTHON_USEDEP}]
>=dev-python/oslo-db-6.0.0[${PYTHON_USEDEP}]
>=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
>=dev-python/oslo-log-3.44.0[${PYTHON_USEDEP}]
>=dev-python/oslo-middleware-3.31.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-policy-3.0.2[${PYTHON_USEDEP}]
- >=dev-python/oslo-serialization-1.18.0[${PYTHON_USEDEP}]
- !~dev-python/oslo-serialization-1.19.1[${PYTHON_USEDEP}]
- >=dev-python/oslo-upgradecheck-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-policy-3.7.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-2.18.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-upgradecheck-1.3.0[${PYTHON_USEDEP}]
>=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
>=dev-python/oauthlib-0.6.2[${PYTHON_USEDEP}]
>=dev-python/pysaml2-5.0.0[${PYTHON_USEDEP}]
@@ -74,7 +67,6 @@ RDEPEND="
>=dev-python/dogpile-cache-1.0.2[${PYTHON_USEDEP}]
>=dev-python/jsonschema-3.2.0[${PYTHON_USEDEP}]
>=dev-python/pycadf-1.1.0[${PYTHON_USEDEP}]
- !~dev-python/pycadf-2.0.0[${PYTHON_USEDEP}]
>=dev-python/msgpack-0.5.0[${PYTHON_USEDEP}]
>=dev-python/osprofiler-1.4.0[${PYTHON_USEDEP}]
>=dev-python/pytz-2013.6[${PYTHON_USEDEP}]
@@ -83,7 +75,6 @@ RDEPEND="
)
mongo? (
>=dev-python/pymongo-3.0.2[${PYTHON_USEDEP}]
- !~dev-python/pymongo-3.1[${PYTHON_USEDEP}]
)
ldap? (
>=dev-python/python-ldap-3.1.0[${PYTHON_USEDEP}]
@@ -95,7 +86,33 @@ RDEPEND="
www-servers/gunicorn[${PYTHON_USEDEP}]
)
acct-user/keystone
- acct-group/keystone"
+ acct-group/keystone
+"
+DEPEND="
+ ${RDEPEND}
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/bashate-0.5.1[${PYTHON_USEDEP}]
+ >=dev-python/stestr-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/freezegun-0.3.6[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2013.6[${PYTHON_USEDEP}]
+ >=dev-python/oslo-db-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.5.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/webtest-2.0.27[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/tempest-17.1.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ )
+"
+
+REQUIRED_USE="
+ || ( mysql postgres sqlite )
+ test? ( ldap )
+"
+
+distutils_enable_tests pytest
python_prepare_all() {
# it's in git, but not in the tarball.....
@@ -108,14 +125,6 @@ python_prepare_all() {
distutils-r1_python_prepare_all
}
-python_test() {
- nosetests -I 'test_keystoneclient*' \
- -e test_static_translated_string_is_Message \
- -e test_get_token_id_error_handling \
- -e test_provider_token_expiration_validation \
- -e test_import --process-restartworker --process-timeout=60 || die "testsuite failed under python2.7"
-}
-
python_install_all() {
distutils-r1_python_install_all
@@ -132,7 +141,7 @@ python_install_all() {
fowners keystone:keystone /etc/keystone /etc/keystone/httpd /var/log/keystone
# stupid python doing stupid things
- rm -r "${ED}"/usr/etc
+ rm -r "${ED}/usr/etc" || die
}
pkg_postinst() {