aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2020-03-30 18:26:47 +0200
committerVolkmar W. Pogatzki <gentoo@pogatzki.net>2020-03-30 18:26:47 +0200
commit779e6b56b88d63fe741b80b9084fbbe711be915a (patch)
tree203fcd28894393592d02ca882e5a0f1f4f14cf02 /sys-auth
parentsci-libs/jdqz: do not die if USE="-doc" (diff)
downloadguru-779e6b56b88d63fe741b80b9084fbbe711be915a.tar.gz
guru-779e6b56b88d63fe741b80b9084fbbe711be915a.tar.bz2
guru-779e6b56b88d63fe741b80b9084fbbe711be915a.zip
sys-auth/AusweisApp2: new package
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net>
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/AusweisApp2/AusweisApp2-1.20.0.ebuild38
-rw-r--r--sys-auth/AusweisApp2/Manifest1
-rw-r--r--sys-auth/AusweisApp2/metadata.xml8
3 files changed, 47 insertions, 0 deletions
diff --git a/sys-auth/AusweisApp2/AusweisApp2-1.20.0.ebuild b/sys-auth/AusweisApp2/AusweisApp2-1.20.0.ebuild
new file mode 100644
index 0000000000..82cea2603b
--- /dev/null
+++ b/sys-auth/AusweisApp2/AusweisApp2-1.20.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_BUILD_TYPE=Release
+inherit cmake-utils
+
+DESCRIPTION="Official authentication app for German ID cards and residence permits"
+HOMEPAGE="https://www.ausweisapp.bund.de/"
+SRC_URI="https://github.com/Governikus/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="EUPL-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtconcurrent:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwebsockets:5[qml]
+ dev-qt/qtquickcontrols2:5
+ dev-qt/qtwidgets:5
+ dev-libs/openssl:0=
+ sys-apps/pcsc-lite
+ net-libs/http-parser"
+
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=( -DBUILD_SHARED_LIBS=OFF )
+ cmake-utils_src_configure
+}
diff --git a/sys-auth/AusweisApp2/Manifest b/sys-auth/AusweisApp2/Manifest
new file mode 100644
index 0000000000..6a730bf1ac
--- /dev/null
+++ b/sys-auth/AusweisApp2/Manifest
@@ -0,0 +1 @@
+DIST AusweisApp2-1.20.0.tar.gz 9727544 BLAKE2B 23d31b5cff2756948d563052ff53fffb737c6895fddada036969350b0a65f404f8def70f8ac4409a34fe9f83160e15cd8d4b6441f901f8e53e791ca386140383 SHA512 9222bc59521aa3533c79206df14b079e618f6efbdd04c11b4cc754027dc155d2ad4a321cabdbb35b9308f5e9631ca05e828969633125fe0ac651156669a784d0
diff --git a/sys-auth/AusweisApp2/metadata.xml b/sys-auth/AusweisApp2/metadata.xml
new file mode 100644
index 0000000000..6c6206dd10
--- /dev/null
+++ b/sys-auth/AusweisApp2/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="github">Governikus/AusweisApp2</remote-id>
+ </upstream>
+</pkgmetadata>