aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArsen Arsenović <arsen@gentoo.org>2023-03-15 10:50:51 +0100
committerArsen Arsenović <arsen@gentoo.org>2023-03-15 10:52:48 +0100
commit32aca42ba7dea13c9c21456909b2ded25bdf6c45 (patch)
tree4fa0970ac4d447d03dc7dd9f363e6160465480f3 /sys-boot
parentmedia-sound/spotify-adblock: handle the debug USE flag (diff)
downloadguru-32aca42ba7dea13c9c21456909b2ded25bdf6c45.tar.gz
guru-32aca42ba7dea13c9c21456909b2ded25bdf6c45.tar.bz2
guru-32aca42ba7dea13c9c21456909b2ded25bdf6c45.zip
sys-boot/limine: add 4.20230315.0
Signed-off-by: Arsen Arsenović <arsen@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/limine/Manifest1
-rw-r--r--sys-boot/limine/limine-4.20230315.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/sys-boot/limine/Manifest b/sys-boot/limine/Manifest
index 04254de81..f8e6a8a5a 100644
--- a/sys-boot/limine/Manifest
+++ b/sys-boot/limine/Manifest
@@ -11,3 +11,4 @@ DIST limine-4.20230227.0.tar.xz 782796 BLAKE2B 35819ccfe896f595a10b666bc0a8d665e
DIST limine-4.20230305.2.tar.xz 783156 BLAKE2B 0a030a8ed3b1cef212adf94ba22d3e599b7cbae61551e374c9139fb6a2c02eae6c6f3241cebf220f877df91c0e9fc1b4f0cbafa35d4fe3fa32b380df50b9528a SHA512 6adb0054f512710752667419a08439175e63297794a9c88eaad92a20c54abfbc45636ecac10302db3a4956469d2c1b8608495ef60b51888fef7c2f0da8843d25
DIST limine-4.20230307.0.tar.xz 783112 BLAKE2B 108340d15aca9954c22bf78e2abcc1d1f65036cfbc37247385b77565146a96a405884d8d7c9d3999785090b8d980d6c3b17c3d658b7381ffba3f57cfff57bbcf SHA512 55de1d592157e4227caca6191b764c5a093208d3ba02b23e4fc03f7f132b86cc9984b0bae084fa909506cd9ff4c29f8fdb628699e34511389be12e7e46bd52c2
DIST limine-4.20230308.0.tar.xz 783384 BLAKE2B 2aa80c90b495f3fa09b5324fa58a8fa547f6763924bef7b0b82e1c02b56e0ea9a1c9cc3afab698450c37d9ec4146dd4b621ea93208733c285793a10fa153fba2 SHA512 e715dc27936037248fc8be7e1cd4f460af40217eff74e90cd56562d252c915ee97c8b8129bb523043a3e57cfbca8846fc2a0183d8c6337e9bca2e763ed306ec3
+DIST limine-4.20230315.0.tar.xz 897716 BLAKE2B ca46816a2fd326fa3ac642b3b3ca3cc6fdef3d68831cebe7b52dcb2a3fe818a5aa249ff2d69e44e31f64cdcce5a7f32914e6264fc175687e2b62115a5e7238ff SHA512 58dbea3f55913ffae938367ff0f5e1a13fe7439bac6e7766a00909dbab01eeb05da2120bbcda46f1b3fa3ff170f8adbf2d2f5e589cb6c3581327c2ee175445de
diff --git a/sys-boot/limine/limine-4.20230315.0.ebuild b/sys-boot/limine/limine-4.20230315.0.ebuild
new file mode 100644
index 000000000..0a48fd176
--- /dev/null
+++ b/sys-boot/limine/limine-4.20230315.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Limine is a modern, advanced, and portable BIOS/UEFI multiprotocol bootloader"
+HOMEPAGE="https://limine-bootloader.org/"
+SRC_URI="https://github.com/limine-bootloader/limine/releases/download/v${PV}/limine-${PV}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+bios +bios-pxe +bios-cd +cd-efi +uefi32 +uefi64 +uefiaa64"
+
+MY_LLVM_TARGETS="AArch64 ARM X86"
+MY_LLVM_FLAGS="llvm_targets_${MY_LLVM_TARGETS// /(-),llvm_targets_}(-)"
+
+BDEPEND="
+ app-arch/gzip
+ dev-lang/nasm
+ sys-apps/findutils
+ sys-devel/clang[${MY_LLVM_FLAGS}]
+ sys-devel/lld
+ sys-devel/llvm[${MY_LLVM_FLAGS}]
+
+ cd-efi? ( sys-fs/mtools )
+"
+
+src_configure() {
+ local myconf=(
+ "$(use_enable bios)"
+ "$(use_enable bios-cd)"
+ "$(use_enable bios-pxe)"
+
+ "$(use_enable uefi32 uefi-ia32)"
+ "$(use_enable uefi64 uefi-x86-64)"
+ "$(use_enable uefiaa64 uefi-aarch64)"
+ "$(use_enable cd-efi uefi-cd)"
+ )
+
+ FREESTANDING_TOOLCHAIN=llvm \
+ econf "${myconf[@]}"
+}