aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-07-01 00:53:47 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-07-01 01:40:19 +0200
commit270cf23973818956d6f8246e584eda7dd11c5940 (patch)
tree1d8ce082c90586d9a6ee775c2ba185dbbf7c4684 /sys-cluster
parentapp-misc/navi: Version bump + crates update live ebuild (diff)
downloadguru-270cf23973818956d6f8246e584eda7dd11c5940.tar.gz
guru-270cf23973818956d6f8246e584eda7dd11c5940.tar.bz2
guru-270cf23973818956d6f8246e584eda7dd11c5940.zip
sys-cluster/scorep: add openacc useflag
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/scorep/metadata.xml1
-rw-r--r--sys-cluster/scorep/scorep-7.1-r1.ebuild5
-rw-r--r--sys-cluster/scorep/scorep-7.1.ebuild4
3 files changed, 5 insertions, 5 deletions
diff --git a/sys-cluster/scorep/metadata.xml b/sys-cluster/scorep/metadata.xml
index b371d2d2e..68bcf7105 100644
--- a/sys-cluster/scorep/metadata.xml
+++ b/sys-cluster/scorep/metadata.xml
@@ -9,6 +9,7 @@
<flag name="gcc-plugin">Enable support for the GCC plug-in instrumentation</flag>
<flag name="llvm">Enable the user library wrapping feature</flag>
<flag name="online-access">Enable Online Access</flag>
+ <flag name="openacc">Enable support for OpenACC</flag>
<flag name="opencl">Build with libOpenCL support</flag>
<flag name="openshmem">Use the SHMEM compiler</flag>
<flag name="pmi">Build with libpmi support</flag>
diff --git a/sys-cluster/scorep/scorep-7.1-r1.ebuild b/sys-cluster/scorep/scorep-7.1-r1.ebuild
index e44d04bb6..eadffa9b9 100644
--- a/sys-cluster/scorep/scorep-7.1-r1.ebuild
+++ b/sys-cluster/scorep/scorep-7.1-r1.ebuild
@@ -18,8 +18,7 @@ S="${WORKDIR}/sources.edf930df"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="debug gcc-plugin llvm mpi online-access opencl openshmem pmi unwind"
-#TODO: openacc
+IUSE="debug gcc-plugin llvm mpi online-access +openacc opencl openshmem pmi unwind"
CDEPEND="
dev-libs/cubelib
@@ -123,7 +122,6 @@ src_configure() {
local myconf=(
--disable-cuda
--disable-experimental-platform
- --disable-openacc
--disable-platform-mic
--disable-static
--enable-shared
@@ -144,6 +142,7 @@ src_configure() {
--without-pdt
$(use_enable debug)
+ $(use_enable openacc)
$(use_with gcc-plugin)
$(use_with online-access)
$(use_with opencl libOpenCL)
diff --git a/sys-cluster/scorep/scorep-7.1.ebuild b/sys-cluster/scorep/scorep-7.1.ebuild
index 6ac68d960..d12a677a3 100644
--- a/sys-cluster/scorep/scorep-7.1.ebuild
+++ b/sys-cluster/scorep/scorep-7.1.ebuild
@@ -16,7 +16,7 @@ SRC_URI="https://perftools.pages.jsc.fz-juelich.de/cicd/${PN}/tags/${P}/${P}.tar
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="debug gcc-plugin llvm mpi online-access opencl openshmem pmi unwind"
+IUSE="debug gcc-plugin llvm mpi online-access +openacc opencl openshmem pmi unwind"
CDEPEND="
dev-libs/cubelib
@@ -122,7 +122,6 @@ src_configure() {
local myconf=(
--disable-cuda
--disable-experimental-platform
- --disable-openacc
--disable-platform-mic
--disable-static
--enable-shared
@@ -143,6 +142,7 @@ src_configure() {
--without-pdt
$(use_enable debug)
+ $(use_enable openacc)
$(use_with gcc-plugin)
$(use_with online-access)
$(use_with opencl libOpenCL)