aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Olagbaiye <bqv@fron.io>2022-05-18 20:36:30 +0100
committerTony Olagbaiye <bqv@fron.io>2022-05-18 20:36:30 +0100
commit101320a44ad90548e7678e1fe9eab562e4d34ae0 (patch)
tree094a25c9d7d20eca39ff67bd1c66da824ea7f12b /sys-process
parentdev-libs/weechat-relay: unkeyword 9999 for ~amd64 (diff)
downloadguru-101320a44ad90548e7678e1fe9eab562e4d34ae0.tar.gz
guru-101320a44ad90548e7678e1fe9eab562e4d34ae0.tar.bz2
guru-101320a44ad90548e7678e1fe9eab562e4d34ae0.zip
sys-process/snooze: simplify ebuilds
Signed-off-by: Tony Olagbaiye <bqv@fron.io>
Diffstat (limited to 'sys-process')
-rw-r--r--[l---------]sys-process/snooze/snooze-0.5.ebuild18
-rw-r--r--sys-process/snooze/snooze-9999.ebuild10
2 files changed, 20 insertions, 8 deletions
diff --git a/sys-process/snooze/snooze-0.5.ebuild b/sys-process/snooze/snooze-0.5.ebuild
index fff5de8a5..19a93cb6c 120000..100644
--- a/sys-process/snooze/snooze-0.5.ebuild
+++ b/sys-process/snooze/snooze-0.5.ebuild
@@ -1 +1,17 @@
-snooze-9999.ebuild \ No newline at end of file
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Run a command at a particular time"
+HOMEPAGE="https://github.com/leahneukirchen/${PN}"
+SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="CC0-1.0"
+SLOT="0"
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr install
+ dodoc {README,NEWS}.md
+}
diff --git a/sys-process/snooze/snooze-9999.ebuild b/sys-process/snooze/snooze-9999.ebuild
index 53b600639..204622917 100644
--- a/sys-process/snooze/snooze-9999.ebuild
+++ b/sys-process/snooze/snooze-9999.ebuild
@@ -5,13 +5,9 @@ EAPI=7
DESCRIPTION="Run a command at a particular time"
HOMEPAGE="https://github.com/leahneukirchen/${PN}"
-if [[ "${PV}" = 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="${HOMEPAGE}.git"
-else
- SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 x86"
-fi
+
+inherit git-r3
+EGIT_REPO_URI="${HOMEPAGE}.git"
LICENSE="CC0-1.0"
SLOT="0"