aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-03-26 12:23:57 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-03-26 12:23:57 +0100
commit64139f8fdcead82e90192eb813cc010d6151f129 (patch)
tree0fd44f3de72838d12b6e4b183f158193e2c230a5 /sys-process
parentnet-p2p/monero: treeclean (diff)
downloadguru-64139f8fdcead82e90192eb813cc010d6151f129.tar.gz
guru-64139f8fdcead82e90192eb813cc010d6151f129.tar.bz2
guru-64139f8fdcead82e90192eb813cc010d6151f129.zip
sys-process/task-spooler: quote unquoted variables, add missing || die
simplify patch applying, move S up Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/task-spooler/task-spooler-1.3.0.ebuild17
1 files changed, 5 insertions, 12 deletions
diff --git a/sys-process/task-spooler/task-spooler-1.3.0.ebuild b/sys-process/task-spooler/task-spooler-1.3.0.ebuild
index cbda27c747..5c8fc96f17 100644
--- a/sys-process/task-spooler/task-spooler-1.3.0.ebuild
+++ b/sys-process/task-spooler/task-spooler-1.3.0.ebuild
@@ -8,6 +8,7 @@ inherit cmake
DESCRIPTION="A scheduler for CPU tasks"
HOMEPAGE="https://github.com/justanhduc/task-spooler"
SRC_URI="https://github.com/justanhduc/${PN}/archive/refs/tags/v${PV}-cpu.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/task-spooler-${PV}-cpu"
# A GPU version does exist, if anyone needs it, it can be added through a use flag
@@ -18,29 +19,21 @@ IUSE="doc"
DOCS="Changelog OBJECTIVES PORTABILITY PROTOCOL README.md TRICKS"
HTML_DOCS=( web/index.html web/ts-0.2.1.png web/ts-0.5.4.ebuild web/article_linux_com.html )
-S="${WORKDIR}/task-spooler-${PV}-cpu"
-
-src_prepare() {
- default
-
- eapply "${FILESDIR}"/var-redefinition.patch
-
- cmake_src_prepare
-}
+PATCHES=( "${FILESDIR}"/var-redefinition.patch )
src_test() {
- cp ${BUILD_DIR}/ts ${S}/ || die "failed to copy ts executable to source folder for tests"
+ cp $"{BUILD_DIR}/ts" "${S}"/ || die "failed to copy ts executable to source folder for tests"
sh testbench.sh || die "tests failed"
}
src_install() {
- cd ${WORKDIR}/${P}-cpu_build
+ cd "${WORKDIR}/${P}-cpu_build" || die
mv ts tsp || die "Failed renaming ts executable into tsp"
dobin tsp
# When the use flag doc is enabled.
if use doc; then
- cd ${S}
+ cd "${S}" || die
einstalldocs
fi
}