aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authortiotags <tiotags1@gmail.com>2021-04-21 11:49:23 +0300
committertiotags <tiotags1@gmail.com>2021-04-21 11:49:23 +0300
commitb1349123aa8262d56069a350b766e03813c2becb (patch)
tree997dbee4254a9d2d76cf15e9b6dc44d8a27c441d /www-servers
parentnet-vpn/riseup-vpn: move linguist-tools to BDEPEND (diff)
downloadguru-b1349123aa8262d56069a350b766e03813c2becb.tar.gz
guru-b1349123aa8262d56069a350b766e03813c2becb.tar.bz2
guru-b1349123aa8262d56069a350b766e03813c2becb.zip
www-servers/hinsightd: added ebuild 0.9.0
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Alexandru Campeanu <tiotags1@gmail.com>
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/hinsightd/Manifest1
-rw-r--r--www-servers/hinsightd/hinsightd-0.9.0.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/www-servers/hinsightd/Manifest b/www-servers/hinsightd/Manifest
new file mode 100644
index 0000000000..61940dc508
--- /dev/null
+++ b/www-servers/hinsightd/Manifest
@@ -0,0 +1 @@
+DIST hin9-v0.9.0.tar.gz 65320 BLAKE2B c1348bc5afffa8804494f6ae228f54874d25cc5f40c17ee2a36f23104286f96f5d616cdc3e98de0854cf7d4b18165a2b70600b32f58024b679d213b2156c1f18 SHA512 60a1ff72d1abf57d8f764ebb77ab77f7069b40bfdbb5bb1c95324b366d1052378ffe36198112a595e08238622654a9c1e1d89679924883f8ff42b98ca7cf139e
diff --git a/www-servers/hinsightd/hinsightd-0.9.0.ebuild b/www-servers/hinsightd/hinsightd-0.9.0.ebuild
new file mode 100644
index 0000000000..1a48c1f944
--- /dev/null
+++ b/www-servers/hinsightd/hinsightd-0.9.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..4} )
+
+inherit fcaps
+
+DESCRIPTION="hinsightd a http/1.1 webserver with (hopefully) minimal goals"
+HOMEPAGE="https://gitlab.com/tiotags/hin9"
+SRC_URI="https://gitlab.com/tiotags/hin9/-/archive/v0.9.0/hin9-v0.9.0.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+IUSE="" #+openssl
+
+BDEPEND="
+dev-util/ninja
+"
+
+RDEPEND="
+acct-user/hinsightd
+acct-group/hinsightd
+sys-libs/liburing
+dev-lang/lua:*
+sys-libs/zlib
+dev-libs/openssl
+"
+
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+"${FILESDIR}/hinsightd-redefine-directories.patch"
+)
+
+#src_configure() {
+#}
+
+src_compile() {
+ cd build
+ ninja || die
+}
+
+src_install() {
+ newbin "${S}/build/hin9" hinsightd
+ newinitd "${FILESDIR}/init.d.sh" hinsightd
+ #systemd_dounit "${FILESDIR}/hinsightd.service" # not tested
+
+ insinto /etc/hinsightd
+ newins "${S}/workdir/main.lua" hinsightd.lua
+
+ # logrotate
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/logrotate.d.sh hinsightd
+
+ keepdir /var/www/localhost/htdocs
+ keepdir /var/log/hinsightd
+ keepdir /var/tmp/hinsightd
+}
+
+pkg_postinst() {
+ fcaps CAP_NET_BIND_SERVICE /usr/bin/hinsightd
+}