aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2021-10-27 03:13:13 +0300
committerSergey Torokhov <torokhov-s-a@yandex.ru>2021-10-27 03:13:13 +0300
commit347c3d914b7e2cd7e77841d4b86ad49a0a877d7a (patch)
tree03c33a8aa2a96af2d7b9a93c0ebd63fb73c251d5 /x11-libs
parentx11-libs/gtk-fortran: 3.24.30 version bump (diff)
downloadguru-347c3d914b7e2cd7e77841d4b86ad49a0a877d7a.tar.gz
guru-347c3d914b7e2cd7e77841d4b86ad49a0a877d7a.tar.bz2
guru-347c3d914b7e2cd7e77841d4b86ad49a0a877d7a.zip
x11-libs/gtk-fortran: 4.1.0 version bump, new SLOT
SLOT="4" depends on gui-libs/gtk:4 instead of x11-libs/gtk+:3 and could be installed independently of x11-libs/gtk-fortran:3 Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/gtk-fortran/Manifest1
-rw-r--r--x11-libs/gtk-fortran/gtk-fortran-4.1.0.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/x11-libs/gtk-fortran/Manifest b/x11-libs/gtk-fortran/Manifest
index 67d6d1499c..010a18a627 100644
--- a/x11-libs/gtk-fortran/Manifest
+++ b/x11-libs/gtk-fortran/Manifest
@@ -1,2 +1,3 @@
DIST gtk-fortran-3.24.18.tar.gz 4066185 BLAKE2B 45a84dfd27b5f0495da55526262e3ba888f1d7eaa685336aaafae726dab63d047d71901a07eafc08c2f51d1e24a087e85f7b2a172323a8f1608c5ff64193f31c SHA512 b8ebf9e129c95c7aa2cf67d41f16915a18f05bd4cce4001ed56148b6d4e4ae3fe2b2e2080f35a1db4be8256bc3d5992061bf0c0e55e332f9a75a4a03e52cded5
DIST gtk-fortran-3.24.30.tar.gz 4276622 BLAKE2B 4b18d21e0479496caea386450fc16c12d20ad3491932b331890b5d7328c704799f8dd288c4a1d0d2e34f0957f0bdca316f820850b80c4ff8d2b66ce3673fe5ec SHA512 4e1cd522ca80db01a1058d6c58b4a6e3e63e6b1d510e2ee5fd0b8f8aa9f9dc8e433d203781c908065571c4c1a6d9686c22eec879b396352b12fa82b604855c86
+DIST gtk-fortran-4.1.0.tar.gz 4100843 BLAKE2B c11658472c4f2ad9916f8f421f0d1c48b9ec7874e9e4075f2247e7cfb33ed69946e644aa9a460d63ff676c075b76caf4c70bd09532dda53b4d2035c88b3c1c61 SHA512 cd4628a56b2a03f7e958d4284c595b573ab84ac6c630cfae4f3ed13bb6d19a66246cb6adac8b05104f562406a467c03841cf350f8482e7e9f8fd596de4f4c873
diff --git a/x11-libs/gtk-fortran/gtk-fortran-4.1.0.ebuild b/x11-libs/gtk-fortran/gtk-fortran-4.1.0.ebuild
new file mode 100644
index 0000000000..b95e916966
--- /dev/null
+++ b/x11-libs/gtk-fortran/gtk-fortran-4.1.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_MAKEFILE_GENERATOR="emake"
+FORTRAN_STANDARD=2003
+
+inherit cmake fortran-2
+
+DESCRIPTION="A GTK+ binding to build Graphical User Interfaces in Fortran"
+HOMEPAGE="https://github.com/vmagnin/gtk-fortran"
+SRC_URI="https://github.com/vmagnin/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="examples high-level plplot static-libs"
+REQUIRED_USE="plplot? ( high-level )"
+
+RDEPEND="
+ gui-libs/gtk:4
+ plplot? ( >=sci-libs/plplot-5.13.0[cairo,fortran] )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/fortran
+ virtual/pkgconfig
+"
+
+DOCS=( "README.md" "README-high-level.md" "CHANGELOG.md" )
+
+pkg_setup() {
+ fortran-2_pkg_setup
+}
+
+src_prepare() {
+ default
+ # Fix library installation path and disable 'sketcher' build
+ sed -i -e "s:CMAKE_INSTALL_LIBDIR lib:CMAKE_INSTALL_LIBDIR $(get_libdir):" \
+ -e "s: add_subdirectory(sketcher)::" CMakeLists.txt || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ mycmakeargs+=(
+ -DEXCLUDE_PLPLOT=$(usex plplot false true)
+ -DNO_BUILD_HL=$(usex high-level false true)
+ -DINSTALL_EXAMPLES=$(usex examples)
+ -DNO_BUILD_EXAMPLES=true
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ # Remove static library here as it's used to build additional tools
+ if use !static-libs ; then
+ rm "${ED}/usr/$(get_libdir)/libgtk-${SLOT}-fortran.a" || die
+ fi
+}