aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorGerben Jan Dijkman <gjdijkman@gjdwebserver.nl>2021-11-11 12:17:35 +0100
committerGerben Jan Dijkman <gjdijkman@gjdwebserver.nl>2021-11-11 12:17:35 +0100
commit26608cffa55a61f2adbe6dbfafa8468211bf9545 (patch)
tree008f8f682a9b8e8335bfc2297a3fd0ecf7dc9aa9 /x11-wm
parentnet-wireless/rtl8821cu: Version bump (diff)
downloadguru-26608cffa55a61f2adbe6dbfafa8468211bf9545.tar.gz
guru-26608cffa55a61f2adbe6dbfafa8468211bf9545.tar.bz2
guru-26608cffa55a61f2adbe6dbfafa8468211bf9545.zip
x11-wm/phoc: Fixed wlroots and dep
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Gerben Jan Dijkman <gjdijkman@gjdwebserver.nl>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/phoc/Manifest2
-rw-r--r--x11-wm/phoc/files/0001-seat-Don-t-notify-on-key-release.patch19
-rw-r--r--x11-wm/phoc/metadata.xml3
-rw-r--r--x11-wm/phoc/phoc-0.9.0.ebuild12
4 files changed, 20 insertions, 16 deletions
diff --git a/x11-wm/phoc/Manifest b/x11-wm/phoc/Manifest
index 72e811c187..5c4d37dd25 100644
--- a/x11-wm/phoc/Manifest
+++ b/x11-wm/phoc/Manifest
@@ -1,2 +1,2 @@
DIST phoc-v0.9.0.tar.gz 154836 BLAKE2B c701b1f9384d86d381719320303f9baa0000a0cabaed6d81d359a2f72f0c067da965ba57659c63b65aee32604b2bec65a4e6c8a59c3bbd8433ef3231a139bf3c SHA512 1146bd689a1a2fac60f2b4ea5893bd49c6cb4628cc4a6422a053e3210fed238ab572c28144f262ed5cc2992ebd3870e587a051e2b62f39e2fc146218387a5d89
-DIST wlroots-0.12.0.tar.gz 476936 BLAKE2B 4129c87a148085f95f4cee6973308d79ab3f8b024247287a68dadd6729da8a5f8cc1e4ada63c15477a2c8e8258032440afe4a21a26f947143d17c87b0ca8a1a4 SHA512 560eae30932b777c1f07fb44592d5601c5d10ef74b31b6b9e4166a14caadab2bfa88d39282f159785d4c7f22f78d204f9bb7fab65d58afaf14b72a8486f9b415
+DIST wlroots-5413b1ec61c6e3390929db595c0ec92f92ea2594.tar.gz 477754 BLAKE2B 6424b3ec038b3cb658ffeeb6302c210f5632fc524017c6de2f33794650b44dcd79d6079bd2799df5e5440f4710c7155fd81e1beedb7694f6b953ec62572dcbd2 SHA512 353532240840ccd11192a807d8d2c3d13ca42cbdaf7366e6a4908a4698d0305910ff152b12fe6839dde72f63b4ea279f47d4268196d34d2ee02f69c9ae9e4e9d
diff --git a/x11-wm/phoc/files/0001-seat-Don-t-notify-on-key-release.patch b/x11-wm/phoc/files/0001-seat-Don-t-notify-on-key-release.patch
index a2928002b5..2a896de499 100644
--- a/x11-wm/phoc/files/0001-seat-Don-t-notify-on-key-release.patch
+++ b/x11-wm/phoc/files/0001-seat-Don-t-notify-on-key-release.patch
@@ -11,15 +11,16 @@ diff --git a/src/seat.c b/src/seat.c
index b04fed1..679a3f5 100644
--- a/src/seat.c
+++ b/src/seat.c
-@@ -30,8 +30,9 @@ static void handle_keyboard_key(struct wl_listener *listener, void *data) {
- PhocKeyboard *keyboard =
- wl_container_of(listener, keyboard, keyboard_key);
- PhocDesktop *desktop = server->desktop;
-- wlr_idle_notify_activity(desktop->idle, keyboard->seat->seat);
- struct wlr_event_keyboard_key *event = data;
-+ if (event->state == WLR_KEY_PRESSED)
-+ wlr_idle_notify_activity(desktop->idle, keyboard->seat->seat);
- phoc_keyboard_handle_key(keyboard, event);
+@@ -42,9 +42,9 @@ handle_keyboard_key (struct wl_listener
+ wl_container_of (listener, keyboard, keyboard_key);
+ PhocDesktop *desktop = server->desktop;
+
+- wlr_idle_notify_activity (desktop->idle, keyboard->seat->seat);
+ struct wlr_event_keyboard_key *event = data;
+-
++ if (event->state == WLR_KEY_PRESSED)
++ wlr_idle_notify_activity(desktop->idle, keyboard->seat->seat);
+ phoc_keyboard_handle_key (keyboard, event);
}
--
diff --git a/x11-wm/phoc/metadata.xml b/x11-wm/phoc/metadata.xml
index 52a95ab63f..d495e34d97 100644
--- a/x11-wm/phoc/metadata.xml
+++ b/x11-wm/phoc/metadata.xml
@@ -5,6 +5,9 @@
<email>gjdijkman@gjdwebserver.nl</email>
<name>Gerben Jan Dijkman</name>
</maintainer>
+ <longdescription lang="en">
+ Wayland compositor for mobile phones like the Librem 5.
+ </longdescription>
<upstream>
<doc>https://source.puri.sm/Librem5/phoc</doc>
<bugs-to>https://source.puri.sm/Librem5/phoc/-/issues</bugs-to>
diff --git a/x11-wm/phoc/phoc-0.9.0.ebuild b/x11-wm/phoc/phoc-0.9.0.ebuild
index a60acea7a5..a5de2747bc 100644
--- a/x11-wm/phoc/phoc-0.9.0.ebuild
+++ b/x11-wm/phoc/phoc-0.9.0.ebuild
@@ -7,9 +7,9 @@ inherit meson vala xdg gnome2-utils
MY_PV="v${PV}"
MY_P="${PN}-${MY_PV}"
-# 0.13.0 does not work atm
-WL_PV="0.12.0"
-WL_P="wlroots-${WL_PV}"
+
+WL_COMMIT="5413b1ec61c6e3390929db595c0ec92f92ea2594"
+WL_P="wlroots-${WL_COMMIT}"
DESCRIPTION="Wlroots based Phone compositor"
HOMEPAGE="https://gitlab.gnome.org/World/Phosh/phoc"
@@ -18,7 +18,7 @@ HOMEPAGE="https://gitlab.gnome.org/World/Phosh/phoc"
# the phoc installation. we follow method used in archlinuxarm
SRC_URI="
https://gitlab.gnome.org/World/Phosh/phoc/-/archive/${MY_PV}/${MY_P}.tar.gz
- https://github.com/swaywm/wlroots/releases/download/${WL_PV}/${WL_P}.tar.gz
+ https://source.puri.sm/Librem5/wlroots/-/archive/${WL_COMMIT}/${WL_P}.tar.gz
"
LICENSE="GPL-3"
@@ -44,6 +44,7 @@ RDEPEND="
x11-libs/xcb-util-wm
x11-wm/mutter
sys-auth/seatd
+ !gui-libs/wlroots
"
BDEPEND="
@@ -52,9 +53,9 @@ BDEPEND="
virtual/pkgconfig
x11-base/xorg-server
"
+
PATCHES=(
"${FILESDIR}/0001-seat-Don-t-notify-on-key-release.patch"
- "${FILESDIR}/0002-seat-inhibit-touch-events-when-in-power-save-mode-or.patch"
)
S="${WORKDIR}/${MY_P}"
@@ -66,7 +67,6 @@ src_prepare() {
cd "${S}"/subprojects/wlroots
eapply "${FILESDIR}"/xcursor-fix-false-positive-stringop-truncation.diff
- eapply "${FILESDIR}"/Revert-layer-shell-error-on-0-dimension-without-anchors.diff
}