aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Moone <gentoo@chaoslab.org>2018-12-09 16:25:27 +0000
committerAnthony G. Basile <blueness@gentoo.org>2018-12-09 14:27:35 -0500
commitad6b86d88511beadfbcb3965855ff2b6fb7f7f73 (patch)
treeb634bc643b6a70d057864711104fbce7bb276340 /app-admin/mongo-tools/mongo-tools-3.0.14.ebuild
parentdev-qt/qtnetwork: Sync with main tree; Drop 5.11.2 (diff)
downloadlibressl-ad6b86d88511beadfbcb3965855ff2b6fb7f7f73.tar.gz
libressl-ad6b86d88511beadfbcb3965855ff2b6fb7f7f73.tar.bz2
libressl-ad6b86d88511beadfbcb3965855ff2b6fb7f7f73.zip
Drop =app-admin/mongo-tools-3.0.14
Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Diffstat (limited to 'app-admin/mongo-tools/mongo-tools-3.0.14.ebuild')
-rw-r--r--app-admin/mongo-tools/mongo-tools-3.0.14.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/app-admin/mongo-tools/mongo-tools-3.0.14.ebuild b/app-admin/mongo-tools/mongo-tools-3.0.14.ebuild
deleted file mode 100644
index b9b001a..0000000
--- a/app-admin/mongo-tools/mongo-tools-3.0.14.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils
-
-MY_PV=${PV/_rc/-rc}
-MY_P=${PN}-r${MY_PV}
-
-DESCRIPTION="A high-performance, open source, schema-free document-oriented database"
-HOMEPAGE="http://www.mongodb.org"
-SRC_URI="https://github.com/mongodb/mongo-tools/archive/r${MY_PV}.tar.gz -> mongo-tools-${MY_PV}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="sasl ssl libressl"
-
-# Maintainer note:
-# openssl DEPEND constraint, see:
-# https://github.com/mongodb/mongo-tools/issues/11
-
-RDEPEND="!<dev-db/mongodb-3.0.0"
-DEPEND="${RDEPEND}
- dev-lang/go:=
- sasl? ( dev-libs/cyrus-sasl )
- ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- )
-"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- # ensure we use bash wrt #582906
- sed -e 's@/bin/sh@/bin/bash@g' -i build.sh || die
-}
-
-src_compile() {
- local myconf
-
- if use sasl; then
- myconf="${myconf} sasl"
- fi
-
- if use ssl; then
- myconf="${myconf} ssl"
- fi
-
- ./build.sh ${myconf} || die "build failed"
-}
-
-src_install() {
- dobin bin/*
-}