aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAric Belsito <lluixhi@gmail.com>2016-03-07 20:27:11 -0800
committerAric Belsito <lluixhi@gmail.com>2016-03-07 20:27:11 -0800
commit6249b350e2d05e7657322fd6d4129d4e90a31a20 (patch)
treec6932db7939fc0f380829c86f0e4e1ae5bfefb80 /app-crypt
parentmail-mta/postfix: libressl support in tree (diff)
downloadlibressl-6249b350e2d05e7657322fd6d4129d4e90a31a20.tar.gz
libressl-6249b350e2d05e7657322fd6d4129d4e90a31a20.tar.bz2
libressl-6249b350e2d05e7657322fd6d4129d4e90a31a20.zip
Add chntpw with libressl USE flag.
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/chntpw/Manifest1
-rw-r--r--app-crypt/chntpw/chntpw-140201.ebuild53
-rw-r--r--app-crypt/chntpw/metadata.xml8
3 files changed, 62 insertions, 0 deletions
diff --git a/app-crypt/chntpw/Manifest b/app-crypt/chntpw/Manifest
new file mode 100644
index 0000000..d3b8857
--- /dev/null
+++ b/app-crypt/chntpw/Manifest
@@ -0,0 +1 @@
+DIST chntpw-source-140201.zip 1404098 SHA256 96e20905443e24cba2f21e51162df71dd993a1c02bfa12b1be2d0801a4ee2ccc SHA512 a26d747f6e077d1bb3e9b8077781f8c37dd978e07b7426495862f15c9004572b706c34736fc4d1ed8856b1a43335d726b4d87c688f7f9a11fd6cc3a74d71a7fa WHIRLPOOL 87284c123d2ae1965d069d4d97cda23ce757305b3521f84089e43a9f1fa8aaa48f8fbad5bba19b3a439cfb16d270e0f77f528664fdba895c65c100492eb9e42a
diff --git a/app-crypt/chntpw/chntpw-140201.ebuild b/app-crypt/chntpw/chntpw-140201.ebuild
new file mode 100644
index 0000000..3f62535
--- /dev/null
+++ b/app-crypt/chntpw/chntpw-140201.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Offline Windows NT Password & Registry Editor"
+HOMEPAGE="http://pogostick.net/~pnh/ntpasswd/"
+SRC_URI="http://pogostick.net/~pnh/ntpasswd/${PN}-source-${PV}.zip"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="static"
+
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl )"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ static? (
+ !libressl? ( dev-libs/openssl:0[static-libs] )
+ libressl? ( dev-libs/libressl[static-libs] )
+ )"
+
+src_prepare() {
+ sed -i -e '/-o/s:$(CC):$(CC) $(LDFLAGS):' Makefile || die
+
+ if ! use static ; then
+ sed -i -e "/^all:/s/ \(chntpw\|reged\).static//g" Makefile || die
+ fi
+
+ emake clean
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} -DUSEOPENSSL -Wall" \
+ LIBS="-lcrypto"
+}
+
+src_install() {
+ dobin chntpw cpnt reged
+
+ if use static; then
+ dobin {chntpw,reged}.static
+ fi
+
+ dodoc {HISTORY,README,regedit,WinReg}.txt
+}
diff --git a/app-crypt/chntpw/metadata.xml b/app-crypt/chntpw/metadata.xml
new file mode 100644
index 0000000..040cba5
--- /dev/null
+++ b/app-crypt/chntpw/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>crypto@gentoo.org</email>
+ <name>Crypto</name>
+ </maintainer>
+</pkgmetadata>