aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorQuentin Retornaz <caseoffr@outlook.com>2018-04-02 18:42:17 +0200
committerAnthony G. Basile <blueness@gentoo.org>2018-04-02 15:31:41 -0400
commit2d05b32fd543a1ce03ed2357da4b43ef4b605d91 (patch)
tree815b3cea29f0a9a2087f669cb9e1e065d4afbb49 /dev-lang/python/files/python-2.7.5-nonfatal-compileall.patch
parentadd support for libressl 2.7.x #651174 (diff)
downloadlibressl-2d05b32fd543a1ce03ed2357da4b43ef4b605d91.tar.gz
libressl-2d05b32fd543a1ce03ed2357da4b43ef4b605d91.tar.bz2
libressl-2d05b32fd543a1ce03ed2357da4b43ef4b605d91.zip
add support for libressl 2.7.x #651162
Diffstat (limited to 'dev-lang/python/files/python-2.7.5-nonfatal-compileall.patch')
-rw-r--r--dev-lang/python/files/python-2.7.5-nonfatal-compileall.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-lang/python/files/python-2.7.5-nonfatal-compileall.patch b/dev-lang/python/files/python-2.7.5-nonfatal-compileall.patch
new file mode 100644
index 0000000..a762dfb
--- /dev/null
+++ b/dev-lang/python/files/python-2.7.5-nonfatal-compileall.patch
@@ -0,0 +1,18 @@
+diff --git a/Makefile.pre.in b/Makefile.pre.in
+--- a/Makefile.pre.in
++++ b/Makefile.pre.in
+@@ -1000,12 +1000,12 @@
+ $(INSTALL_DATA) $(srcdir)/Modules/xxmodule.c \
+ $(DESTDIR)$(LIBDEST)/distutils/tests ; \
+ fi
+- PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
++ -PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
+ $(PYTHON_FOR_BUILD) -Wi -tt $(DESTDIR)$(LIBDEST)/compileall.py \
+ -d $(LIBDEST) -f \
+ -x 'bad_coding|badsyntax|site-packages|lib2to3/tests/data' \
+ $(DESTDIR)$(LIBDEST)
+- PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
++ -PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
+ $(PYTHON_FOR_BUILD) -Wi -tt -O $(DESTDIR)$(LIBDEST)/compileall.py \
+ -d $(LIBDEST) -f \
+ -x 'bad_coding|badsyntax|site-packages|lib2to3/tests/data' \