aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno <hanno@gentoo.org>2014-07-18 00:30:38 +0200
committerHanno <hanno@gentoo.org>2014-07-18 00:30:38 +0200
commitcd1a8e7e46cc0d4c66e72fd6d5a26b3448684f6f (patch)
tree88d845431af1e05a9132ca6cf4ed1018985d82eb /dev-lang/python/files/python-2.7.5-nonfatal-compileall.patch
parentadd links (diff)
downloadlibressl-cd1a8e7e46cc0d4c66e72fd6d5a26b3448684f6f.tar.gz
libressl-cd1a8e7e46cc0d4c66e72fd6d5a26b3448684f6f.tar.bz2
libressl-cd1a8e7e46cc0d4c66e72fd6d5a26b3448684f6f.zip
add python with patches for 2.7, 3.3 and 3.4
Diffstat (limited to 'dev-lang/python/files/python-2.7.5-nonfatal-compileall.patch')
-rw-r--r--dev-lang/python/files/python-2.7.5-nonfatal-compileall.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-lang/python/files/python-2.7.5-nonfatal-compileall.patch b/dev-lang/python/files/python-2.7.5-nonfatal-compileall.patch
new file mode 100644
index 0000000..a762dfb
--- /dev/null
+++ b/dev-lang/python/files/python-2.7.5-nonfatal-compileall.patch
@@ -0,0 +1,18 @@
+diff --git a/Makefile.pre.in b/Makefile.pre.in
+--- a/Makefile.pre.in
++++ b/Makefile.pre.in
+@@ -1000,12 +1000,12 @@
+ $(INSTALL_DATA) $(srcdir)/Modules/xxmodule.c \
+ $(DESTDIR)$(LIBDEST)/distutils/tests ; \
+ fi
+- PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
++ -PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
+ $(PYTHON_FOR_BUILD) -Wi -tt $(DESTDIR)$(LIBDEST)/compileall.py \
+ -d $(LIBDEST) -f \
+ -x 'bad_coding|badsyntax|site-packages|lib2to3/tests/data' \
+ $(DESTDIR)$(LIBDEST)
+- PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
++ -PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
+ $(PYTHON_FOR_BUILD) -Wi -tt -O $(DESTDIR)$(LIBDEST)/compileall.py \
+ -d $(LIBDEST) -f \
+ -x 'bad_coding|badsyntax|site-packages|lib2to3/tests/data' \