aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAric Belsito <lluixhi@gmail.com>2017-04-18 11:29:41 -0700
committerAric Belsito <lluixhi@gmail.com>2017-04-18 11:30:25 -0700
commit50a73cd3f7e933fe24f844a4f2175c94d913c618 (patch)
tree351cc21ee1991e6b3e988b312928300adad2f172 /media-video/ffmpeg
parentmedia-video/ffmpeg: version bump to 3.3 (diff)
downloadlibressl-50a73cd3f7e933fe24f844a4f2175c94d913c618.tar.gz
libressl-50a73cd3f7e933fe24f844a4f2175c94d913c618.tar.bz2
libressl-50a73cd3f7e933fe24f844a4f2175c94d913c618.zip
media-video/ffmpeg: sync with upstream
Diffstat (limited to 'media-video/ffmpeg')
-rw-r--r--media-video/ffmpeg/ffmpeg-3.3.ebuild23
1 files changed, 19 insertions, 4 deletions
diff --git a/media-video/ffmpeg/ffmpeg-3.3.ebuild b/media-video/ffmpeg/ffmpeg-3.3.ebuild
index 8f9237c..35c61ae 100644
--- a/media-video/ffmpeg/ffmpeg-3.3.ebuild
+++ b/media-video/ffmpeg/ffmpeg-3.3.ebuild
@@ -54,7 +54,7 @@ LICENSE="
samba? ( GPL-3 )
"
if [ "${PV#9999}" = "${PV}" ] ; then
- KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+ KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
fi
# Options to use as use_enable in the foo[:bar] form.
@@ -103,8 +103,23 @@ IUSE="
# Strings for CPU features in the useflag[:configure_option] form
# if :configure_option isn't set, it will use 'useflag' as configure option
-ARM_CPU_FEATURES=( armv5te armv6 armv6t2 neon armvfp:vfp )
-ARM_CPU_REQUIRED_USE="arm64? ( armvfp neon )"
+ARM_CPU_FEATURES=(
+ cpu_flags_arm_thumb:armv5te
+ cpu_flags_arm_v6:armv6
+ cpu_flags_arm_thumb2:armv6t2
+ cpu_flags_arm_neon:neon
+ cpu_flags_arm_vfp:vfp
+ cpu_flags_arm_vfpv3:vfpv3
+ cpu_flags_arm_v8:armv8
+)
+ARM_CPU_REQUIRED_USE="
+ arm64? ( cpu_flags_arm_v8 )
+ cpu_flags_arm_v8? ( cpu_flags_arm_vfpv3 cpu_flags_arm_neon )
+ cpu_flags_arm_neon? ( cpu_flags_arm_thumb2 cpu_flags_arm_vfp )
+ cpu_flags_arm_vfpv3? ( cpu_flags_arm_vfp )
+ cpu_flags_arm_thumb2? ( cpu_flags_arm_v6 )
+ cpu_flags_arm_v6? ( cpu_flags_arm_thumb )
+"
MIPS_CPU_FEATURES=( mipsdspr1 mipsdspr2 mipsfpu )
PPC_CPU_FEATURES=( altivec )
X86_CPU_FEATURES_RAW=( 3dnow:amd3dnow 3dnowext:amd3dnowext aes:aesni avx:avx avx2:avx2 fma3:fma3 fma4:fma4 mmx:mmx mmxext:mmxext sse:sse sse2:sse2 sse3:sse3 ssse3:ssse3 sse4_1:sse4 sse4_2:sse42 xop:xop )
@@ -392,7 +407,7 @@ multilib_src_configure() {
# cross compile support
if tc-is-cross-compiler ; then
- myconf+=( --enable-cross-compile --arch=$(tc-arch-kernel) --cross-prefix=${CHOST}- )
+ myconf+=( --enable-cross-compile --arch=$(tc-arch-kernel) --cross-prefix=${CHOST}- --host-cc="$(tc-getBUILD_CC)" )
case ${CHOST} in
*freebsd*)
myconf+=( --target-os=freebsd )