aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Moone <gentoo@chaoslab.org>2018-12-08 05:39:57 +0000
committerAnthony G. Basile <blueness@gentoo.org>2018-12-08 06:11:51 -0500
commit6d6a39057fe11e64c6c8e43e37f84c9c5ab670ce (patch)
tree652d35852c2b8c929255cd5096a314423d3d203d /media-video
parentmedia-video/ffmpeg: Drop versions not in main tree (diff)
downloadlibressl-6d6a39057fe11e64c6c8e43e37f84c9c5ab670ce.tar.gz
libressl-6d6a39057fe11e64c6c8e43e37f84c9c5ab670ce.tar.bz2
libressl-6d6a39057fe11e64c6c8e43e37f84c9c5ab670ce.zip
media-video/ffmpeg: Remove celt, schroedinger and arm-linux
The packages for 'celt' and 'schroedinger' was dropped from main tree. Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/ffmpeg/ffmpeg-3.2.6.ebuild12
-rw-r--r--media-video/ffmpeg/ffmpeg-3.2.7.ebuild12
-rw-r--r--media-video/ffmpeg/ffmpeg-3.3.4.ebuild12
-rw-r--r--media-video/ffmpeg/ffmpeg-3.3.6.ebuild12
-rw-r--r--media-video/ffmpeg/metadata.xml2
5 files changed, 24 insertions, 26 deletions
diff --git a/media-video/ffmpeg/ffmpeg-3.2.6.ebuild b/media-video/ffmpeg/ffmpeg-3.2.6.ebuild
index 6a4b96a..73bec86 100644
--- a/media-video/ffmpeg/ffmpeg-3.2.6.ebuild
+++ b/media-video/ffmpeg/ffmpeg-3.2.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -54,7 +54,7 @@ LICENSE="
samba? ( GPL-3 )
"
if [ "${PV#9999}" = "${PV}" ] ; then
- KEYWORDS="alpha amd64 arm ~hppa ia64 ~mips ~ppc ~ppc64 x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+ KEYWORDS="alpha amd64 arm ~hppa ia64 ~mips ~ppc ~ppc64 x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
fi
# Options to use as use_enable in the foo[:bar] form.
@@ -73,9 +73,9 @@ FFMPEG_FLAG_MAP=(
libv4l:libv4l2 pulseaudio:libpulse
# decoders
amr:libopencore-amrwb amr:libopencore-amrnb fdk:libfdk-aac
- jpeg2k:libopenjpeg bluray:libbluray celt:libcelt gme:libgme gsm:libgsm
+ jpeg2k:libopenjpeg bluray:libbluray gme:libgme gsm:libgsm
mmal modplug:libmodplug opus:libopus libilbc librtmp ssh:libssh
- schroedinger:libschroedinger speex:libspeex vorbis:libvorbis vpx:libvpx
+ speex:libspeex vorbis:libvorbis vpx:libvpx
zvbi:libzvbi
# libavfilter options
bs2b:libbs2b chromaprint ebur128:libebur128 flite:libflite frei0r
@@ -159,7 +159,6 @@ RDEPEND="
bs2b? ( >=media-libs/libbs2b-3.1.0-r1[${MULTILIB_USEDEP}] )
bzip2? ( >=app-arch/bzip2-1.0.6-r4[${MULTILIB_USEDEP}] )
cdio? ( >=dev-libs/libcdio-paranoia-0.90_p1-r1[${MULTILIB_USEDEP}] )
- celt? ( >=media-libs/celt-0.11.1-r1[${MULTILIB_USEDEP}] )
chromaprint? ( >=media-libs/chromaprint-1.2-r1[${MULTILIB_USEDEP}] )
ebur128? ( >=media-libs/libebur128-1.1.0[${MULTILIB_USEDEP}] )
encode? (
@@ -221,7 +220,6 @@ RDEPEND="
librtmp? ( >=media-video/rtmpdump-2.4_p20131018[${MULTILIB_USEDEP}] )
rubberband? ( >=media-libs/rubberband-1.8.1-r1[${MULTILIB_USEDEP}] )
samba? ( >=net-fs/samba-3.6.23-r1[${MULTILIB_USEDEP}] )
- schroedinger? ( >=media-libs/schroedinger-1.0.11-r1[${MULTILIB_USEDEP}] )
sdl? ( media-libs/libsdl2[sound,video,${MULTILIB_USEDEP}] )
speex? ( >=media-libs/speex-1.2_rc1-r1[${MULTILIB_USEDEP}] )
ssh? ( >=net-libs/libssh-0.5.5[${MULTILIB_USEDEP}] )
@@ -391,6 +389,8 @@ multilib_src_configure() {
--enable-avfilter
--enable-avresample
--disable-stripping
+ --disable-libcelt # bug #664158
+ --disable-libschroedinger
"${myconf[@]}"
)
diff --git a/media-video/ffmpeg/ffmpeg-3.2.7.ebuild b/media-video/ffmpeg/ffmpeg-3.2.7.ebuild
index c2bfde2..3636595 100644
--- a/media-video/ffmpeg/ffmpeg-3.2.7.ebuild
+++ b/media-video/ffmpeg/ffmpeg-3.2.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -54,7 +54,7 @@ LICENSE="
samba? ( GPL-3 )
"
if [ "${PV#9999}" = "${PV}" ] ; then
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
fi
# Options to use as use_enable in the foo[:bar] form.
@@ -73,9 +73,9 @@ FFMPEG_FLAG_MAP=(
libv4l:libv4l2 pulseaudio:libpulse
# decoders
amr:libopencore-amrwb amr:libopencore-amrnb fdk:libfdk-aac
- jpeg2k:libopenjpeg bluray:libbluray celt:libcelt gme:libgme gsm:libgsm
+ jpeg2k:libopenjpeg bluray:libbluray gme:libgme gsm:libgsm
mmal modplug:libmodplug opus:libopus libilbc librtmp ssh:libssh
- schroedinger:libschroedinger speex:libspeex vorbis:libvorbis vpx:libvpx
+ speex:libspeex vorbis:libvorbis vpx:libvpx
zvbi:libzvbi
# libavfilter options
bs2b:libbs2b chromaprint ebur128:libebur128 flite:libflite frei0r
@@ -159,7 +159,6 @@ RDEPEND="
bs2b? ( >=media-libs/libbs2b-3.1.0-r1[${MULTILIB_USEDEP}] )
bzip2? ( >=app-arch/bzip2-1.0.6-r4[${MULTILIB_USEDEP}] )
cdio? ( >=dev-libs/libcdio-paranoia-0.90_p1-r1[${MULTILIB_USEDEP}] )
- celt? ( >=media-libs/celt-0.11.1-r1[${MULTILIB_USEDEP}] )
chromaprint? ( >=media-libs/chromaprint-1.2-r1[${MULTILIB_USEDEP}] )
ebur128? ( >=media-libs/libebur128-1.1.0[${MULTILIB_USEDEP}] )
encode? (
@@ -221,7 +220,6 @@ RDEPEND="
librtmp? ( >=media-video/rtmpdump-2.4_p20131018[${MULTILIB_USEDEP}] )
rubberband? ( >=media-libs/rubberband-1.8.1-r1[${MULTILIB_USEDEP}] )
samba? ( >=net-fs/samba-3.6.23-r1[${MULTILIB_USEDEP}] )
- schroedinger? ( >=media-libs/schroedinger-1.0.11-r1[${MULTILIB_USEDEP}] )
sdl? ( media-libs/libsdl2[sound,video,${MULTILIB_USEDEP}] )
speex? ( >=media-libs/speex-1.2_rc1-r1[${MULTILIB_USEDEP}] )
ssh? ( >=net-libs/libssh-0.5.5[${MULTILIB_USEDEP}] )
@@ -391,6 +389,8 @@ multilib_src_configure() {
--enable-avfilter
--enable-avresample
--disable-stripping
+ --disable-libcelt # bug #664158
+ --disable-libschroedinger
"${myconf[@]}"
)
diff --git a/media-video/ffmpeg/ffmpeg-3.3.4.ebuild b/media-video/ffmpeg/ffmpeg-3.3.4.ebuild
index 7732441..8d8ba9c 100644
--- a/media-video/ffmpeg/ffmpeg-3.3.4.ebuild
+++ b/media-video/ffmpeg/ffmpeg-3.3.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -54,7 +54,7 @@ LICENSE="
samba? ( GPL-3 )
"
if [ "${PV#9999}" = "${PV}" ] ; then
- KEYWORDS="amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+ KEYWORDS="amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
fi
# Options to use as use_enable in the foo[:bar] form.
@@ -73,9 +73,9 @@ FFMPEG_FLAG_MAP=(
libv4l:libv4l2 pulseaudio:libpulse
# decoders
amr:libopencore-amrwb amr:libopencore-amrnb fdk:libfdk-aac
- jpeg2k:libopenjpeg bluray:libbluray celt:libcelt gme:libgme gsm:libgsm
+ jpeg2k:libopenjpeg bluray:libbluray gme:libgme gsm:libgsm
mmal modplug:libmodplug opus:libopus libilbc librtmp ssh:libssh
- schroedinger:libschroedinger speex:libspeex vorbis:libvorbis vpx:libvpx
+ speex:libspeex vorbis:libvorbis vpx:libvpx
zvbi:libzvbi
# libavfilter options
bs2b:libbs2b chromaprint flite:libflite frei0r
@@ -176,7 +176,6 @@ RDEPEND="
bs2b? ( >=media-libs/libbs2b-3.1.0-r1[${MULTILIB_USEDEP}] )
bzip2? ( >=app-arch/bzip2-1.0.6-r4[${MULTILIB_USEDEP}] )
cdio? ( >=dev-libs/libcdio-paranoia-0.90_p1-r1[${MULTILIB_USEDEP}] )
- celt? ( >=media-libs/celt-0.11.1-r1[${MULTILIB_USEDEP}] )
chromaprint? ( >=media-libs/chromaprint-1.2-r1[${MULTILIB_USEDEP}] )
encode? (
amrenc? ( >=media-libs/vo-amrwbenc-0.1.2-r1[${MULTILIB_USEDEP}] )
@@ -237,7 +236,6 @@ RDEPEND="
librtmp? ( >=media-video/rtmpdump-2.4_p20131018[${MULTILIB_USEDEP}] )
rubberband? ( >=media-libs/rubberband-1.8.1-r1[${MULTILIB_USEDEP}] )
samba? ( >=net-fs/samba-3.6.23-r1[${MULTILIB_USEDEP}] )
- schroedinger? ( >=media-libs/schroedinger-1.0.11-r1[${MULTILIB_USEDEP}] )
sdl? ( media-libs/libsdl2[sound,video,${MULTILIB_USEDEP}] )
sofalizer? (
>=sci-libs/netcdf-4.3.2-r1[hdf5]
@@ -409,6 +407,8 @@ multilib_src_configure() {
--enable-avfilter
--enable-avresample
--disable-stripping
+ --disable-libcelt # bug #664158
+ --disable-libschroedinger
"${myconf[@]}"
)
diff --git a/media-video/ffmpeg/ffmpeg-3.3.6.ebuild b/media-video/ffmpeg/ffmpeg-3.3.6.ebuild
index 717667e..05e22f8 100644
--- a/media-video/ffmpeg/ffmpeg-3.3.6.ebuild
+++ b/media-video/ffmpeg/ffmpeg-3.3.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -54,7 +54,7 @@ LICENSE="
samba? ( GPL-3 )
"
if [ "${PV#9999}" = "${PV}" ] ; then
- KEYWORDS="amd64 arm ~arm64 ~hppa ia64 ~mips ppc ppc64 x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+ KEYWORDS="amd64 arm ~arm64 ~hppa ia64 ~mips ppc ppc64 x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
fi
# Options to use as use_enable in the foo[:bar] form.
@@ -73,9 +73,9 @@ FFMPEG_FLAG_MAP=(
libv4l:libv4l2 pulseaudio:libpulse
# decoders
amr:libopencore-amrwb amr:libopencore-amrnb fdk:libfdk-aac
- jpeg2k:libopenjpeg bluray:libbluray celt:libcelt gme:libgme gsm:libgsm
+ jpeg2k:libopenjpeg bluray:libbluray gme:libgme gsm:libgsm
mmal modplug:libmodplug opus:libopus libilbc librtmp ssh:libssh
- schroedinger:libschroedinger speex:libspeex vorbis:libvorbis vpx:libvpx
+ speex:libspeex vorbis:libvorbis vpx:libvpx
zvbi:libzvbi
# libavfilter options
bs2b:libbs2b chromaprint flite:libflite frei0r
@@ -176,7 +176,6 @@ RDEPEND="
bs2b? ( >=media-libs/libbs2b-3.1.0-r1[${MULTILIB_USEDEP}] )
bzip2? ( >=app-arch/bzip2-1.0.6-r4[${MULTILIB_USEDEP}] )
cdio? ( >=dev-libs/libcdio-paranoia-0.90_p1-r1[${MULTILIB_USEDEP}] )
- celt? ( >=media-libs/celt-0.11.1-r1[${MULTILIB_USEDEP}] )
chromaprint? ( >=media-libs/chromaprint-1.2-r1[${MULTILIB_USEDEP}] )
encode? (
amrenc? ( >=media-libs/vo-amrwbenc-0.1.2-r1[${MULTILIB_USEDEP}] )
@@ -237,7 +236,6 @@ RDEPEND="
librtmp? ( >=media-video/rtmpdump-2.4_p20131018[${MULTILIB_USEDEP}] )
rubberband? ( >=media-libs/rubberband-1.8.1-r1[${MULTILIB_USEDEP}] )
samba? ( >=net-fs/samba-3.6.23-r1[${MULTILIB_USEDEP}] )
- schroedinger? ( >=media-libs/schroedinger-1.0.11-r1[${MULTILIB_USEDEP}] )
sdl? ( media-libs/libsdl2[sound,video,${MULTILIB_USEDEP}] )
sofalizer? (
>=sci-libs/netcdf-4.3.2-r1[hdf5]
@@ -409,6 +407,8 @@ multilib_src_configure() {
--enable-avfilter
--enable-avresample
--disable-stripping
+ --disable-libcelt # bug #664158
+ --disable-libschroedinger
"${myconf[@]}"
)
diff --git a/media-video/ffmpeg/metadata.xml b/media-video/ffmpeg/metadata.xml
index c502f6b..8f22679 100644
--- a/media-video/ffmpeg/metadata.xml
+++ b/media-video/ffmpeg/metadata.xml
@@ -15,7 +15,6 @@
<flag name="bluray">Enable playback of Blu-ray filesystems</flag>
<flag name="bs2b">Enables <pkg>media-libs/libbs2b</pkg> based Bauer stereo-to-binaural filter.</flag>
<flag name="cdio">Enables audio CD grabbing with <pkg>dev-libs/libcdio</pkg>.</flag>
- <flag name="celt">Adds Xiph CELT audio decoding support via <pkg>media-libs/celt</pkg></flag>
<flag name="chromaprint">Enables audio fingerprinting support with <pkg>media-libs/chromaprint</pkg>.</flag>
<flag name="chromium">Builds libffmpeg.so to enable media playback in Chromium-based browsers like Opera and Vivaldi.</flag>
<flag name="cpudetection">Enables runtime CPU detection (useful for bindist, compatibility on other CPUs)</flag>
@@ -48,7 +47,6 @@
<flag name="pic">Force shared libraries to be built as PIC (this is slower)</flag>
<flag name="postproc">Build and install libpostproc.</flag>
<flag name="rubberband">Adds time-stretching and pitch-shifting audio filter based on <pkg>media-libs/rubberband</pkg>.</flag>
- <flag name="schroedinger">Enable Dirac video support (an advanced royalty-free video compression format) via libschroedinger (high-speed implementation in C of the Dirac codec).</flag>
<flag name="snappy">Enable <pkg>app-arch/snappy</pkg> support. Required for e.g. Vidvox Hap encoder.</flag>
<flag name="sofalizer">Enables Sofalizer filter</flag>
<flag name="ssh">Enable SSH/sftp support via <pkg>net-libs/libssh</pkg>.</flag>