aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhasufell <hasufell@hasufell.de>2015-02-02 15:14:58 +0100
committerhasufell <hasufell@hasufell.de>2015-02-02 15:15:42 +0100
commit5852f9a86efce7926310ecebf3d9a84f0f160ac7 (patch)
tree265c6c2bd8873908bbe9a2070aa4c5e43a6c4a23 /net-libs
parentMerge branch 'master' of git://github.com/hasufell/libressl (diff)
downloadlibressl-5852f9a86efce7926310ecebf3d9a84f0f160ac7.tar.gz
libressl-5852f9a86efce7926310ecebf3d9a84f0f160ac7.tar.bz2
libressl-5852f9a86efce7926310ecebf3d9a84f0f160ac7.zip
net-libs/gloox: initial import of 1.0.13
This releae fixes libressl compatibility.
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gloox/Manifest1
-rw-r--r--net-libs/gloox/gloox-1.0.13.ebuild52
-rw-r--r--net-libs/gloox/metadata.xml13
3 files changed, 66 insertions, 0 deletions
diff --git a/net-libs/gloox/Manifest b/net-libs/gloox/Manifest
new file mode 100644
index 0000000..e41092b
--- /dev/null
+++ b/net-libs/gloox/Manifest
@@ -0,0 +1 @@
+DIST gloox-1.0.13.tar.bz2 675842 SHA256 4d9f1eeac97c6563dde11d4bdba346a025ef27908b088b47b5c8d3d03df6ea8a SHA512 9f9773a5c3d2ae8a4eec6e8365c8578c089004d0f5101c2e8a8bf96ac8e8b6a08cf4e92f93afb8d07af0e8cc2c238c12f4f8df75a81c2a06dfb039c1d4ae850a WHIRLPOOL 772b18a22acff536abb378a4307c6dcb3b9b35b231d061f05b22d5cb260d8da3c0356bdbca0a8cac9feab0fbc9124bc41472b91a335215291e1e66a9184ccc78
diff --git a/net-libs/gloox/gloox-1.0.13.ebuild b/net-libs/gloox/gloox-1.0.13.ebuild
new file mode 100644
index 0000000..dd2afa6
--- /dev/null
+++ b/net-libs/gloox/gloox-1.0.13.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gloox/gloox-1.0.12.ebuild,v 1.1 2014/11/26 02:42:58 mrueg Exp $
+
+EAPI=5
+
+inherit eutils
+
+MY_P="${P/_/-}"
+DESCRIPTION="A portable high-level Jabber/XMPP library for C++"
+HOMEPAGE="http://camaya.net/gloox"
+SRC_URI="http://camaya.net/download/${MY_P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0/13"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="debug gnutls idn libressl ssl static-libs test zlib"
+REQUIRED_USE="?? ( gnutls libressl )"
+
+DEPEND="idn? ( net-dns/libidn )
+ ssl? (
+ gnutls? ( net-libs/gnutls )
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl:= )
+ )
+ zlib? ( sys-libs/zlib )"
+
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch_user
+}
+
+src_configure() {
+ # Examples are not installed anyway, so - why should we build them?
+ econf \
+ --without-examples \
+ $(use debug && echo "--enable-debug") \
+ $(use_enable static-libs static) \
+ $(use_with idn libidn) \
+ $(usex ssl "$(use_with gnutls)" "--without-gnutls") \
+ $(use_with ssl openssl) \
+ $(use_with test tests) \
+ $(use_with zlib)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/net-libs/gloox/metadata.xml b/net-libs/gloox/metadata.xml
new file mode 100644
index 0000000..666a7d4
--- /dev/null
+++ b/net-libs/gloox/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>hasufell@gentoo.org</email>
+ <name>Julian Ospald</name>
+ </maintainer>
+ <use>
+ <flag name="gnutls">Use <pkg>net-libs/gnutls</pkg> as ssl-provider
+ instead of libressl/openssl.
+ </flag>
+ </use>
+</pkgmetadata>