aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2023-03-06 10:02:23 -0800
committerQuentin Retornaz <gentoo@retornaz.com>2023-03-10 23:43:43 +0100
commit3fbd14ccf6728fc56086f04fa6c5480efd8c9153 (patch)
tree5ae07d320d786911cca1b06d0cbad1420c1a98b1 /net-misc
parentapp-emulation/spice: Merge ::gentoo changes (diff)
downloadlibressl-3fbd14ccf6728fc56086f04fa6c5480efd8c9153.tar.gz
libressl-3fbd14ccf6728fc56086f04fa6c5480efd8c9153.tar.bz2
libressl-3fbd14ccf6728fc56086f04fa6c5480efd8c9153.zip
net-misc/socat: New package
socat-1.7.4.3 works with libressl in the ::gentoo repo. Signed-off-by: orbea <orbea@riseup.net> Closes: https://github.com/gentoo/libressl/pull/502 Signed-off-by: Quentin Retornaz <gentoo@retornaz.com>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/socat/Manifest1
-rw-r--r--net-misc/socat/metadata.xml15
-rw-r--r--net-misc/socat/socat-1.7.4.4.ebuild61
3 files changed, 77 insertions, 0 deletions
diff --git a/net-misc/socat/Manifest b/net-misc/socat/Manifest
new file mode 100644
index 0000000..13d9ff4
--- /dev/null
+++ b/net-misc/socat/Manifest
@@ -0,0 +1 @@
+DIST socat-1.7.4.4.tar.bz2 522127 BLAKE2B 221b1c7c1ef0ac9c2402a6917ce7740a7ed857ceae4f4c346ed3c69c261fd0f9ca667e21cab5f97427d3947b06fdb0ac6d090852465878db968a24b8ece587ad SHA512 3eedfbf599ecf1d6fd391d03d710044bc5e18a762395bc4cb151b96fe673d405a6630da3070ecddd5ac558126b56aa65feaa74d528eeb755a04aa0ec61690651
diff --git a/net-misc/socat/metadata.xml b/net-misc/socat/metadata.xml
new file mode 100644
index 0000000..001f8b0
--- /dev/null
+++ b/net-misc/socat/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>netmon@gentoo.org</email>
+ <name>Gentoo network monitoring and analysis project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpe">cpe:/a:dest-unreach:socat</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-misc/socat/socat-1.7.4.4.ebuild b/net-misc/socat/socat-1.7.4.4.ebuild
new file mode 100644
index 0000000..ef8236e
--- /dev/null
+++ b/net-misc/socat/socat-1.7.4.4.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+MY_P=${P/_beta/-b}
+DESCRIPTION="Multipurpose relay (SOcket CAT)"
+HOMEPAGE="http://www.dest-unreach.org/socat/ https://repo.or.cz/socat.git"
+SRC_URI="http://www.dest-unreach.org/socat/download/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="bindist ipv6 readline ssl tcpd"
+
+DEPEND="ssl? ( dev-libs/openssl:0= )
+ readline? ( sys-libs/readline:= )
+ tcpd? ( sys-apps/tcp-wrappers )"
+RDEPEND="${DEPEND}"
+
+# Tests are a large bash script
+# Hard to disable individual tests needing network or privileges
+# in 1.7.4.2: FAILED: 59 329
+RESTRICT="test ssl? ( readline? ( bindist ) )"
+
+DOCS=( BUGREPORTS CHANGES DEVELOPMENT EXAMPLES FAQ FILES PORTING README SECURITY )
+
+pkg_setup() {
+ # bug #587740
+ if use readline && use ssl ; then
+ elog "You are enabling both readline and ssl (openssl) USE flags, the licenses"
+ elog "for these packages conflict. You may not be able to legally"
+ elog "redistribute the resulting binary."
+ fi
+}
+
+src_configure() {
+ # bug #293324
+ filter-flags '-Wno-error*'
+
+ tc-export AR
+
+ # libressl doesn't have OPENSSL_INIT_new()
+ export ac_cv_func_OPENSSL_init_ssl=no
+
+ econf \
+ $(use_enable ssl openssl) \
+ $(use_enable readline) \
+ $(use_enable ipv6 ip6) \
+ $(use_enable tcpd libwrap)
+}
+
+src_install() {
+ default
+
+ docinto html
+ dodoc doc/*.html doc/*.css
+}