aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2022-07-02 19:45:02 -0700
committerQuentin Retornaz <gentoo@retornaz.com>2022-07-03 19:47:00 +0200
commit7bdec3e9fcddc21a864e41d542ef7343ef518420 (patch)
tree95ab4f5b8b422ba89df9e923749ae64dfc261e76 /net-misc
parentnet-libs/wvstreams: Remove package (diff)
downloadlibressl-7bdec3e9fcddc21a864e41d542ef7343ef518420.tar.gz
libressl-7bdec3e9fcddc21a864e41d542ef7343ef518420.tar.bz2
libressl-7bdec3e9fcddc21a864e41d542ef7343ef518420.zip
net-misc/aria2: Remove package
Works with libressl-3.5.x and aria2-1.36.0::gentoo. Signed-off-by: orbea <orbea@riseup.net> Signed-off-by: Quentin Retornaz <gentoo@retornaz.com>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/aria2/Manifest1
-rw-r--r--net-misc/aria2/aria2-1.34.0-r1.ebuild156
-rw-r--r--net-misc/aria2/files/aria2-1.34.0-make_unique.patch44
-rw-r--r--net-misc/aria2/files/aria2-1.34.0-mask-headers.patch46
-rw-r--r--net-misc/aria2/files/aria2-libressl.patch13
-rw-r--r--net-misc/aria2/metadata.xml25
6 files changed, 0 insertions, 285 deletions
diff --git a/net-misc/aria2/Manifest b/net-misc/aria2/Manifest
deleted file mode 100644
index f26538b..0000000
--- a/net-misc/aria2/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST aria2-1.34.0.tar.xz 1525908 BLAKE2B 479145af229f5fe864e54c511197bedb306199dbda608416aa295930a8392c7a118993b5a1634db20b380ab448cc8a397a351b6b64560ca263a0818d47a1ae64 SHA512 80bc43e242c06acc95030021cb347b4ec230729f3d7e512ca1932941b34ef95c312a34007a226869e5d720839a400e66cdb072ccab5d42228d8cf3d828723dcc
diff --git a/net-misc/aria2/aria2-1.34.0-r1.ebuild b/net-misc/aria2/aria2-1.34.0-r1.ebuild
deleted file mode 100644
index 3b0c69c..0000000
--- a/net-misc/aria2/aria2-1.34.0-r1.ebuild
+++ /dev/null
@@ -1,156 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit bash-completion-r1
-
-DESCRIPTION="A download utility with segmented downloading with BitTorrent support"
-HOMEPAGE="https://aria2.github.io/"
-SRC_URI="https://github.com/aria2/${PN}/releases/download/release-${PV}/${P}.tar.xz"
-
-LICENSE="GPL-2"
-KEYWORDS="amd64 ~arm ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
-SLOT="0"
-IUSE="adns bittorrent +gnutls jemalloc libuv +libxml2 metalink +nettle nls sqlite scripts ssh ssl tcmalloc test xmlrpc"
-
-CDEPEND="sys-libs/zlib:0=
- ssl? (
- app-misc/ca-certificates
- gnutls? ( >=net-libs/gnutls-1.2.9:0= )
- !gnutls? ( dev-libs/openssl:0= ) )
- adns? ( >=net-dns/c-ares-1.5.0:0= )
- bittorrent? (
- ssl? (
- gnutls? (
- nettle? ( >=dev-libs/nettle-2.4:0=[gmp] >=dev-libs/gmp-6:0= )
- !nettle? ( >=dev-libs/libgcrypt-1.2.2:0= ) ) )
- !ssl? (
- nettle? ( >=dev-libs/nettle-2.4:0=[gmp] >=dev-libs/gmp-6:0= )
- !nettle? ( >=dev-libs/libgcrypt-1.2.2:0= ) ) )
- jemalloc? ( dev-libs/jemalloc )
- libuv? ( >=dev-libs/libuv-1.13:0= )
- metalink? (
- libxml2? ( >=dev-libs/libxml2-2.6.26:2= )
- !libxml2? ( dev-libs/expat:0= ) )
- sqlite? ( dev-db/sqlite:3= )
- ssh? ( net-libs/libssh2:= )
- tcmalloc? ( dev-util/google-perftools )
- xmlrpc? (
- libxml2? ( >=dev-libs/libxml2-2.6.26:2= )
- !libxml2? ( dev-libs/expat:0= ) )"
-
-DEPEND="${CDEPEND}
- app-arch/xz-utils
- virtual/pkgconfig
- nls? ( sys-devel/gettext )
- test? ( >=dev-util/cppunit-1.12.0:0 )"
-RDEPEND="${CDEPEND}
- nls? ( virtual/libiconv virtual/libintl )
- scripts? ( dev-lang/ruby )"
-
-# xmlrpc has no explicit switch, it's turned out by any XML library
-# so metalink implicitly forces it on
-REQUIRED_USE="?? ( jemalloc tcmalloc )
- metalink? ( xmlrpc )"
-RESTRICT="!test? ( test )"
-
-pkg_setup() {
- if use scripts && ! use xmlrpc; then
- ewarn "Please note that you may need to enable USE=xmlrpc to run the aria2rpc"
- ewarn "and aria2mon scripts against the local aria2."
- fi
-}
-
-src_prepare() {
- eapply "${FILESDIR}"/${P}-make_unique.patch
- # https://bugs.gentoo.org/674622 (CVE-2019-3500)
- eapply "${FILESDIR}"/${P}-mask-headers.patch
- eapply "${FILESDIR}"/aria2-libressl.patch
- default
- sed -i -e "s|/tmp|${T}|" test/*.cc test/*.txt || die "sed failed"
-}
-
-src_configure() {
- local myconf=(
- # threads, epoll: check for best portability
-
- # do not try to compile and run a test LIBXML program
- --disable-xmltest
- # enable the shared library
- --enable-libaria2
- # zlib should always be available anyway
- --with-libz
- --with-ca-bundle="${EPREFIX}/etc/ssl/certs/ca-certificates.crt"
-
- # optional features
- $(use_enable bittorrent)
- $(use_enable metalink)
- $(use_enable nls)
- $(use_with adns libcares)
- $(use_with jemalloc)
- $(use_with libuv)
- $(use_with sqlite sqlite3)
- $(use_with ssh libssh2)
- $(use_with tcmalloc)
- )
-
- # SSL := gnutls / openssl
- # USE=ssl
- # + USE=gnutls -> gnutls
- # + USE=-gnutls -> openssl
-
- if use ssl; then
- myconf+=( $(use_with gnutls) $(use_with !gnutls openssl) )
- else
- myconf+=( --without-gnutls --without-openssl )
- fi
-
- # message-digest := nettle / gcrypt / openssl
- # bignum := nettle+gmp / gcrypt / openssl
- # bittorrent := message-digest + bignum
- # USE=bittorrent
- # + USE=(ssl -gnutls) -> openssl
- # + USE=nettle -> nettle+gmp
- # + USE=-nettle -> gcrypt
-
- if use !bittorrent || use ssl && use !gnutls; then
- myconf+=( --without-libgcrypt --without-libnettle --without-libgmp )
- else
- myconf+=( $(use_with !nettle libgcrypt)
- $(use_with nettle libnettle) $(use_with nettle libgmp) )
- fi
-
- # metalink+xmlrpc := libxml2 / expat
- # USE=(metalink || xmlrpc)
- # + USE=libxml2 -> libxml2
- # + USE=-libxml2 -> expat
-
- if use metalink || use xmlrpc; then
- myconf+=( $(use_with !libxml2 libexpat) $(use_with libxml2) )
- else
- myconf+=( --without-libexpat --without-libxml2 )
- fi
-
- # Note:
- # - always enable gzip/http compression since zlib should always be available anyway
- # - always enable epoll since we can assume kernel 2.6.x
- # - other options for threads: solaris, pth, win32
- econf "${myconf[@]}"
-}
-
-src_install() {
- default
- rm -rf "${D}"/usr/share/doc/aria2 \
- "${D}"/usr/share/doc/${PF}/README{,.html}
-
- dobashcomp doc/bash_completion/aria2c
- use scripts && dobin doc/xmlrpc/aria2{mon,rpc}
-}
-
-pkg_postinst() {
- if use xmlrpc; then
- elog "If you would like to use the additional aria2mon and aria2rpc tools,"
- elog "you need to have \033[1mdev-lang/ruby\033[0m installed."
- fi
-}
diff --git a/net-misc/aria2/files/aria2-1.34.0-make_unique.patch b/net-misc/aria2/files/aria2-1.34.0-make_unique.patch
deleted file mode 100644
index 448d6cf..0000000
--- a/net-misc/aria2/files/aria2-1.34.0-make_unique.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-From e8e04d6f22a507e8374651d3d2343cd9fb986993 Mon Sep 17 00:00:00 2001
-From: Tatsuhiro Tsujikawa <tatsuhiro.t@gmail.com>
-Date: Thu, 17 May 2018 18:39:44 +0900
-Subject: [PATCH] Fix build failure when InternalDHKeyExchange is used
-
----
- src/bignum.h | 10 ++++++----
- 1 file changed, 6 insertions(+), 4 deletions(-)
-
-diff --git a/src/bignum.h b/src/bignum.h
-index e59ab6bbf..5fb4402bc 100644
---- a/src/bignum.h
-+++ b/src/bignum.h
-@@ -19,6 +19,8 @@
- #include <memory>
- #include <stdint.h>
-
-+#include "a2functional.h"
-+
- namespace bignum {
-
- template <size_t dim> class ulong {
-@@ -31,17 +33,17 @@ template <size_t dim> class ulong {
- std::unique_ptr<char_t[]> buf_;
-
- public:
-- inline ulong() : buf_(make_unique<char_t[]>(dim)) {}
-- inline ulong(size_t t) : buf_(make_unique<char_t[]>(dim))
-+ inline ulong() : buf_(aria2::make_unique<char_t[]>(dim)) {}
-+ inline ulong(size_t t) : buf_(aria2::make_unique<char_t[]>(dim))
- {
- memcpy(buf_.get(), (char_t*)&t, sizeof(t));
- }
-- inline ulong(const ulong<dim>& rhs) : buf_(make_unique<char_t[]>(dim))
-+ inline ulong(const ulong<dim>& rhs) : buf_(aria2::make_unique<char_t[]>(dim))
- {
- memcpy(buf_.get(), rhs.buf_.get(), dim);
- }
- explicit inline ulong(const char_t* data, size_t size)
-- : buf_(make_unique<char_t[]>(dim))
-+ : buf_(aria2::make_unique<char_t[]>(dim))
- {
- if (size > dim) {
- throw std::bad_alloc();
diff --git a/net-misc/aria2/files/aria2-1.34.0-mask-headers.patch b/net-misc/aria2/files/aria2-1.34.0-mask-headers.patch
deleted file mode 100644
index 694681d..0000000
--- a/net-misc/aria2/files/aria2-1.34.0-mask-headers.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-From 37368130ca7de5491a75fd18a20c5c5cc641824a Mon Sep 17 00:00:00 2001
-From: Tatsuhiro Tsujikawa <tatsuhiro.t@gmail.com>
-Date: Sat, 5 Jan 2019 09:32:40 +0900
-Subject: [PATCH] Mask headers
-
----
- src/HttpConnection.cc | 18 ++++++++++++------
- 1 file changed, 12 insertions(+), 6 deletions(-)
-
-diff --git a/src/HttpConnection.cc b/src/HttpConnection.cc
-index 77cb9d27a..be5b97723 100644
---- a/src/HttpConnection.cc
-+++ b/src/HttpConnection.cc
-@@ -102,11 +102,17 @@ std::string HttpConnection::eraseConfidentialInfo(const std::string& request)
- std::string result;
- std::string line;
- while (getline(istr, line)) {
-- if (util::startsWith(line, "Authorization: Basic")) {
-- result += "Authorization: Basic ********\n";
-+ if (util::istartsWith(line, "Authorization: ")) {
-+ result += "Authorization: <snip>\n";
- }
-- else if (util::startsWith(line, "Proxy-Authorization: Basic")) {
-- result += "Proxy-Authorization: Basic ********\n";
-+ else if (util::istartsWith(line, "Proxy-Authorization: ")) {
-+ result += "Proxy-Authorization: <snip>\n";
-+ }
-+ else if (util::istartsWith(line, "Cookie: ")) {
-+ result += "Cookie: <snip>\n";
-+ }
-+ else if (util::istartsWith(line, "Set-Cookie: ")) {
-+ result += "Set-Cookie: <snip>\n";
- }
- else {
- result += line;
-@@ -154,8 +160,8 @@ std::unique_ptr<HttpResponse> HttpConnection::receiveResponse()
- const auto& proc = outstandingHttpRequests_.front()->getHttpHeaderProcessor();
- if (proc->parse(socketRecvBuffer_->getBuffer(),
- socketRecvBuffer_->getBufferLength())) {
-- A2_LOG_INFO(
-- fmt(MSG_RECEIVE_RESPONSE, cuid_, proc->getHeaderString().c_str()));
-+ A2_LOG_INFO(fmt(MSG_RECEIVE_RESPONSE, cuid_,
-+ eraseConfidentialInfo(proc->getHeaderString()).c_str()));
- auto result = proc->getResult();
- if (result->getStatusCode() / 100 == 1) {
- socketRecvBuffer_->drain(proc->getLastBytesProcessed());
diff --git a/net-misc/aria2/files/aria2-libressl.patch b/net-misc/aria2/files/aria2-libressl.patch
deleted file mode 100644
index 4c20b1b..0000000
--- a/net-misc/aria2/files/aria2-libressl.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/src/libssl_compat.h b/src/libssl_compat.h
-index 0e03bfd7..cb2e3d97 100644
---- a/src/libssl_compat.h
-+++ b/src/libssl_compat.h
-@@ -44,6 +44,7 @@
- #endif // !defined(LIBRESSL_VERSION_NUMBER)
-
- #define OPENSSL_101_API \
-- (!LIBRESSL_IN_USE && OPENSSL_VERSION_NUMBER >= 0x1010000fL)
-+ ((!LIBRESSL_IN_USE && OPENSSL_VERSION_NUMBER >= 0x1010000fL) || \
-+ (LIBRESSL_IN_USE && LIBRESSL_VERSION_NUMBER >= 0x20700000L))
-
- #endif // LIBSSL_COMPAT_H
diff --git a/net-misc/aria2/metadata.xml b/net-misc/aria2/metadata.xml
deleted file mode 100644
index e5e58f4..0000000
--- a/net-misc/aria2/metadata.xml
+++ /dev/null
@@ -1,25 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>dev-zero@gentoo.org</email>
- <name>Tiziano Müller</name>
- </maintainer>
- <maintainer type="person">
- <email>mgorny@gentoo.org</email>
- <name>Michał Górny</name>
- </maintainer>
- <use>
- <flag name="bittorrent">Enable support for the bittorrent protocol.</flag>
- <flag name="libuv">Use <pkg>dev-libs/libuv</pkg> backend.</flag>
- <flag name="libxml2">Use <pkg>dev-libs/libxml2</pkg> for XML parsing (preferred) instead of <pkg>dev-libs/expat</pkg>.</flag>
- <flag name="nettle">Use <pkg>dev-libs/nettle</pkg> and <pkg>dev-libs/gmp</pkg> for bittorrent/metalink crypto instead of <pkg>dev-libs/libgcrypt</pkg> (when <pkg>dev-libs/openssl</pkg> is not being used).</flag>
- <flag name="metalink">Enable support for metalink.</flag>
- <flag name="scripts">Install additional scripts which use aria2's xmlrpc functionality.</flag>
- <flag name="ssh">Enable SFTP support.</flag>
- </use>
- <upstream>
- <remote-id type="sourceforge">aria2</remote-id>
- <remote-id type="github">tatsuhiro-t/aria2</remote-id>
- </upstream>
-</pkgmetadata>