aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2023-12-29 07:31:28 -0800
committerorbea <orbea@riseup.net>2023-12-29 07:31:28 -0800
commit812fbf11f7edd9a0ce4e55114cbcf7e222f74abb (patch)
tree4ded0633523b15e9dc13ccbb206e349692950756 /net-misc
parentnet-misc/seafile-client: drop 8.0.10, 9.0.0, 9.0.1, 9.0.2, 9.0.2_p1 (diff)
downloadlibressl-812fbf11f7edd9a0ce4e55114cbcf7e222f74abb.tar.gz
libressl-812fbf11f7edd9a0ce4e55114cbcf7e222f74abb.tar.bz2
libressl-812fbf11f7edd9a0ce4e55114cbcf7e222f74abb.zip
net-misc/socat: drop 1.7.4.4
Signed-off-by: orbea <orbea@riseup.net>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/socat/socat-1.7.4.4.ebuild61
1 files changed, 0 insertions, 61 deletions
diff --git a/net-misc/socat/socat-1.7.4.4.ebuild b/net-misc/socat/socat-1.7.4.4.ebuild
deleted file mode 100644
index ef8236e..0000000
--- a/net-misc/socat/socat-1.7.4.4.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit flag-o-matic toolchain-funcs
-
-MY_P=${P/_beta/-b}
-DESCRIPTION="Multipurpose relay (SOcket CAT)"
-HOMEPAGE="http://www.dest-unreach.org/socat/ https://repo.or.cz/socat.git"
-SRC_URI="http://www.dest-unreach.org/socat/download/${MY_P}.tar.bz2"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-IUSE="bindist ipv6 readline ssl tcpd"
-
-DEPEND="ssl? ( dev-libs/openssl:0= )
- readline? ( sys-libs/readline:= )
- tcpd? ( sys-apps/tcp-wrappers )"
-RDEPEND="${DEPEND}"
-
-# Tests are a large bash script
-# Hard to disable individual tests needing network or privileges
-# in 1.7.4.2: FAILED: 59 329
-RESTRICT="test ssl? ( readline? ( bindist ) )"
-
-DOCS=( BUGREPORTS CHANGES DEVELOPMENT EXAMPLES FAQ FILES PORTING README SECURITY )
-
-pkg_setup() {
- # bug #587740
- if use readline && use ssl ; then
- elog "You are enabling both readline and ssl (openssl) USE flags, the licenses"
- elog "for these packages conflict. You may not be able to legally"
- elog "redistribute the resulting binary."
- fi
-}
-
-src_configure() {
- # bug #293324
- filter-flags '-Wno-error*'
-
- tc-export AR
-
- # libressl doesn't have OPENSSL_INIT_new()
- export ac_cv_func_OPENSSL_init_ssl=no
-
- econf \
- $(use_enable ssl openssl) \
- $(use_enable readline) \
- $(use_enable ipv6 ip6) \
- $(use_enable tcpd libwrap)
-}
-
-src_install() {
- default
-
- docinto html
- dodoc doc/*.html doc/*.css
-}