aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authortastytea <tastytea@tastytea.de>2020-01-14 16:10:43 +0100
committertastytea <tastytea@tastytea.de>2020-01-14 16:20:38 +0100
commit90f00c56cb9766e69554f8a876265ee6098642ec (patch)
treea5021afdff1fc28c618e4bf3771bc37bb88f1e22
parentnet-im/riot-web: upgrade to 1.5.5 (diff)
downloadmatrix-90f00c56cb9766e69554f8a876265ee6098642ec.tar.gz
matrix-90f00c56cb9766e69554f8a876265ee6098642ec.tar.bz2
matrix-90f00c56cb9766e69554f8a876265ee6098642ec.zip
net-im/nheko: Remove -Werror from CMakeLists.txt.
Build fails with “QDesktopWidget::availableGeometry […] is deprecated” otherwise. See <https://github.com/Nheko-Reborn/nheko/issues/107>.
-rw-r--r--net-im/nheko/nheko-0.6.4-r1.ebuild8
-rw-r--r--net-im/nheko/nheko-9999.ebuild8
2 files changed, 14 insertions, 2 deletions
diff --git a/net-im/nheko/nheko-0.6.4-r1.ebuild b/net-im/nheko/nheko-0.6.4-r1.ebuild
index 3371751..6c85109 100644
--- a/net-im/nheko/nheko-0.6.4-r1.ebuild
+++ b/net-im/nheko/nheko-0.6.4-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2019 Gentoo Authors
+# Copyright 2019-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -39,6 +39,12 @@ DEPEND="${RDEPEND}
CMAKE_BUILD_TYPE=Release
+src_prepare ()
+{
+ sed -i '/-Werror/d' CMakeLists.txt || die
+ cmake-utils_src_prepare
+}
+
pkg_postinst() {
xdg_desktop_database_update
}
diff --git a/net-im/nheko/nheko-9999.ebuild b/net-im/nheko/nheko-9999.ebuild
index 3371751..6c85109 100644
--- a/net-im/nheko/nheko-9999.ebuild
+++ b/net-im/nheko/nheko-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2019 Gentoo Authors
+# Copyright 2019-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -39,6 +39,12 @@ DEPEND="${RDEPEND}
CMAKE_BUILD_TYPE=Release
+src_prepare ()
+{
+ sed -i '/-Werror/d' CMakeLists.txt || die
+ cmake-utils_src_prepare
+}
+
pkg_postinst() {
xdg_desktop_database_update
}