aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-06-28 13:40:24 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-06-28 13:40:24 -0400
commit0bab672fecdf82cac74c10bd0bda2da93c4c1c7e (patch)
tree951fe5ee1bd971648cc131e139c1b1fc5cda1979 /app-text
parentsys-process/procps: run elibtoolize #580792 (diff)
downloadppc64le-0bab672fecdf82cac74c10bd0bda2da93c4c1c7e.tar.gz
ppc64le-0bab672fecdf82cac74c10bd0bda2da93c4c1c7e.tar.bz2
ppc64le-0bab672fecdf82cac74c10bd0bda2da93c4c1c7e.zip
app-text/opensp: copy from tree
Diffstat (limited to 'app-text')
-rw-r--r--app-text/opensp/Manifest1
-rw-r--r--app-text/opensp/files/opensp-1.5-gcc34.patch10
-rw-r--r--app-text/opensp/files/opensp-1.5.2-fix-segfault.patch23
-rw-r--r--app-text/opensp/metadata.xml12
-rw-r--r--app-text/opensp/opensp-1.5.2-r3.ebuild76
-rw-r--r--app-text/opensp/opensp-1.5.2-r4.ebuild76
6 files changed, 198 insertions, 0 deletions
diff --git a/app-text/opensp/Manifest b/app-text/opensp/Manifest
new file mode 100644
index 0000000..1894e20
--- /dev/null
+++ b/app-text/opensp/Manifest
@@ -0,0 +1 @@
+DIST OpenSP-1.5.2.tar.gz 1521390 SHA256 57f4898498a368918b0d49c826aa434bb5b703d2c3b169beb348016ab25617ce SHA512 a7dcc246ba7f58969ecd6d107c7b82dede811e65f375b7aa3e683621f2c6ff3e7dccefdd79098fcadad6cca8bb94c2933c63f4701be2c002f9a56f1bbe6b047e WHIRLPOOL 9565425b87d0f68025a2058e8941c5c64519cdb1ab3f22aeec6968473989f39b805dbfa8ca8c74f3968358fac2144756cf50aeab8e6c9ce8112610bd445d5ce2
diff --git a/app-text/opensp/files/opensp-1.5-gcc34.patch b/app-text/opensp/files/opensp-1.5-gcc34.patch
new file mode 100644
index 0000000..60ee560
--- /dev/null
+++ b/app-text/opensp/files/opensp-1.5-gcc34.patch
@@ -0,0 +1,10 @@
+--- include/RangeMap.h~ 2004-04-22 20:34:13.729541096 +0300
++++ include/RangeMap.h 2004-04-22 20:31:48.473049702 +0300
+@@ -8,6 +8,7 @@
+ #include "Boolean.h"
+ #include "ISet.h"
+ #include "types.h"
++#include "constant.h"
+ #include <stddef.h>
+
+ #ifdef SP_NAMESPACE
diff --git a/app-text/opensp/files/opensp-1.5.2-fix-segfault.patch b/app-text/opensp/files/opensp-1.5.2-fix-segfault.patch
new file mode 100644
index 0000000..5a9d328
--- /dev/null
+++ b/app-text/opensp/files/opensp-1.5.2-fix-segfault.patch
@@ -0,0 +1,23 @@
+Resolve segfault in OpenSP::ParsedSystemId::unparse.
+Patch taken from Debian.
+https://bugs.gentoo.org/show_bug.cgi?id=196230
+--- a/lib/ExtendEntityManager.cxx
++++ b/lib/ExtendEntityManager.cxx
+@@ -1238,7 +1238,8 @@
+ }
+
+ StorageObjectSpec::StorageObjectSpec(const StorageObjectSpec& x)
+-: codingSystemName(x.codingSystemName),
++: storageManager(x.storageManager),
++ codingSystemName(x.codingSystemName),
+ codingSystem(x.codingSystem),
+ specId(x.specId),
+ baseId(x.baseId),
+@@ -1253,6 +1254,7 @@
+ StorageObjectSpec& StorageObjectSpec::operator=(const StorageObjectSpec& x)
+ {
+ if (this != &x) {
++ storageManager = x.storageManager;
+ codingSystemName = x.codingSystemName;
+ codingSystem = x.codingSystem;
+ specId = x.specId;
diff --git a/app-text/opensp/metadata.xml b/app-text/opensp/metadata.xml
new file mode 100644
index 0000000..84b1dda
--- /dev/null
+++ b/app-text/opensp/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>heroxbd@gentoo.org</email>
+ <name>Benda Xu</name>
+ </maintainer>
+ <longdescription>An SGML System Conforming to International Standard ISO 8879.</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">openjade</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/opensp/opensp-1.5.2-r3.ebuild b/app-text/opensp/opensp-1.5.2-r3.ebuild
new file mode 100644
index 0000000..9f97607
--- /dev/null
+++ b/app-text/opensp/opensp-1.5.2-r3.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils flag-o-matic
+
+MY_P=${P/opensp/OpenSP}
+
+DESCRIPTION="A free, object-oriented toolkit for SGML parsing and entity management"
+HOMEPAGE="http://openjade.sourceforge.net/"
+SRC_URI="mirror://sourceforge/openjade/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc nls static-libs test"
+
+DEPEND="nls? ( sys-devel/gettext )
+ doc? (
+ app-text/xmlto
+ app-text/docbook-xml-dtd:4.1.2
+ )
+ test? (
+ app-text/docbook-xml-dtd:4.5
+ app-text/openjade
+ app-text/sgml-common
+ )"
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-1.5-gcc34.patch \
+ "${FILESDIR}"/${P}-fix-segfault.patch
+}
+
+src_configure() {
+ # The following filters are taken from openjade's ebuild. See bug #100828.
+ # Please note! Opts are disabled. If you know what you're doing
+ # feel free to remove this line. It may cause problems with
+ # docbook-sgml-utils among other things.
+ #ALLOWED_FLAGS="-O -O1 -O2 -pipe -g -march"
+ strip-flags
+
+ econf \
+ --enable-http \
+ --enable-default-catalog="${EPREFIX}"/etc/sgml/catalog \
+ --enable-default-search-path="${EPREFIX}"/usr/share/sgml \
+ --datadir="${EPREFIX}"/usr/share/sgml/${P} \
+ $(use_enable nls) \
+ $(use_enable doc doc-build) \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake pkgdocdir="${EPREFIX}"/usr/share/doc/${PF}
+}
+
+src_test() {
+ # Skipping tests known not to work
+ emake SHOWSTOPPERS= check
+ SANDBOX_PREDICT="${SANDBOX_PREDICT%:/}"
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ pkgdocdir="${EPREFIX}"/usr/share/doc/${PF} \
+ install
+
+ prune_libtool_files
+
+ dodoc AUTHORS BUGS ChangeLog NEWS README
+}
diff --git a/app-text/opensp/opensp-1.5.2-r4.ebuild b/app-text/opensp/opensp-1.5.2-r4.ebuild
new file mode 100644
index 0000000..2abcab3
--- /dev/null
+++ b/app-text/opensp/opensp-1.5.2-r4.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+WANT_AUTOMAKE='1.13'
+inherit eutils flag-o-matic autotools
+
+MY_P=${P/opensp/OpenSP}
+
+DESCRIPTION="A free, object-oriented toolkit for SGML parsing and entity management"
+HOMEPAGE="http://openjade.sourceforge.net/"
+SRC_URI="mirror://sourceforge/openjade/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc nls static-libs test"
+
+DEPEND="nls? ( sys-devel/gettext )
+ doc? (
+ app-text/xmlto
+ app-text/docbook-xml-dtd:4.1.2
+ )
+ test? (
+ app-text/docbook-xml-dtd:4.5
+ app-text/openjade
+ app-text/sgml-common
+ )"
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-fix-segfault.patch
+ use prefix && eautoreconf
+}
+
+src_configure() {
+ # The following filters are taken from openjade's ebuild. See bug #100828.
+ # Please note! Opts are disabled. If you know what you're doing
+ # feel free to remove this line. It may cause problems with
+ # docbook-sgml-utils among other things.
+ #ALLOWED_FLAGS="-O -O1 -O2 -pipe -g -march"
+ strip-flags
+
+ econf \
+ --enable-http \
+ --enable-default-catalog="${EPREFIX}"/etc/sgml/catalog \
+ --enable-default-search-path="${EPREFIX}"/usr/share/sgml \
+ --datadir="${EPREFIX}"/usr/share/sgml/${P} \
+ $(use_enable nls) \
+ $(use_enable doc doc-build) \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake pkgdocdir="${EPREFIX}"/usr/share/doc/${PF}
+}
+
+src_test() {
+ # Skipping tests known not to work
+ emake SHOWSTOPPERS= check
+ SANDBOX_PREDICT="${SANDBOX_PREDICT%:/}"
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ pkgdocdir="${EPREFIX}"/usr/share/doc/${PF} \
+ install
+
+ prune_libtool_files
+
+ dodoc AUTHORS BUGS ChangeLog NEWS README
+}