summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2018-06-01 22:02:31 +0200
committerFabian Groffen <grobian@gentoo.org>2018-06-01 22:02:31 +0200
commit05e91ddb79908f0b52b42b7df6238e91ebec69ee (patch)
tree69f5fd333d61a0626c9defe0f0ffc4ec4f7e19b1
parentscripts/bootstrap-prefix: fix bootstrap on macOS to get past stage2 (diff)
downloadprefix-05e91ddb79908f0b52b42b7df6238e91ebec69ee.tar.gz
prefix-05e91ddb79908f0b52b42b7df6238e91ebec69ee.tar.bz2
prefix-05e91ddb79908f0b52b42b7df6238e91ebec69ee.zip
dev-lang/python: ensure Python framework gets built without $D
On macOS when building native stuff, the Makefile uses DESTDIR in the install_name of the framework. This obviously causes install_name QA checks to go off, so ensure we never use DESTDIR in the install_name by removing it. Package-Manager: Portage-2.3.40.1-prefix, Repoman-2.3.9
-rw-r--r--dev-lang/python/python-2.7.14-r2.ebuild2
1 files changed, 2 insertions, 0 deletions
diff --git a/dev-lang/python/python-2.7.14-r2.ebuild b/dev-lang/python/python-2.7.14-r2.ebuild
index 494beb6780..abe2442ccc 100644
--- a/dev-lang/python/python-2.7.14-r2.ebuild
+++ b/dev-lang/python/python-2.7.14-r2.ebuild
@@ -127,6 +127,8 @@ src_prepare() {
configure.ac configure || die
# we handle creation of symlinks in src_install
sed -i -e '/ln -fs .*PYTHONFRAMEWORK/d' Makefile.pre.in || die
+ # build the Python framework without DESTDIR in install_name
+ sed -i -e '/-install_name/s/$(DESTDIR)//' Makefile.pre.in || die
fi
# don't try to do fancy things on Darwin
sed -i -e 's/__APPLE__/__NO_MUCKING_AROUND__/g' Modules/readline.c || die