aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorstefson <herrtimson@yahoo.de>2019-10-23 21:52:15 +0200
committerstefson <herrtimson@yahoo.de>2019-10-23 21:52:15 +0200
commit730c23eb2893cdd91cac94f0a21547aea663d067 (patch)
tree7f150c6c29bee05b83c4f07527606abc07e5b788
parentMerge pull request #452 from sielicki/dev-lang/rust-std-bin (diff)
downloadrust-730c23eb2893cdd91cac94f0a21547aea663d067.tar.gz
rust-730c23eb2893cdd91cac94f0a21547aea663d067.tar.bz2
rust-730c23eb2893cdd91cac94f0a21547aea663d067.zip
dev-lang/rust: allow llvm 8 or 9 for the live ebuild with system-llvm
I tried to follow the instructions more closer, right now it wants to pull in the old llvm-8 slot, also it might break soon given that it's a live ebuild
-rw-r--r--dev-lang/rust/rust-9999.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/dev-lang/rust/rust-9999.ebuild b/dev-lang/rust/rust-9999.ebuild
index 15f831c..238b918 100644
--- a/dev-lang/rust/rust-9999.ebuild
+++ b/dev-lang/rust/rust-9999.ebuild
@@ -42,6 +42,10 @@ IUSE="clippy cpu_flags_x86_sse2 debug doc libressl rls rustfmt system-llvm wasm
# 3. Specify LLVM_MAX_SLOT, e.g. 8.
LLVM_DEPEND="
|| (
+ sys-devel/llvm:9[llvm_targets_WebAssembly?]
+ wasm? ( >=sys-devel/lld-9 )
+ )
+ (
sys-devel/llvm:8[llvm_targets_WebAssembly?]
wasm? ( >=sys-devel/lld-8 )
)