aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorstefson <herrtimson@yahoo.de>2019-10-23 20:04:23 +0200
committerstefson <herrtimson@yahoo.de>2019-10-23 20:04:23 +0200
commitec9f87c5e289b3fb20f76ba2d873640e30ef1917 (patch)
tree4a4fa5579d5cbf7a16743466c19cc9952f6cc8b5
parentdev-lang/rust: add pr65474 to beta branch (diff)
downloadrust-ec9f87c5e289b3fb20f76ba2d873640e30ef1917.tar.gz
rust-ec9f87c5e289b3fb20f76ba2d873640e30ef1917.tar.bz2
rust-ec9f87c5e289b3fb20f76ba2d873640e30ef1917.zip
dev-lang/rust: allow llvm 8 or 9 for beta branch
please patch this and open a pullrequest if it's not working anymore
-rw-r--r--dev-lang/rust/rust-999.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/dev-lang/rust/rust-999.ebuild b/dev-lang/rust/rust-999.ebuild
index b8a91e1..f0c6789 100644
--- a/dev-lang/rust/rust-999.ebuild
+++ b/dev-lang/rust/rust-999.ebuild
@@ -43,6 +43,10 @@ IUSE="clippy cpu_flags_x86_sse2 debug doc libressl rls rustfmt system-llvm wasm
# 3. Specify LLVM_MAX_SLOT, e.g. 8.
LLVM_DEPEND="
|| (
+ sys-devel/llvm:9[llvm_targets_WebAssembly?]
+ wasm? ( >=sys-devel/lld-9 )
+ )
+ (
sys-devel/llvm:8[llvm_targets_WebAssembly?]
wasm? ( >=sys-devel/lld-8 )
)