aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authoro01eg <o01eg@yandex.ru>2017-08-17 21:53:24 +0300
committero01eg <o01eg@yandex.ru>2017-08-17 21:53:24 +0300
commit025f767fa972c2829a2cbd34d99dcc22ddf1f178 (patch)
tree379f6d650cdb738d2154189f443568e01c1d3fa2 /dev-rust/qt_generator
parentRemove obsoleted and conflicting with portage cargo.eclass file. (diff)
downloadrust-025f767fa972c2829a2cbd34d99dcc22ddf1f178.tar.gz
rust-025f767fa972c2829a2cbd34d99dcc22ddf1f178.tar.bz2
rust-025f767fa972c2829a2cbd34d99dcc22ddf1f178.zip
Add dev-rust/qt_generator.
Diffstat (limited to 'dev-rust/qt_generator')
-rw-r--r--dev-rust/qt_generator/qt_generator-9999.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-rust/qt_generator/qt_generator-9999.ebuild b/dev-rust/qt_generator/qt_generator-9999.ebuild
new file mode 100644
index 0000000..34eb5c0
--- /dev/null
+++ b/dev-rust/qt_generator/qt_generator-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cargo git-r3
+
+EGIT_REPO_URI="https://github.com/rust-qt/cpp_to_rust.git"
+
+DESCRIPTION="Generator of Rust-Qt crates."
+HOMEPAGE="https://github.com/rust-qt/cpp_to_rust"
+SRC_URI=""
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+CDEPEND="dev-db/sqlite"
+DEPEND="${CDEPEND}
+virtual/rust
+|| ( dev-util/cargo dev-util/cargo-bin )
+"
+RDEPEND="${CDEPEND}
+dev-qt/qtchooser
+dev-qt/qtcore
+"
+
+S="${WORKDIR}/${P}/qt_generator/qt_generator"
+
+