aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Sarnie <sarnex@gentoo.org>2020-09-29 18:36:25 -0400
committerNick Sarnie <sarnex@gentoo.org>2020-09-29 18:36:25 -0400
commitac57db7693e62549d57fbdb076f406bae7bc5842 (patch)
treeb7c5e5c4c17de4642dac1a65f6d2905da3b9efa6 /app-emulation/vkd3d
parentapp-emulation/vkd3d: Fix build (diff)
downloadwine-ac57db7693e62549d57fbdb076f406bae7bc5842.tar.gz
wine-ac57db7693e62549d57fbdb076f406bae7bc5842.tar.bz2
wine-ac57db7693e62549d57fbdb076f406bae7bc5842.zip
app-emulation/vkd3d: Sync with ::gentoo
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Nick Sarnie <sarnex@gentoo.org>
Diffstat (limited to 'app-emulation/vkd3d')
-rw-r--r--app-emulation/vkd3d/vkd3d-9999.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/app-emulation/vkd3d/vkd3d-9999.ebuild b/app-emulation/vkd3d/vkd3d-9999.ebuild
index 90e8035..0e542af 100644
--- a/app-emulation/vkd3d/vkd3d-9999.ebuild
+++ b/app-emulation/vkd3d/vkd3d-9999.ebuild
@@ -3,13 +3,15 @@
EAPI=6
-inherit multilib-minimal
+inherit multilib-minimal autotools
+
+AUTOTOOLS_AUTORECONF="1"
if [[ "${PV}" == "9999" ]]; then
EGIT_REPO_URI="https://source.winehq.org/git/vkd3d.git"
inherit git-r3
else
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="~amd64"
SRC_URI="https://dl.winehq.org/vkd3d/source/${P}.tar.xz"
fi
@@ -22,7 +24,7 @@ RDEPEND="spirv-tools? ( dev-util/spirv-tools:=[${MULTILIB_USEDEP}] )
DEPEND="${RDEPEND}
dev-util/spirv-headers
- dev-util/vulkan-headers"
+ >=dev-util/vulkan-headers-1.1.114"
DESCRIPTION="D3D12 to Vulkan translation library"
HOMEPAGE="https://source.winehq.org/git/vkd3d.git/"
@@ -30,6 +32,11 @@ HOMEPAGE="https://source.winehq.org/git/vkd3d.git/"
LICENSE="LGPL-2.1"
SLOT="0"
+src_prepare() {
+ default
+ eautoreconf
+}
+
multilib_src_configure() {
local myconf=(
$(use_with spirv-tools)