aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2021-08-13 13:38:41 +0300
committerJimi Huotari <chiitoo@gentoo.org>2021-08-13 13:38:41 +0300
commit6746b7bb342ef93f14736b45fcc6d1424fcd88c8 (patch)
treeb73940ac5997525cca99393f16b62970fd87ca05 /app-emulation/wine-d3d9/wine-d3d9-2.3-r1.ebuild
parentapp-emulation/wine-staging: use plocale instead of the l10n eclass (diff)
downloadwine-6746b7bb342ef93f14736b45fcc6d1424fcd88c8.tar.gz
wine-6746b7bb342ef93f14736b45fcc6d1424fcd88c8.tar.bz2
wine-6746b7bb342ef93f14736b45fcc6d1424fcd88c8.zip
app-emulation/wine-d3d9: use plocale instead of the l10n eclass
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Diffstat (limited to 'app-emulation/wine-d3d9/wine-d3d9-2.3-r1.ebuild')
-rw-r--r--app-emulation/wine-d3d9/wine-d3d9-2.3-r1.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/app-emulation/wine-d3d9/wine-d3d9-2.3-r1.ebuild b/app-emulation/wine-d3d9/wine-d3d9-2.3-r1.ebuild
index 6649f9e..0f57782 100644
--- a/app-emulation/wine-d3d9/wine-d3d9-2.3-r1.ebuild
+++ b/app-emulation/wine-d3d9/wine-d3d9-2.3-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -6,7 +6,7 @@ EAPI=6
PLOCALES="ar bg ca cs da de el en en_US eo es fa fi fr he hi hr hu it ja ko lt ml nb_NO nl or pa pl pt_BR pt_PT rm ro ru sk sl sr_RS@cyrillic sr_RS@latin sv te th tr uk wa zh_CN zh_TW"
PLOCALE_BACKUP="en"
-inherit autotools eapi7-ver estack eutils flag-o-matic gnome2-utils l10n multilib multilib-minimal pax-utils toolchain-funcs virtualx xdg-utils
+inherit autotools eapi7-ver estack eutils flag-o-matic gnome2-utils multilib multilib-minimal pax-utils plocale toolchain-funcs virtualx xdg-utils
MY_PN="${PN%%-*}"
MY_P="${MY_PN}-${PV}"
@@ -313,7 +313,7 @@ src_unpack() {
default
- l10n_find_plocales_changes "${S}/po" "" ".po"
+ plocale_find_changes "${S}/po" "" ".po"
}
src_prepare() {
@@ -352,7 +352,7 @@ src_prepare() {
# hi-res default icon, #472990, https://bugs.winehq.org/show_bug.cgi?id=24652
cp "${PATCHDIR}/files/oic_winlogo.ico" dlls/user32/resources/ || die
- l10n_get_locales > po/LINGUAS || die # otherwise wine doesn't respect LINGUAS
+ plocale_get_locales > po/LINGUAS || die # otherwise wine doesn't respect LINGUAS
# Fix manpage generation for locales #469418 and abi_x86_64 #617864
# Requires wine-2.0-rearrange-manpages.patch
@@ -377,7 +377,7 @@ src_prepare() {
}
while read f; do
- l10n_for_each_disabled_locale_do rm_man_file "${f}"
+ plocale_for_each_disabled_locale rm_man_file "${f}"
done < <(find -name "Makefile.in" -exec grep -q "UTF-8.man.in" "{}" \; -print)
}
@@ -485,7 +485,7 @@ multilib_src_install_all() {
local locale_doc="documentation/README.$1"
[[ ! -e ${locale_doc} ]] || DOCS+=( ${locale_doc} )
}
- l10n_for_each_locale_do add_locale_docs
+ plocale_for_each_locale add_locale_docs
einstalldocs
prune_libtool_files --all