aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-20 02:13:06 +0100
committerSam James <sam@gentoo.org>2022-05-20 02:13:06 +0100
commit5d5b469904109980759a77e2cdd737efa14c0bc7 (patch)
tree297ac696b18a6700239187d542ff856df903889b /app-emulation/wine-d3d9
parentapp-emulation/wine-vanilla: [QA] drop (very) stale GCC version checks (diff)
downloadwine-5d5b469904109980759a77e2cdd737efa14c0bc7.tar.gz
wine-5d5b469904109980759a77e2cdd737efa14c0bc7.tar.bz2
wine-5d5b469904109980759a77e2cdd737efa14c0bc7.zip
app-emulation/wine-d3d9: [QA] drop (very) stale GCC version checks
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-emulation/wine-d3d9')
-rw-r--r--app-emulation/wine-d3d9/wine-d3d9-3.11.ebuild23
-rw-r--r--app-emulation/wine-d3d9/wine-d3d9-3.4.ebuild23
2 files changed, 0 insertions, 46 deletions
diff --git a/app-emulation/wine-d3d9/wine-d3d9-3.11.ebuild b/app-emulation/wine-d3d9/wine-d3d9-3.11.ebuild
index 7d7d9e8..5266089 100644
--- a/app-emulation/wine-d3d9/wine-d3d9-3.11.ebuild
+++ b/app-emulation/wine-d3d9/wine-d3d9-3.11.ebuild
@@ -175,29 +175,6 @@ wine_compiler_check() {
wine_build_environment_check() {
[[ ${MERGE_TYPE} = "binary" ]] && return 0
- if use abi_x86_64; then
- if tc-is-gcc && [[ $(gcc-major-version) -lt 4 || ( $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 4 ) ]]; then
- eerror "You need gcc-4.4+ to compile 64-bit wine"
- die
- elif tc-is-clang && [[ $(clang-major-version) -lt 3 || ( $(clang-major-version) -eq 3 && $(clang-minor-version) -lt 8 ) ]]; then
- eerror "You need clang-3.8+ to compile 64-bit wine"
- die
- fi
- fi
- if tc-is-gcc && [[ $(gcc-major-version) -eq 5 && $(gcc-minor-version) -le 3 ]]; then
- ewarn "GCC-5.0-5.3 suffered from compiler bugs and are no longer supported by"
- ewarn "Gentoo's Toolchain Team. If your ebuild fails the compiler checks in"
- ewarn "the configure phase, either update your compiler or switch to <5.0 || >=5.4"
- fi
- if tc-is-gcc && [[ $(gcc-major-version) -eq 5 && $(gcc-minor-version) -eq 4 ]]; then
- if has "-march=i686" ${CFLAGS} && ! has "-mtune=generic" ${CFLAGS}; then
- ewarn "Compilation can hang with CFLAGS=\"-march=i686\". You can temporarily work"
- ewarn "around this by adding \"-mtune=generic\" to your CFLAGS for wine."
- ewarn "See package.env in man 5 portage for more information on how to do this."
- ewarn "See https://bugs.gentoo.org/show_bug.cgi?id=613128 for more details"
- fi
- fi
-
if use abi_x86_32 && use opencl && [[ "$(eselect opencl show 2> /dev/null)" == "intel" ]]; then
eerror "You cannot build wine with USE=opencl because intel-ocl-sdk is 64-bit only."
eerror "See https://bugs.gentoo.org/487864 for more details."
diff --git a/app-emulation/wine-d3d9/wine-d3d9-3.4.ebuild b/app-emulation/wine-d3d9/wine-d3d9-3.4.ebuild
index 22ba9f5..7186adf 100644
--- a/app-emulation/wine-d3d9/wine-d3d9-3.4.ebuild
+++ b/app-emulation/wine-d3d9/wine-d3d9-3.4.ebuild
@@ -173,29 +173,6 @@ wine_compiler_check() {
wine_build_environment_check() {
[[ ${MERGE_TYPE} = "binary" ]] && return 0
- if use abi_x86_64; then
- if tc-is-gcc && [[ $(gcc-major-version) -lt 4 || ( $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 4 ) ]]; then
- eerror "You need gcc-4.4+ to compile 64-bit wine"
- die
- elif tc-is-clang && [[ $(clang-major-version) -lt 3 || ( $(clang-major-version) -eq 3 && $(clang-minor-version) -lt 8 ) ]]; then
- eerror "You need clang-3.8+ to compile 64-bit wine"
- die
- fi
- fi
- if tc-is-gcc && [[ $(gcc-major-version) -eq 5 && $(gcc-minor-version) -le 3 ]]; then
- ewarn "GCC-5.0-5.3 suffered from compiler bugs and are no longer supported by"
- ewarn "Gentoo's Toolchain Team. If your ebuild fails the compiler checks in"
- ewarn "the configure phase, either update your compiler or switch to <5.0 || >=5.4"
- fi
- if tc-is-gcc && [[ $(gcc-major-version) -eq 5 && $(gcc-minor-version) -eq 4 ]]; then
- if has "-march=i686" ${CFLAGS} && ! has "-mtune=generic" ${CFLAGS}; then
- ewarn "Compilation can hang with CFLAGS=\"-march=i686\". You can temporarily work"
- ewarn "around this by adding \"-mtune=generic\" to your CFLAGS for wine."
- ewarn "See package.env in man 5 portage for more information on how to do this."
- ewarn "See https://bugs.gentoo.org/show_bug.cgi?id=613128 for more details"
- fi
- fi
-
if use abi_x86_32 && use opencl && [[ "$(eselect opencl show 2> /dev/null)" == "intel" ]]; then
eerror "You cannot build wine with USE=opencl because intel-ocl-sdk is 64-bit only."
eerror "See https://bugs.gentoo.org/487864 for more details."