aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Walker <bob.mt.wya@gmail.com>2018-10-21 14:05:10 +0100
committerNick Sarnie <sarnex@gentoo.org>2018-10-22 19:28:04 -0400
commit6ce20ed04a18222843839d5d8b90d26497de6a64 (patch)
treec5ca546843376d54a4c3b636111e56cca1c3e84a /app-emulation/wine-staging/wine-staging-2.16-r1.ebuild
parentapp-emulation/wine-vanilla: update/fix metadata.xml (diff)
downloadwine-6ce20ed04a18222843839d5d8b90d26497de6a64.tar.gz
wine-6ce20ed04a18222843839d5d8b90d26497de6a64.tar.bz2
wine-6ce20ed04a18222843839d5d8b90d26497de6a64.zip
app-emulation/wine-staging: migrate to git-r3.eclass EGIT_OVERRIDE* APIs
See: https://xxoo.ws/gentoo/portage/commit/17d7a4564177b1985e4b7e8f23a8efbc4d5c32ae Signed-off-by: Rob Walker <bob.mt.wya@gmail.com>
Diffstat (limited to 'app-emulation/wine-staging/wine-staging-2.16-r1.ebuild')
-rw-r--r--app-emulation/wine-staging/wine-staging-2.16-r1.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/app-emulation/wine-staging/wine-staging-2.16-r1.ebuild b/app-emulation/wine-staging/wine-staging-2.16-r1.ebuild
index aca612b..0091e24 100644
--- a/app-emulation/wine-staging/wine-staging-2.16-r1.ebuild
+++ b/app-emulation/wine-staging/wine-staging-2.16-r1.ebuild
@@ -267,14 +267,17 @@ wine_env_vcs_vars() {
if use staging; then
eerror "Because of the multi-repo nature of ${MY_PN}, ${pn_live_var}"
eerror "cannot be used to set the commit. Instead, you may use the"
- eerror "environmental variables WINE_COMMIT, and STAGING_COMMIT."
+ eerror "environment variables:"
+ eerror " EGIT_OVERRIDE_COMMIT_WINE"
+ eerror " EGIT_OVERRIDE_COMMIT_WINE_COMPHOLIO_WINE_STAGING"
eerror
return 1
fi
fi
if [[ ! -z ${EGIT_COMMIT} ]]; then
- eerror "Commits must now be specified using the environmental variables"
- eerror "WINE_COMMIT, STAGING_COMMIT, and D3D9_COMMIT"
+ eerror "Commits must now be specified using the environment variables:"
+ eerror " EGIT_OVERRIDE_COMMIT_WINE"
+ eerror " EGIT_OVERRIDE_COMMIT_WINE_COMPHOLIO_WINE_STAGING"
eerror
return 1
fi
@@ -313,19 +316,18 @@ pkg_setup() {
src_unpack() {
if [[ ${PV} == "9999" ]] ; then
- EGIT_CHECKOUT_DIR="${S}" EGIT_COMMIT="${WINE_COMMIT}" git-r3_src_unpack
+ EGIT_CHECKOUT_DIR="${S}" git-r3_src_unpack
if use staging; then
local CURRENT_WINE_COMMIT=${EGIT_VERSION}
- git-r3_fetch "${STAGING_EGIT_REPO_URI}" "${STAGING_COMMIT}"
- git-r3_checkout "${STAGING_EGIT_REPO_URI}" "${STAGING_DIR}"
+ EGIT_CHECKOUT_DIR="${STAGING_DIR}" EGIT_REPO_URI="${STAGING_EGIT_REPO_URI}" git-r3_src_unpack
local COMPAT_WINE_COMMIT=$("${STAGING_DIR}/patches/patchinstall.sh" --upstream-commit) || die
if [[ "${CURRENT_WINE_COMMIT}" != "${COMPAT_WINE_COMMIT}" ]]; then
einfo "The current Staging patchset is not guaranteed to apply on this WINE commit."
einfo "If src_prepare fails, try emerging with the env var WINE_COMMIT."
- einfo "Example: WINE_COMMIT=${COMPAT_WINE_COMMIT} emerge -1 wine"
+ einfo "Example: EGIT_OVERRIDE_COMMIT_WINE=${COMPAT_WINE_COMMIT} emerge -1 wine"
fi
fi
fi