aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2021-08-13 13:34:13 +0300
committerJimi Huotari <chiitoo@gentoo.org>2021-08-13 13:34:13 +0300
commitc7320da6e7092defb6081dc72d98cbed8efa26dc (patch)
treeeea41d8d7a2b74c7f4f7e8b40ef7d692971a08a2 /app-emulation/wine-vanilla/wine-vanilla-5.17.ebuild
parentapp-emulation/wine-vanilla: Fix build (diff)
downloadwine-c7320da6e7092defb6081dc72d98cbed8efa26dc.tar.gz
wine-c7320da6e7092defb6081dc72d98cbed8efa26dc.tar.bz2
wine-c7320da6e7092defb6081dc72d98cbed8efa26dc.zip
app-emulation/wine-vanilla: use plocale instead of the l10n eclass
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Diffstat (limited to 'app-emulation/wine-vanilla/wine-vanilla-5.17.ebuild')
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-5.17.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/app-emulation/wine-vanilla/wine-vanilla-5.17.ebuild b/app-emulation/wine-vanilla/wine-vanilla-5.17.ebuild
index a52badd..7a896c2 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-5.17.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-5.17.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -6,7 +6,7 @@ EAPI=6
PLOCALES="ar ast bg ca cs da de el en en_US eo es fa fi fr he hi hr hu it ja ko lt ml nb_NO nl or pa pl pt_BR pt_PT rm ro ru si sk sl sr_RS@cyrillic sr_RS@latin sv ta te th tr uk wa zh_CN zh_TW"
PLOCALE_BACKUP="en"
-inherit autotools eapi7-ver estack eutils flag-o-matic gnome2-utils l10n multilib multilib-minimal pax-utils toolchain-funcs virtualx xdg-utils
+inherit autotools eapi7-ver estack eutils flag-o-matic gnome2-utils multilib multilib-minimal pax-utils plocale toolchain-funcs virtualx xdg-utils
MY_PN="${PN%%-*}"
MY_P="${MY_PN}-${PV}"
@@ -287,7 +287,7 @@ src_unpack() {
default
- l10n_find_plocales_changes "${S}/po" "" ".po"
+ plocale_find_changes "${S}/po" "" ".po"
}
src_prepare() {
@@ -321,7 +321,7 @@ src_prepare() {
# hi-res default icon, #472990, https://bugs.winehq.org/show_bug.cgi?id=24652
cp "${PATCHDIR}/files/oic_winlogo.ico" dlls/user32/resources/ || die
- l10n_get_locales > po/LINGUAS || die # otherwise wine doesn't respect LINGUAS
+ plocale_get_locales > po/LINGUAS || die # otherwise wine doesn't respect LINGUAS
# Fix manpage generation for locales #469418 and abi_x86_64 #617864
@@ -345,7 +345,7 @@ src_prepare() {
}
while read f; do
- l10n_for_each_disabled_locale_do rm_man_file "${f}"
+ plocale_for_each_disabled_locale rm_man_file "${f}"
done < <(find -name "Makefile.in" -exec grep -q "UTF-8.man.in" "{}" \; -print)
}
@@ -459,7 +459,7 @@ multilib_src_install_all() {
local locale_doc="documentation/README.$1"
[[ ! -e ${locale_doc} ]] || DOCS+=( ${locale_doc} )
}
- l10n_for_each_locale_do add_locale_docs
+ plocale_for_each_locale add_locale_docs
einstalldocs
find "${ED}" -name *.la -delete || die