aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Sarnie <sarnex@gentoo.org>2022-04-15 15:27:33 -0400
committerNick Sarnie <sarnex@gentoo.org>2022-04-15 15:29:39 -0400
commit0fddb34e05c1f58e00de87f90a025a8e1dbc392b (patch)
treeb80a430462a08409f3a5b495e46fd19921628a4a /app-emulation
parentapp-emulation/winetricks: remove version 20210825 (diff)
downloadwine-0fddb34e05c1f58e00de87f90a025a8e1dbc392b.tar.gz
wine-0fddb34e05c1f58e00de87f90a025a8e1dbc392b.tar.bz2
wine-0fddb34e05c1f58e00de87f90a025a8e1dbc392b.zip
app-emulation/vkd3d: Restrict test
Closes: https://bugs.gentoo.org/838655 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Nick Sarnie <sarnex@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/vkd3d/vkd3d-1.2.ebuild5
-rw-r--r--app-emulation/vkd3d/vkd3d-9999.ebuild18
2 files changed, 11 insertions, 12 deletions
diff --git a/app-emulation/vkd3d/vkd3d-1.2.ebuild b/app-emulation/vkd3d/vkd3d-1.2.ebuild
index 90e8035..e64cc1a 100644
--- a/app-emulation/vkd3d/vkd3d-1.2.ebuild
+++ b/app-emulation/vkd3d/vkd3d-1.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -13,6 +13,9 @@ else
SRC_URI="https://dl.winehq.org/vkd3d/source/${P}.tar.xz"
fi
+#Tests fail: https://bugs.gentoo.org/838655
+RESTRICT="test"
+
IUSE="spirv-tools"
RDEPEND="spirv-tools? ( dev-util/spirv-tools:=[${MULTILIB_USEDEP}] )
media-libs/vulkan-loader[${MULTILIB_USEDEP},X]
diff --git a/app-emulation/vkd3d/vkd3d-9999.ebuild b/app-emulation/vkd3d/vkd3d-9999.ebuild
index 0e542af..e64cc1a 100644
--- a/app-emulation/vkd3d/vkd3d-9999.ebuild
+++ b/app-emulation/vkd3d/vkd3d-9999.ebuild
@@ -1,20 +1,21 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit multilib-minimal autotools
-
-AUTOTOOLS_AUTORECONF="1"
+inherit multilib-minimal
if [[ "${PV}" == "9999" ]]; then
EGIT_REPO_URI="https://source.winehq.org/git/vkd3d.git"
inherit git-r3
else
- KEYWORDS="~amd64"
+ KEYWORDS="~amd64 ~x86"
SRC_URI="https://dl.winehq.org/vkd3d/source/${P}.tar.xz"
fi
+#Tests fail: https://bugs.gentoo.org/838655
+RESTRICT="test"
+
IUSE="spirv-tools"
RDEPEND="spirv-tools? ( dev-util/spirv-tools:=[${MULTILIB_USEDEP}] )
media-libs/vulkan-loader[${MULTILIB_USEDEP},X]
@@ -24,7 +25,7 @@ RDEPEND="spirv-tools? ( dev-util/spirv-tools:=[${MULTILIB_USEDEP}] )
DEPEND="${RDEPEND}
dev-util/spirv-headers
- >=dev-util/vulkan-headers-1.1.114"
+ dev-util/vulkan-headers"
DESCRIPTION="D3D12 to Vulkan translation library"
HOMEPAGE="https://source.winehq.org/git/vkd3d.git/"
@@ -32,11 +33,6 @@ HOMEPAGE="https://source.winehq.org/git/vkd3d.git/"
LICENSE="LGPL-2.1"
SLOT="0"
-src_prepare() {
- default
- eautoreconf
-}
-
multilib_src_configure() {
local myconf=(
$(use_with spirv-tools)