aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2020-12-03 09:25:35 +0200
committerJimi Huotari <chiitoo@gentoo.org>2020-12-04 04:35:10 +0200
commit14deadb457c34a5f053217b4fa0bc720209973ba (patch)
treea18018e5bae14c2f58cdfef4b87fbaacd39688ee /app-emulation
parentapp-emulation/wine-vanilla: Pass CFLAGS to mingw (diff)
downloadwine-14deadb457c34a5f053217b4fa0bc720209973ba.tar.gz
wine-14deadb457c34a5f053217b4fa0bc720209973ba.tar.bz2
wine-14deadb457c34a5f053217b4fa0bc720209973ba.zip
app-emulation/wine-vanilla: adjust path to wineconsole removal
Bug: https://bugs.gentoo.org/757999 Package-Manager: Portage-3.0.11, Repoman-3.0.2 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-5.22-r2.ebuild14
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-9999.ebuild14
2 files changed, 22 insertions, 6 deletions
diff --git a/app-emulation/wine-vanilla/wine-vanilla-5.22-r2.ebuild b/app-emulation/wine-vanilla/wine-vanilla-5.22-r2.ebuild
index 05ef8ff..ff9a439 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-5.22-r2.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-5.22-r2.ebuild
@@ -505,9 +505,17 @@ multilib_src_install_all() {
if ! use X && ! use ncurses; then
rm "${D%/}${MY_PREFIX}"/bin/wineconsole* || die
rm "${D%/}${MY_MANDIR}"/man1/wineconsole* || die
- rm_wineconsole() {
- rm "${D%/}${MY_PREFIX}/$(get_libdir)"/wine/{,fakedlls/}wineconsole.exe* || die
- }
+
+ if ! use mingw; then
+ rm_wineconsole() {
+ rm "${D%/}/usr/$(get_libdir)/wine-${WINE_VARIANT}"/wine/{,fakedlls/}wineconsole.exe* || die
+ }
+ else
+ rm_wineconsole() {
+ rm "${D%/}/usr/$(get_libdir)/wine-${WINE_VARIANT}"/wine/wineconsole.exe* || die
+ }
+ fi
+
multilib_foreach_abi rm_wineconsole
fi
diff --git a/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild b/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
index 05ef8ff..ff9a439 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
@@ -505,9 +505,17 @@ multilib_src_install_all() {
if ! use X && ! use ncurses; then
rm "${D%/}${MY_PREFIX}"/bin/wineconsole* || die
rm "${D%/}${MY_MANDIR}"/man1/wineconsole* || die
- rm_wineconsole() {
- rm "${D%/}${MY_PREFIX}/$(get_libdir)"/wine/{,fakedlls/}wineconsole.exe* || die
- }
+
+ if ! use mingw; then
+ rm_wineconsole() {
+ rm "${D%/}/usr/$(get_libdir)/wine-${WINE_VARIANT}"/wine/{,fakedlls/}wineconsole.exe* || die
+ }
+ else
+ rm_wineconsole() {
+ rm "${D%/}/usr/$(get_libdir)/wine-${WINE_VARIANT}"/wine/wineconsole.exe* || die
+ }
+ fi
+
multilib_foreach_abi rm_wineconsole
fi