aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/wine-staging/wine-staging-7.4.ebuild')
-rw-r--r--app-emulation/wine-staging/wine-staging-7.4.ebuild19
1 files changed, 11 insertions, 8 deletions
diff --git a/app-emulation/wine-staging/wine-staging-7.4.ebuild b/app-emulation/wine-staging/wine-staging-7.4.ebuild
index cf584a4..35870f8 100644
--- a/app-emulation/wine-staging/wine-staging-7.4.ebuild
+++ b/app-emulation/wine-staging/wine-staging-7.4.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
PLOCALES="ar ast bg ca cs da de el en en_US eo es fa fi fr he hi hr hu it ja ko lt ml nb_NO nl or pa pl pt_BR pt_PT rm ro ru si sk sl sr_RS@cyrillic sr_RS@latin sv ta te th tr uk wa zh_CN zh_TW"
PLOCALE_BACKUP="en"
-inherit autotools eapi7-ver estack eutils flag-o-matic gnome2-utils multilib multilib-minimal pax-utils plocale toolchain-funcs virtualx xdg-utils
+inherit autotools estack flag-o-matic multilib-minimal pax-utils plocale toolchain-funcs virtualx wrapper xdg-utils
MY_PN="${PN%%-*}"
MY_PV="${PV/_/-}"
MY_P="${MY_PN}-${MY_PV}"
@@ -48,7 +48,7 @@ fi
LICENSE="LGPL-2.1"
SLOT="${MY_PV}"
-IUSE="+abi_x86_32 +abi_x86_64 +alsa capi cups custom-cflags dos elibc_glibc +fontconfig +gecko gphoto2 gssapi gstreamer kerberos ldap mingw +mono mp3 netapi nls odbc openal opencl +opengl osmesa oss +perl pcap pipelight pulseaudio +realtime +run-exes samba scanner sdl selinux +ssl staging test +threads +truetype udev +udisks +unwind usb v4l vkd3d vulkan +X +xcomposite xinerama"
+IUSE="+abi_x86_32 +abi_x86_64 +alsa capi cups custom-cflags dos +fontconfig +gecko gphoto2 gssapi gstreamer kerberos ldap mingw +mono mp3 netapi nls odbc openal opencl +opengl osmesa oss +perl pcap pipelight pulseaudio +realtime +run-exes samba scanner sdl selinux +ssl staging test +threads +truetype udev +udisks +unwind usb v4l vkd3d vulkan +X +xcomposite xinerama"
REQUIRED_USE="|| ( abi_x86_32 abi_x86_64 )
X? ( truetype )
elibc_glibc? ( threads )
@@ -61,7 +61,13 @@ REQUIRED_USE="|| ( abi_x86_32 abi_x86_64 )
# or fail due to Xvfb's opengl limitations.
RESTRICT="test"
+BDEPEND="mingw? ( !!>=cross-i686-w64-mingw32/binutils-2.38 !!>=cross-x86_64-w64-mingw32/binutils-2.38 )
+ sys-devel/flex
+ virtual/yacc
+ virtual/pkgconfig"
+
COMMON_DEPEND="
+ ${BDEPEND}
X? (
x11-libs/libXcursor[${MULTILIB_USEDEP}]
x11-libs/libXext[${MULTILIB_USEDEP}]
@@ -131,10 +137,7 @@ RDEPEND="${COMMON_DEPEND}
# tools/make_requests requires perl
DEPEND="${COMMON_DEPEND}
- sys-devel/flex
>=sys-kernel/linux-headers-2.6
- virtual/pkgconfig
- virtual/yacc
X? ( x11-base/xorg-proto )
staging? (
dev-lang/perl
@@ -275,8 +278,8 @@ pkg_pretend() {
# Verify OSS support
if use oss; then
if ! has_version ">=media-sound/oss-4"; then
- eerror "You cannot build wine with USE=oss without having support from a"
- eerror "FreeBSD kernel or >=media-sound/oss-4 (only available through external repos)"
+ eerror "You cannot build wine with USE=oss without having support from"
+ eerror ">=media-sound/oss-4 (only available through external repos)"
eerror
die
fi