summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-10 18:26:54 +0000
committerSam James <sam@gentoo.org>2021-01-10 18:30:00 +0000
commit61874b16e7df22e0b67e2776ae651641007dacb8 (patch)
tree9e1c2e2f7a3c0b06197f6b1800eb9bcd5736f8c2
parentsys-fs/avfs: add changelog to metadata (diff)
downloadgentoo-61874b16e7df22e0b67e2776ae651641007dacb8.tar.gz
gentoo-61874b16e7df22e0b67e2776ae651641007dacb8.tar.bz2
gentoo-61874b16e7df22e0b67e2776ae651641007dacb8.zip
sys-fs/avfs: bump to 1.1.3
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-fs/avfs/Manifest1
-rw-r--r--sys-fs/avfs/avfs-1.1.3.ebuild70
-rw-r--r--sys-fs/avfs/metadata.xml3
3 files changed, 74 insertions, 0 deletions
diff --git a/sys-fs/avfs/Manifest b/sys-fs/avfs/Manifest
index 3b889a6b3435..64d304a77722 100644
--- a/sys-fs/avfs/Manifest
+++ b/sys-fs/avfs/Manifest
@@ -1 +1,2 @@
DIST avfs-1.1.1.tar.bz2 606819 BLAKE2B 240bb342dc9f993ac8deb60941411b1419c190f9909b5b1bde65777b82f622e121f44f238d2bd8ddc303c86ef376950d4af773c8fae79848b466ec3a3c5aafc1 SHA512 0707f8e746d8d3633755b1a1efb944a400c095b517a7befd75de4d25e2fad1a1b5132b9cf94285b05ad1344bfc138ec75e9cb5f8a5d7775a69595b9b35266f92
+DIST avfs-1.1.3.tar.bz2 609901 BLAKE2B 2eea31365533372fc5ea252d57da97a8e0d362b6db5f0a6e10af9255105ccdcadbd7f5157aafd63244da2c7a53dcbc6781d0c4ba5ca231ce2937855d400ea4e5 SHA512 8e87655cbdb64f0cbbcc399142957ea9e04a998953cc64def9c8bb338b46abffc85a35e09b5fa52bb9ddcf56e27c4f62503050d32c8201eaad61c54e22bdd005
diff --git a/sys-fs/avfs/avfs-1.1.3.ebuild b/sys-fs/avfs/avfs-1.1.3.ebuild
new file mode 100644
index 000000000000..a9d5071514cd
--- /dev/null
+++ b/sys-fs/avfs/avfs-1.1.3.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="AVFS is a virtual filesystem that allows browsing of compressed files"
+HOMEPAGE="https://sourceforge.net/projects/avf/"
+SRC_URI="mirror://sourceforge/avf/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE="+lzma webdav +zstd"
+
+BDEPEND="
+ sys-devel/libtool
+ virtual/pkgconfig
+"
+RDEPEND="
+ app-arch/bzip2:=
+ >=sys-fs/fuse-2.4:0
+ sys-libs/zlib
+ lzma? ( app-arch/xz-utils )
+ webdav? ( net-libs/neon:= )
+ zstd? ( app-arch/zstd:= )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf \
+ --enable-fuse \
+ --enable-library \
+ --enable-shared \
+ --with-system-zlib \
+ --with-system-bzlib \
+ --disable-static \
+ $(use_enable webdav dav) \
+ $(use_with lzma xz) \
+ $(use_with zstd)
+}
+
+src_install() {
+ default
+
+ # remove cruft
+ rm "${ED}"/usr/bin/{davpass,ftppass} || die
+
+ # install docs
+ dodoc doc/{api-overview,background,FORMAT,INSTALL.*,README.avfs-fuse}
+ dosym ../../../$(get_libdir)/avfs/extfs/README /usr/share/doc/${PF}/README.extfs
+
+ docinto scripts
+ dodoc scripts/*pass
+
+ find "${ED}" -name "*.la" -delete || die
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ einfo "This version of AVFS includes FUSE support. It is user-based."
+ einfo "To execute:"
+ einfo "1) as user, mkdir ~/.avfs"
+ einfo "2) make sure fuse is either compiled into the kernel OR"
+ einfo " modprobe fuse or add to startup."
+ einfo "3) run mountavfs"
+ einfo "To unload daemon, type umountavfs"
+ einfo
+ einfo "READ the documentation! Enjoy :)"
+ fi
+}
diff --git a/sys-fs/avfs/metadata.xml b/sys-fs/avfs/metadata.xml
index 4f0ed2e64cca..293141f061c2 100644
--- a/sys-fs/avfs/metadata.xml
+++ b/sys-fs/avfs/metadata.xml
@@ -2,6 +2,9 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<!-- maintainer-needed -->
+ <use>
+ <flag name="webdav">Allow mounting WebDAV shares via <pkg>net-libs/neon</pkg></flag>
+ </use>
<upstream>
<remote-id type="sourceforge">avf</remote-id>
<changelog>https://sourceforge.net/p/avf/git/ci/master/tree/NEWS</changelog>