summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2021-11-30 22:06:34 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2021-11-30 22:06:34 +0000
commit7fde4464ba848e3eb8b2b989e0fa41124416bfb9 (patch)
tree16011713cfa2b059a991f43c36cb1cf87532da2b
parent2021-11-30 21:51:35 UTC (diff)
parentdev-python/xmlschema: Bump to 1.9.0 (diff)
downloadgentoo-7fde4464ba848e3eb8b2b989e0fa41124416bfb9.tar.gz
gentoo-7fde4464ba848e3eb8b2b989e0fa41124416bfb9.tar.bz2
gentoo-7fde4464ba848e3eb8b2b989e0fa41124416bfb9.zip
Merge updates from master
-rw-r--r--dev-python/django-otp/Manifest1
-rw-r--r--dev-python/django-otp/django-otp-1.1.3.ebuild35
-rw-r--r--dev-python/parso/Manifest1
-rw-r--r--dev-python/parso/parso-0.8.3.ebuild24
-rw-r--r--dev-python/xmlschema/Manifest1
-rw-r--r--dev-python/xmlschema/xmlschema-1.9.0.ebuild31
6 files changed, 93 insertions, 0 deletions
diff --git a/dev-python/django-otp/Manifest b/dev-python/django-otp/Manifest
index 209230488f72..cc553fd76403 100644
--- a/dev-python/django-otp/Manifest
+++ b/dev-python/django-otp/Manifest
@@ -1,2 +1,3 @@
DIST django-otp-1.1.1.gh.tar.gz 71526 BLAKE2B d68c0fe99c5437d08a8a0a433b4d6f41f0068047e3899efbb24234696c3494a064982aabc02d2788662d516235413bfc804f76cf5ffa1c608d3aa61927e2fad3 SHA512 5946cd64fd0f52dac5ef9fb192f8ecf78e99c96fe7e3223b41c68d96e249f6727149ef58a2dbf48024452e078f5f93c1f9edb9db2a25def5cbb3992c16aac18c
DIST django-otp-1.1.2.gh.tar.gz 72639 BLAKE2B ba30e8d6c9982010dd9a627a810b9bc36474c571cbb6eb756d45b617338f18b7ceb024f88baeb7ceb6dbd76b3f5cf9ed53ebabd9dba435b6ab6cc3bdba092fa4 SHA512 85b34f9a36632ca44e4f7a3f11d1fd795bf65f909c0b6e4735afd56f06d754f7f28b43ccc851cb86c7330919978d3e2cb793111e50030273056da0231ee0e3ca
+DIST django-otp-1.1.3.gh.tar.gz 72736 BLAKE2B 1dc0570d65f0ac8de417260ce2fb895dbae7f5f2cd106b0dd969bc04df207cd4aa9ccf8be2bfc74475bb3ec6abcd451b7fa1c32fd0f7f0d3b27afca212f3b8ed SHA512 4e8b38c393fe29b2fa91e3f1f70abd2cc671dcf760e2e2bf8f738e04fc43a6e7f54229f298f7f2611988dffc40b4450ed1ab910ce9e9995b205dff1b3c90a977
diff --git a/dev-python/django-otp/django-otp-1.1.3.ebuild b/dev-python/django-otp/django-otp-1.1.3.ebuild
new file mode 100644
index 000000000000..892604810582
--- /dev/null
+++ b/dev-python/django-otp/django-otp-1.1.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Django framework adding two-factor authentication using one-time passwords"
+HOMEPAGE="https://github.com/django-otp/django-otp/"
+SRC_URI="
+ https://github.com/django-otp/django-otp/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-2.2[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/qrcode[${PYTHON_USEDEP}]
+ ${RDEPEND}
+ )"
+
+python_test() {
+ local -x PYTHONPATH=test:${PYTHONPATH}
+ local -x DJANGO_SETTINGS_MODULE=test_project.settings
+ django-admin test -v 2 django_otp || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/parso/Manifest b/dev-python/parso/Manifest
index 8c996586d04f..1ff516e0eddc 100644
--- a/dev-python/parso/Manifest
+++ b/dev-python/parso/Manifest
@@ -1,2 +1,3 @@
DIST parso-0.7.1.tar.gz 399842 BLAKE2B 1e47c1dd6846d01aa5820d7cedc3eafcf12ea0d4a2e95fa3f54429633b1c12dc39a4abe237fa46eb629408006777bd1f512cf878025b55119568ac19729b8c19 SHA512 318969a7a941c4a0948e58643b07b6f5c446ea166b3a8e44a556f0677ec9a36d7dc8c6d37ca7bce3f8276ee3d7144e22fbaaeac90c738fb90f7e94a0cf8abf7d
DIST parso-0.8.2.tar.gz 394419 BLAKE2B f4e86ae55140adc9bbfdd34a8044e7fdfbf9d318a6385ac5feedc07127061943c2d690581af144f158846e3bf6f82124046c7e625369a4055ab92a54f9210c49 SHA512 a90810ad89301d804d215392ed77593b015f13bc7ef8512302a8893b314a9e74c15e2aaa77157c8595a134d3481e8115f306f9628835271478837ec6f19e645f
+DIST parso-0.8.3.tar.gz 397648 BLAKE2B 8942408e27198075c92ef51f7a191cc7781eb3a5110119b91fd95f86e13ebe2fbfee11022a2bfec794150f60b3af8c4d5f324cb011703cd581c17f92232ae5bf SHA512 7874460053662d40c2cfcf0015e330e1c8201eeb07682e2079a636db553a82dc25b70b14ad0f0c82fb817f655359d695101a17f616abf9a39f49c61ae5fd49b1
diff --git a/dev-python/parso/parso-0.8.3.ebuild b/dev-python/parso/parso-0.8.3.ebuild
new file mode 100644
index 000000000000..7a270d5a5eeb
--- /dev/null
+++ b/dev-python/parso/parso-0.8.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="a python parser that supports error recovery and round-trip parsing"
+HOMEPAGE="https://github.com/davidhalter/parso https://pypi.org/project/parso/"
+SRC_URI="https://github.com/davidhalter/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # py3.10 changed exception messages
+ test/test_python_errors.py::test_python_exception_matches
+)
diff --git a/dev-python/xmlschema/Manifest b/dev-python/xmlschema/Manifest
index b2909297146b..b2d657542154 100644
--- a/dev-python/xmlschema/Manifest
+++ b/dev-python/xmlschema/Manifest
@@ -1,2 +1,3 @@
DIST xmlschema-1.8.1.tar.gz 390835 BLAKE2B 5ba4e37bc52402a939e3c6508bb3d2cca33b85d73db9be375295de62587bae638d498435198a4b25bc6858bad19a89d14a11870774c631bcc9f1b22bb1c41f4c SHA512 741477d006270deb4a1d1b13bb404c6f4917047b0f68e85727a2dfe239a59f36f4160a6a88f26514a05865219a16ccbaa26bc319b06ac867aeabe008a778ddf8
DIST xmlschema-1.8.2.tar.gz 392045 BLAKE2B 05b63c069bc6f7052e84f7af20b789e2e9b9e54eccbc28971006b924d1eff4b23a43e2a85356214603f4c2263f2478f7cc4321c4ae93e8106f31940098ab7ae2 SHA512 3a03206c732b3d46a58bcfdeafdccb08c7f3334c78df63901352d2d2eaebaabbb663d70329bd9667530a1e8c2bf1b7087eb493f971c3fa914d8944064e12361c
+DIST xmlschema-1.9.0.tar.gz 394048 BLAKE2B 96060d971826263b3a52b3d8720c7d2421af0bf55f1603b68691a374a72d441238b790f3c7ce0e48ca436cd9939aa0f3563bd3862d5371bd57c44815777ec83a SHA512 c7763acefa6cd34a1edc5487f0c2257c871b7c5aed2466dfb1867a004e9f91603e20d458238a52da33225d9303a7262e347f20c41203dea0f0cb7400bed66838
diff --git a/dev-python/xmlschema/xmlschema-1.9.0.ebuild b/dev-python/xmlschema/xmlschema-1.9.0.ebuild
new file mode 100644
index 000000000000..4860e6037578
--- /dev/null
+++ b/dev-python/xmlschema/xmlschema-1.9.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="An XML Schema validator and decoder"
+HOMEPAGE="https://github.com/sissaschool/xmlschema https://pypi.org/project/xmlschema/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/elementpath-2.3.2[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ "${EPYTHON}" tests/test_all.py -v ||
+ die "Tests fail with ${EPYTHON}"
+}