summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2023-06-03 16:01:55 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2023-06-03 16:01:55 +0000
commit9ac507ca399e73ff79dd7fc30742a4a45ec7f699 (patch)
treef7ad44675795a9cdd04dcf87ec55a5cbc19d335a
parent2023-06-03 15:31:58 UTC (diff)
parentnet-im/openmittsu: add 0.10.0.0 (diff)
downloadgentoo-9ac507ca399e73ff79dd7fc30742a4a45ec7f699.tar.gz
gentoo-9ac507ca399e73ff79dd7fc30742a4a45ec7f699.tar.bz2
gentoo-9ac507ca399e73ff79dd7fc30742a4a45ec7f699.zip
Merge updates from master
-rw-r--r--dev-ml/zmq-async/Manifest1
-rw-r--r--dev-ml/zmq-async/metadata.xml13
-rw-r--r--dev-ml/zmq-async/zmq-async-5.2.1.ebuild44
-rw-r--r--dev-ml/zmq-lwt/Manifest1
-rw-r--r--dev-ml/zmq-lwt/metadata.xml13
-rw-r--r--dev-ml/zmq-lwt/zmq-lwt-5.2.1.ebuild42
-rw-r--r--dev-ml/zmq/Manifest1
-rw-r--r--dev-ml/zmq/metadata.xml13
-rw-r--r--dev-ml/zmq/zmq-5.2.1.ebuild41
-rw-r--r--games-util/antimicrox/Manifest3
-rw-r--r--games-util/antimicrox/antimicrox-3.3.2.ebuild74
-rw-r--r--games-util/antimicrox/antimicrox-3.3.4.ebuild (renamed from games-util/antimicrox/antimicrox-3.3.1.ebuild)2
-rw-r--r--net-im/openmittsu/Manifest1
-rw-r--r--net-im/openmittsu/openmittsu-0.10.0.0.ebuild60
14 files changed, 232 insertions, 77 deletions
diff --git a/dev-ml/zmq-async/Manifest b/dev-ml/zmq-async/Manifest
new file mode 100644
index 000000000000..cb55bc1e51bb
--- /dev/null
+++ b/dev-ml/zmq-async/Manifest
@@ -0,0 +1 @@
+DIST ocaml-zmq-zmq-async.tar.gz 33027 BLAKE2B 935468c29394abaac36fdea922f82b525f0cdaf35365b893a0186cc54e9b0a4e3fa25a9d8362addad52e89a3b930d36974590c481647c19a55fca8fdfef68bf3 SHA512 85d1b16f8e9d6abc24e175b7dd3574585f4d854f5355bb67797f8651eea3f0835ade03a28d5d9e8dbd5cb5573f517e271854099ee91a79835c2d84076983dff4
diff --git a/dev-ml/zmq-async/metadata.xml b/dev-ml/zmq-async/metadata.xml
new file mode 100644
index 000000000000..e367ac09da1c
--- /dev/null
+++ b/dev-ml/zmq-async/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/issuu/ocaml-zmq/</bugs-to>
+ <remote-id type="github">issuu/ocaml-zmq</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/zmq-async/zmq-async-5.2.1.ebuild b/dev-ml/zmq-async/zmq-async-5.2.1.ebuild
new file mode 100644
index 000000000000..5e13c28209b9
--- /dev/null
+++ b/dev-ml/zmq-async/zmq-async-5.2.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Async-aware bindings to ZMQ for OCaml"
+HOMEPAGE="https://github.com/issuu/ocaml-zmq/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/issuu/ocaml-zmq.git"
+else
+ SRC_URI="https://github.com/issuu/ocaml-zmq/archive/${PV}.tar.gz
+ -> ocaml-zmq-${PN}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+S="${WORKDIR}"/ocaml-zmq-${PV}
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-ml/async_kernel:=
+ dev-ml/async_unix:=
+ dev-ml/base:=
+ net-libs/zeromq:=
+"
+DEPEND="${DEPEND}"
+BDEPEND="
+ dev-ml/dune-configurator
+ test? ( dev-ml/ounit2 )
+"
+
+src_compile() {
+ dune-compile ${DUNE_PKG_NAME}
+}
+
+src_test() {
+ dune-test ${DUNE_PKG_NAME}
+}
diff --git a/dev-ml/zmq-lwt/Manifest b/dev-ml/zmq-lwt/Manifest
new file mode 100644
index 000000000000..df4e516c7a95
--- /dev/null
+++ b/dev-ml/zmq-lwt/Manifest
@@ -0,0 +1 @@
+DIST ocaml-zmq-5.2.1.tar.gz 33027 BLAKE2B 935468c29394abaac36fdea922f82b525f0cdaf35365b893a0186cc54e9b0a4e3fa25a9d8362addad52e89a3b930d36974590c481647c19a55fca8fdfef68bf3 SHA512 85d1b16f8e9d6abc24e175b7dd3574585f4d854f5355bb67797f8651eea3f0835ade03a28d5d9e8dbd5cb5573f517e271854099ee91a79835c2d84076983dff4
diff --git a/dev-ml/zmq-lwt/metadata.xml b/dev-ml/zmq-lwt/metadata.xml
new file mode 100644
index 000000000000..e367ac09da1c
--- /dev/null
+++ b/dev-ml/zmq-lwt/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/issuu/ocaml-zmq/</bugs-to>
+ <remote-id type="github">issuu/ocaml-zmq</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/zmq-lwt/zmq-lwt-5.2.1.ebuild b/dev-ml/zmq-lwt/zmq-lwt-5.2.1.ebuild
new file mode 100644
index 000000000000..729eb085aacf
--- /dev/null
+++ b/dev-ml/zmq-lwt/zmq-lwt-5.2.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Lwt-aware bindings to ZMQ for OCaml"
+HOMEPAGE="https://github.com/issuu/ocaml-zmq/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/issuu/ocaml-zmq.git"
+else
+ SRC_URI="https://github.com/issuu/ocaml-zmq/archive/${PV}.tar.gz
+ -> ocaml-zmq-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+S="${WORKDIR}"/ocaml-zmq-${PV}
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-ml/lwt:=
+ net-libs/zeromq:=
+"
+DEPEND="${DEPEND}"
+BDEPEND="
+ dev-ml/dune-configurator
+ test? ( dev-ml/ounit2 )
+"
+
+src_compile() {
+ dune-compile ${DUNE_PKG_NAME}
+}
+
+src_test() {
+ dune-test ${DUNE_PKG_NAME}
+}
diff --git a/dev-ml/zmq/Manifest b/dev-ml/zmq/Manifest
new file mode 100644
index 000000000000..df4e516c7a95
--- /dev/null
+++ b/dev-ml/zmq/Manifest
@@ -0,0 +1 @@
+DIST ocaml-zmq-5.2.1.tar.gz 33027 BLAKE2B 935468c29394abaac36fdea922f82b525f0cdaf35365b893a0186cc54e9b0a4e3fa25a9d8362addad52e89a3b930d36974590c481647c19a55fca8fdfef68bf3 SHA512 85d1b16f8e9d6abc24e175b7dd3574585f4d854f5355bb67797f8651eea3f0835ade03a28d5d9e8dbd5cb5573f517e271854099ee91a79835c2d84076983dff4
diff --git a/dev-ml/zmq/metadata.xml b/dev-ml/zmq/metadata.xml
new file mode 100644
index 000000000000..e367ac09da1c
--- /dev/null
+++ b/dev-ml/zmq/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/issuu/ocaml-zmq/</bugs-to>
+ <remote-id type="github">issuu/ocaml-zmq</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/zmq/zmq-5.2.1.ebuild b/dev-ml/zmq/zmq-5.2.1.ebuild
new file mode 100644
index 000000000000..4dbb21fa9cd7
--- /dev/null
+++ b/dev-ml/zmq/zmq-5.2.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="OCaml bindings for ZeroMQ 4.x"
+HOMEPAGE="https://github.com/issuu/ocaml-zmq/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/issuu/ocaml-zmq.git"
+else
+ SRC_URI="https://github.com/issuu/ocaml-zmq/archive/${PV}.tar.gz
+ -> ocaml-zmq-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+S="${WORKDIR}"/ocaml-zmq-${PV}
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ net-libs/zeromq:=
+"
+DEPEND="${DEPEND}"
+BDEPEND="
+ dev-ml/dune-configurator
+ test? ( dev-ml/ounit2 )
+"
+
+src_compile() {
+ dune-compile ${DUNE_PKG_NAME}
+}
+
+src_test() {
+ dune-test ${DUNE_PKG_NAME}
+}
diff --git a/games-util/antimicrox/Manifest b/games-util/antimicrox/Manifest
index e4d404b44b7b..a207c7baed6b 100644
--- a/games-util/antimicrox/Manifest
+++ b/games-util/antimicrox/Manifest
@@ -1,3 +1,2 @@
-DIST antimicrox-3.3.1.tar.gz 1878461 BLAKE2B 4f1d0c9be92bf89c5ebc6cad8a8b106f1888e53d135efc86616c1244738f79df6981fe0ea0e233e8d436ace126f4ac43a5edd63b0684a6af257c055db99f4284 SHA512 15c6b88640e0cd6ebff85574d1911fb92ed27868b2442ab225ef0eaccfbe243b445c3a78435225cb5a54d9dca65517da8998df95ebfa50d92bd1e53338c102d2
-DIST antimicrox-3.3.2.tar.gz 1884509 BLAKE2B fad1c73800944defab7c807a76677f2451cb6ec436ca32bacb75663a71a5df7cac65cb26cb780efbead5ff2d496b54d35aa362d48321d6cfad6895146dfe2c3c SHA512 b78827e4fb7909d4b8998be7bdbfe22e3e1453da3ad34aa924e57a34993397155e5a249e10b616ea85595fc2559bb733910217a191cb53f640e52a9a4ebeab4f
DIST antimicrox-3.3.3.tar.gz 1956700 BLAKE2B 8f385f238bfe03cb294e5970dde63cc3f1668c8dfdd31c751b769e79493bfe86901fdcb6da80beda72fdb1672d3b1246a3e3f509387dba6418e09e1e6ff8bbb4 SHA512 e4e9edf4fdd15c111ee1675a166b70d0ecdcf735adf79d46498a88fe81ebbfd4f35fec10cb831d6506d19db8fd21edc7055d39be362c0f53036dff684841fb5e
+DIST antimicrox-3.3.4.tar.gz 2002552 BLAKE2B fbaca20e3d76f048c4d9ef1b0eb8d043ed3d357a8a208d65f26c08b657c18b34c82462ea3e06278194b6b461d9828404cf31ce510b963f5e98e615d1e8934928 SHA512 f6be26facb23f08682e091208aa3a4210666b89a50533c0970b2447d3c7a229fd705c2a5adeecb156708ce5cbef145b63db9f2244a98961ee8fa9fa063a03b3a
diff --git a/games-util/antimicrox/antimicrox-3.3.2.ebuild b/games-util/antimicrox/antimicrox-3.3.2.ebuild
deleted file mode 100644
index c8b91e144b90..000000000000
--- a/games-util/antimicrox/antimicrox-3.3.2.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit udev xdg cmake
-
-DESCRIPTION="Graphical program used to map keyboard buttons and mouse controls to a gamepad"
-HOMEPAGE="https://github.com/AntiMicroX/antimicrox/"
-SRC_URI="https://github.com/AntiMicroX/${PN}/archive/${PV}.tar.gz
- -> ${P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="amd64 ~x86"
-IUSE="doc"
-# Tests fail to build
-# https://github.com/AntiMicroX/antimicrox/issues/530
-RESTRICT="test"
-
-RDEPEND="
- dev-qt/qtconcurrent:5
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtnetwork:5
- dev-qt/qtwidgets:5
- media-libs/libsdl2[X,joystick]
- virtual/udev
- x11-libs/libX11
- x11-libs/libXi
- x11-libs/libXtst
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- dev-qt/linguist-tools:5
- kde-frameworks/extra-cmake-modules
- doc? ( app-doc/doxygen[dot] )
-"
-
-PATCHES=( "${FILESDIR}"/${PN}-man_gz.patch )
-DOCS=( CHANGELOG.md README.md )
-
-src_configure() {
- local mycmakeargs=(
- -DAPPDATA=OFF
- -DCHECK_FOR_UPDATES=OFF
- -DINSTALL_UINPUT_UDEV_RULES=OFF # Install in src_install
- -DWITH_TESTS=OFF
- -DWITH_UINPUT=ON
- -DWITH_X11=ON
- -DWITH_XTEST=ON
- -DBUILD_DOCS=$(usex doc ON OFF)
- )
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
- rm -r "${ED}"/usr/share/doc/${PN} || die
-
- udev_dorules "${S}"/other/60-${PN}-uinput.rules
-
- use doc && dodoc -r "${S}"/docs/{html,latex}
-}
-
-pkg_postinst() {
- udev_reload
- xdg_pkg_postinst
-}
-
-pkg_postrm() {
- udev_reload
- xdg_pkg_postrm
-}
diff --git a/games-util/antimicrox/antimicrox-3.3.1.ebuild b/games-util/antimicrox/antimicrox-3.3.4.ebuild
index c8b91e144b90..aa75972cfbbd 100644
--- a/games-util/antimicrox/antimicrox-3.3.1.ebuild
+++ b/games-util/antimicrox/antimicrox-3.3.4.ebuild
@@ -12,7 +12,7 @@ SRC_URI="https://github.com/AntiMicroX/${PN}/archive/${PV}.tar.gz
LICENSE="GPL-3+"
SLOT="0"
-KEYWORDS="amd64 ~x86"
+KEYWORDS="~amd64 ~x86"
IUSE="doc"
# Tests fail to build
# https://github.com/AntiMicroX/antimicrox/issues/530
diff --git a/net-im/openmittsu/Manifest b/net-im/openmittsu/Manifest
index 8381d6e3e48f..2937b3a1a154 100644
--- a/net-im/openmittsu/Manifest
+++ b/net-im/openmittsu/Manifest
@@ -1 +1,2 @@
+DIST openmittsu-0.10.0.0.tar.xz 2345724 BLAKE2B 407fe07147b17e6ac6ec2381e77256d09824fce87f1d9d141d2940e566191e911b05fb3d6701d342be9bb667551903f4f8913cbb25f504100e92ab4a38339555 SHA512 d4334c8516efcd63a3e9dfcf9f9655922aa14b2574f39269cf7019a8c951144569138c2a0a75abb16e2746a33002f0c07ef6c86dbdb5405e11c315ec630eb0d0
DIST openmittsu-0.9.15.0.tar.xz 2302908 BLAKE2B 2800004968a1965d0c91197402618ae4ebaeb7a7d977e79654f296d7d2ca1466d26b86d99810e0502e9eced27e5a664dbb4b0113ec344367fb7b85557ebc0381 SHA512 9e00828053506cf233a4cede49c501da903cc36d49379b891e4186cf10cacfbd596b4d2b7ac551e2e6340a878bfa1155f8696e179ed9dd1c2ecbff61430ed7f9
diff --git a/net-im/openmittsu/openmittsu-0.10.0.0.ebuild b/net-im/openmittsu/openmittsu-0.10.0.0.ebuild
new file mode 100644
index 000000000000..359edee95eb0
--- /dev/null
+++ b/net-im/openmittsu/openmittsu-0.10.0.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake desktop
+
+DESCRIPTION="Open source chat client for Threema-style end-to-end encrypted chat networks"
+HOMEPAGE="https://www.openmittsu.de/"
+# snapshot of https://github.com/blizzard4591/openMittsu.git
+# git-archive-all.sh --prefix ${P}/ -- - | xz > ${P}.tar.xz
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2+ BitstreamVera OFL-1.1 Apache-2.0 CC0-1.0 MIT BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-db/qt5-sqlcipher
+ >=dev-libs/libsodium-1.0.18:=
+ >=dev-qt/qtcore-5.7.1:5=
+ >=dev-qt/qtgui-5.7.1:5=
+ >=dev-qt/qtmultimedia-5.7.1:5=[widgets]
+ >=dev-qt/qtnetwork-5.7.1:5=[ssl]
+ >=dev-qt/qtsql-5.7.1:5=[sqlite]
+ >=dev-qt/qtwidgets-5.7.1:5=
+ >=media-gfx/qrencode-3.4.4-r1:="
+DEPEND="${RDEPEND}
+ test? ( >=dev-cpp/gtest-1.8.0 )"
+
+DOCS=(
+ README.md
+ Example-client-configuration-file.ini
+ Example-contacts-file.txt
+)
+
+src_configure() {
+ local mycmakeargs=(
+ # set version manually, since autodetection works only with git
+ "-DOPENMITTSU_CUSTOM_VERSION_STRING=${PV%.*}-${PV##*.}-00000000"
+ "-DOPENMITTSU_DISABLE_VERSION_UPDATE_CHECK=ON"
+ "-DOPENMITTSU_ENABLE_TESTS=$(usex test)"
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ cd "${BUILD_DIR}" || die
+ ./openMittsuTests || die
+}
+
+src_install() {
+ local my_pn="openMittsu"
+ cmake_src_install
+ newicon resources/icon.png ${my_pn}.png
+ make_desktop_entry ${my_pn} ${my_pn} ${my_pn}
+ rm "${ED}"/usr/bin/${my_pn}VersionInfo || die
+ rm -f "${ED}"/usr/bin/${my_pn}Tests || die
+}