summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-accessibility/emacspeak-ss
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-accessibility/emacspeak-ss')
-rw-r--r--app-accessibility/emacspeak-ss/Manifest1
-rw-r--r--app-accessibility/emacspeak-ss/emacspeak-ss-1.9.1.ebuild32
-rw-r--r--app-accessibility/emacspeak-ss/files/gentoo-apollo-fix.patch24
-rw-r--r--app-accessibility/emacspeak-ss/metadata.xml20
4 files changed, 77 insertions, 0 deletions
diff --git a/app-accessibility/emacspeak-ss/Manifest b/app-accessibility/emacspeak-ss/Manifest
new file mode 100644
index 000000000000..c73124f6a434
--- /dev/null
+++ b/app-accessibility/emacspeak-ss/Manifest
@@ -0,0 +1 @@
+DIST emacspeak-ss-1.9.1.tar.gz 49077 SHA256 67131f9958381fd62be38b9c27b49d77d2d2d5cc4af1106d0dc9d74d2d9cf94e SHA512 a95505a1eaa0b45732d6d8e7322fb75bebc59b876233ae07c5912f1582f0be29d3258dfd5659993ce4b03f72eb316469de95688dcefb7ec61b4ef328f2f50335 WHIRLPOOL 54e838777f957a6e9f2f495db51b639448b7d71f2b9b6668fce58f6567998df56fd6f1582ed6d2435cac0c631efcc4054b766f692ddff805ec24f2f17cad5813
diff --git a/app-accessibility/emacspeak-ss/emacspeak-ss-1.9.1.ebuild b/app-accessibility/emacspeak-ss/emacspeak-ss-1.9.1.ebuild
new file mode 100644
index 000000000000..4bb348863573
--- /dev/null
+++ b/app-accessibility/emacspeak-ss/emacspeak-ss-1.9.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="adds support for several speech synthesizers to emacspeak"
+HOMEPAGE="http://leb.net/blinux/"
+SRC_URI="http://leb.net/pub/blinux/emacspeak/blinux/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 x86 ppc"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=app-accessibility/emacspeak-18"
+
+src_prepare() {
+ epatch "${FILESDIR}"/gentoo-apollo-fix.patch
+ tc-export CC
+}
+
+src_install() {
+ emake \
+ prefix="${D}"/usr \
+ man1dir="${D}"/usr/share/man/man1 \
+ install
+ dodoc CREDITS ChangeLog OtherSynthesizers TODO TROUBLESHOOTING README*
+}
diff --git a/app-accessibility/emacspeak-ss/files/gentoo-apollo-fix.patch b/app-accessibility/emacspeak-ss/files/gentoo-apollo-fix.patch
new file mode 100644
index 000000000000..3d8aa016453a
--- /dev/null
+++ b/app-accessibility/emacspeak-ss/files/gentoo-apollo-fix.patch
@@ -0,0 +1,24 @@
+diff -Naur emacspeak-ss-1.9.1.old/Makefile.in emacspeak-ss-1.9.1/Makefile.in
+--- emacspeak-ss-1.9.1.old/Makefile.in 2000-05-07 18:51:21.000000000 -0500
++++ emacspeak-ss-1.9.1/Makefile.in 2004-04-22 18:43:20.635283200 -0500
+@@ -3,7 +3,7 @@
+ man1dir=@mandir@/man1
+ exec_prefix = @exec_prefix@
+ bindir=$(prefix)/share/emacs/site-lisp/emacspeak/
+-libdir=$(prefix)/lib/emacs/common/emacspeak/
++libdir=$(prefix)/lib/emacspeak-ss
+
+ INSTALL=@INSTALL@
+ VERSION=@VERSION@
+diff -Naur emacspeak-ss-1.9.1.old/apollo.in emacspeak-ss-1.9.1/apollo.in
+--- emacspeak-ss-1.9.1.old/apollo.in 2000-05-07 18:27:31.000000000 -0500
++++ emacspeak-ss-1.9.1/apollo.in 2004-04-22 18:35:09.255401085 -0500
+@@ -101,7 +101,7 @@
+ # write the argument to the synthesizer, and return its response if any
+ proc tts_ping {query} {
+ global tts
+- set status [exec /usr/lib/emacs/common/emacspeak/ping-apollo "$query" $tts(port) ]
++ set status [exec /usr/lib/emacspeak-ss/ping-apollo "$query" $tts(port) ]
+ return $status
+ }
+
diff --git a/app-accessibility/emacspeak-ss/metadata.xml b/app-accessibility/emacspeak-ss/metadata.xml
new file mode 100644
index 000000000000..5e5b1e56d563
--- /dev/null
+++ b/app-accessibility/emacspeak-ss/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>accessibility</herd>
+<maintainer>
+ <email>williamh@gentoo.org</email>
+</maintainer>
+<longdescription lang="en">
+ Emacspeak speech servers for DoubleTalk PC and AT,
+ Braille 'n Speak, Type 'n Speak, Braille Lite from Blazie,
+ Accent SA, Apollo 2, JUNO, and JUNO-sp from Dolphin,
+ Spanish ciber 232 (+plus), Spanish PC Hablado notebook.
+</longdescription>
+<longdescription lang="ja">
+ DoubleTalkPC and ATとBraille 'n SpeakとType 'n SpeakとBlazieから
+ Braille LiteとAccent SAとApollo SAとApollo 2とDolphinからJUNO
+ and JUNO-spとSpanish ciber 232 (+plus)とSpanish PC Hablado
+ notebookのEmacspeakスピーチサーバーです。
+</longdescription>
+</pkgmetadata>