summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-11-26 00:22:11 +0100
committerMarek Szuba <marecki@gentoo.org>2021-11-26 00:39:45 +0100
commit0f693f801e8e4bc5e190203dbe7ed32f2e21a54f (patch)
tree447f34c32d3436b9e0c7105c15695d1593da264c /app-admin/ansible-molecule
parentnet-misc/ps3mediaserver: update EAPI 5 -> 8 (diff)
downloadgentoo-0f693f801e8e4bc5e190203dbe7ed32f2e21a54f.tar.gz
gentoo-0f693f801e8e4bc5e190203dbe7ed32f2e21a54f.tar.bz2
gentoo-0f693f801e8e4bc5e190203dbe7ed32f2e21a54f.zip
app-admin/ansible-molecule: drop 3.3.4
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-admin/ansible-molecule')
-rw-r--r--app-admin/ansible-molecule/Manifest1
-rw-r--r--app-admin/ansible-molecule/ansible-molecule-3.3.4.ebuild84
2 files changed, 0 insertions, 85 deletions
diff --git a/app-admin/ansible-molecule/Manifest b/app-admin/ansible-molecule/Manifest
index bf31ff02b74b..700d4ea41538 100644
--- a/app-admin/ansible-molecule/Manifest
+++ b/app-admin/ansible-molecule/Manifest
@@ -1,2 +1 @@
-DIST molecule-3.3.4.tar.gz 280980 BLAKE2B af704a8a8d709323441e6e6057bf7a62b0d89aa582eff4d9139b521ed0729c36836f324cd1741f441fae4ed4b9c148de76c2502a01ce5a7b142bfe32bc7fd391 SHA512 8ccc6e121d028bc9d477504a3e5067486d4a3e37f2c27a9686b068c9dac2185db7f965960affb4f9e958bb68d3c3a72786459ea3d221d781377d899b0d75d5a5
DIST molecule-3.5.2.tar.gz 290964 BLAKE2B b6c6bb8ecdb4230d23161e25fa003c8979f48fc1705bfba7d14204fbaa3e9c235a71db0c4ccbab5c4328ddb8a0725d3c2ba7cb4b624afda21c6453c8be824f3e SHA512 04a7d1f7e7e098c0ada71d8dc9a3e3a94320033942d8ee03f2c51ec185405d2ee13fcb44000a4942ec66923f0426717ab7e2c3a785ddda7a23515096474dc3c3
diff --git a/app-admin/ansible-molecule/ansible-molecule-3.3.4.ebuild b/app-admin/ansible-molecule/ansible-molecule-3.3.4.ebuild
deleted file mode 100644
index 5655e622e75f..000000000000
--- a/app-admin/ansible-molecule/ansible-molecule-3.3.4.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..9} )
-DISTUTILS_SINGLE_IMPL=1
-DISTUTILS_USE_SETUPTOOLS="rdepend"
-
-inherit distutils-r1
-
-MY_PN="${PN#ansible-}"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A toolkit designed to aid in the development and testing of Ansible roles"
-HOMEPAGE="https://pypi.org/project/molecule/ https://github.com/ansible-community/molecule/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="selinux"
-
-RDEPEND="$(python_gen_cond_dep '
- >=app-admin/ansible-lint-5.0.12[${PYTHON_USEDEP}]
- <dev-python/cerberus-1.3.3[${PYTHON_USEDEP}]
- >=dev-python/click-8.0[${PYTHON_USEDEP}]
- dev-python/click-help-colors[${PYTHON_USEDEP}]
- dev-python/enrich[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- <dev-python/paramiko-3[${PYTHON_USEDEP}]
- <dev-python/pluggy-1.0[${PYTHON_USEDEP}]
- <dev-python/pyyaml-6[${PYTHON_USEDEP}]
- dev-python/rich[${PYTHON_USEDEP}]
- dev-python/subprocess-tee[${PYTHON_USEDEP}]
- >=dev-util/cookiecutter-1.7.3[${PYTHON_USEDEP}]
- selinux? ( sys-libs/libselinux[python,${PYTHON_USEDEP}] )
-')"
-BDEPEND="$(python_gen_cond_dep '
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]
- doc? (
- dev-python/simplejson[${PYTHON_USEDEP}]
- )
- test? (
- dev-python/ansi2html[${PYTHON_USEDEP}]
- <dev-python/pexpect-5[${PYTHON_USEDEP}]
- dev-python/pytest-helpers-namespace[${PYTHON_USEDEP}]
- >=dev-python/pytest-html-3.0.0[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/pytest-plus[${PYTHON_USEDEP}]
- dev-python/pytest-testinfra[${PYTHON_USEDEP}]
- dev-python/pytest-verbose-parametrize[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
-')"
-
-S="${WORKDIR}"/${MY_P}
-
-distutils_enable_sphinx docs '>=dev-python/sphinx-notfound-page-0.7.1' 'dev-python/sphinx_ansible_theme'
-distutils_enable_tests --install pytest
-
-src_prepare() {
- default
-
- if ! use selinux; then
- sed -i "/^\s\+selinux/d" setup.cfg || die "Failed to remove dependency on SELinux"
- fi
-
- # Several issues with tests from this file:
- # - quite a few of these use the network;
- # - test_command_dependency[shell] only works if Molecule has previously been installed;
- # - tests involving creation of a new scenario fail on ansible-lint errors, even though
- # a config file is deployed which should skip expected issues.
- rm -f src/molecule/test/functional/test_command.py
- # Uses unpackaged yamllint
- rm -f src/molecule/test/unit/cookiecutter/test_molecule.py
-}
-
-python_test() {
- distutils_install_for_testing --via-venv
- distutils-r1_python_test
-}