summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/conkyforecast
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/conkyforecast')
-rw-r--r--app-admin/conkyforecast/Manifest1
-rw-r--r--app-admin/conkyforecast/conkyforecast-2.24-r1.ebuild45
-rw-r--r--app-admin/conkyforecast/metadata.xml11
3 files changed, 57 insertions, 0 deletions
diff --git a/app-admin/conkyforecast/Manifest b/app-admin/conkyforecast/Manifest
new file mode 100644
index 000000000000..4688cca395aa
--- /dev/null
+++ b/app-admin/conkyforecast/Manifest
@@ -0,0 +1 @@
+DIST conkyforecast_2.24.tar.gz 11347231 SHA256 251dba60bc209a2f4181de856abb1fe553e8b983d1af40998235061e8679a54d SHA512 dcff08915c00915f6be4cd25824e3d8de978ed15ffb6776f002d585d95856f5e0827632371dd4d37016e07d58542e2bc95a7a859ebdc8ab9d1200ac04d4364e0 WHIRLPOOL d7a6967e09a52eeac98ab13f64f3ab86a29f1964b7b79951c78b08f7e42c67d6d41e5c339bd1d7dedad687c523bd7fd059d529d076894d19af2a1c2a8180e718
diff --git a/app-admin/conkyforecast/conkyforecast-2.24-r1.ebuild b/app-admin/conkyforecast/conkyforecast-2.24-r1.ebuild
new file mode 100644
index 000000000000..ad5f02ca7983
--- /dev/null
+++ b/app-admin/conkyforecast/conkyforecast-2.24-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# upstream broke setup.py to install into /usr/share...
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Conky weather forecast script with support for language files"
+HOMEPAGE="https://launchpad.net/~conky-companions"
+SRC_URI="https://launchpad.net/~conky-companions/+archive/ppa/+files/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-admin/conky"
+
+S=${WORKDIR}/src
+
+python_prepare_all() {
+ sed -i -e "s:pythoncmd=.*$:pythoncmd=${EPYTHON}:" conkyForecast* || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ python_optimize "${ED%/}"/usr/share/${PN}
+}
+
+pkg_postinst() {
+ elog "You have to define a partner id and registration code for "
+ elog "the weather.com xoap. You need to copy the template from"
+ elog "/usr/share/conkyforecast/conkyForecast.config into you account"
+ elog "as ~/.conkyForecast.config and edit the respective fields."
+ elog
+ elog "More details can be found in the README file."
+}
diff --git a/app-admin/conkyforecast/metadata.xml b/app-admin/conkyforecast/metadata.xml
new file mode 100644
index 000000000000..7ad6f3ff7899
--- /dev/null
+++ b/app-admin/conkyforecast/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="launchpad">~conky-companions</remote-id>
+ </upstream>
+</pkgmetadata>