summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/puppet-agent
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/puppet-agent')
-rw-r--r--app-admin/puppet-agent/Manifest2
-rw-r--r--app-admin/puppet-agent/files/mcollective.initd19
-rw-r--r--app-admin/puppet-agent/files/mcollective.service14
-rw-r--r--app-admin/puppet-agent/files/puppet-agent.conf.tmpfilesd1
-rw-r--r--app-admin/puppet-agent/files/puppet.initd30
-rw-r--r--app-admin/puppet-agent/files/puppet.service14
-rw-r--r--app-admin/puppet-agent/metadata.xml14
-rw-r--r--app-admin/puppet-agent/puppet-agent-1.2.2-r1.ebuild65
-rw-r--r--app-admin/puppet-agent/puppet-agent-1.2.2-r2.ebuild76
9 files changed, 235 insertions, 0 deletions
diff --git a/app-admin/puppet-agent/Manifest b/app-admin/puppet-agent/Manifest
new file mode 100644
index 000000000000..81fb2e1cba27
--- /dev/null
+++ b/app-admin/puppet-agent/Manifest
@@ -0,0 +1,2 @@
+DIST puppet-agent_1.2.2-1wheezy_amd64.deb 14860604 SHA256 5910ff850e8814092b50dc70a68d8c5497d5fe3d960bfef9cd13f8dc689dc665 SHA512 ad11b0ba820186f4b315ac156e8bf78348acd69d11e4c03cb12314fc73e4e3fbfef0814664e7fd04f692e8db42f9e137194e267354b2fc4ec8dda424af9f5d98 WHIRLPOOL 25c42e9f7871ccf61eb55b83327813e6090ee359c42e1e473ef09155db69adebfe412fd61a5752b4b634e5ad8aa7bd45d4a86f7e5ba29c1bdb74033b91f45c3f
+DIST puppet-agent_1.2.2-1wheezy_i386.deb 14816930 SHA256 092b8bfe1e1156322d0ab68d411487c80146bd778916409b1c907791f41a49c8 SHA512 50879ce4eebcd451dafb33cb7a12c36ee9bcaedfc29ffa0d60552efa5aa4cd66d0007061d28a80d31615c67442f8526863185e6753418772d8275e58454d6886 WHIRLPOOL 7abb0b6f52f5dd07a5ccb56b1c795c05f8c4efd18665d2ca209400e51419e4ae335e630a845c031a47df09d96ce20fbc92d7cafa082deb3872306daf74838612
diff --git a/app-admin/puppet-agent/files/mcollective.initd b/app-admin/puppet-agent/files/mcollective.initd
new file mode 100644
index 000000000000..1fc171586e98
--- /dev/null
+++ b/app-admin/puppet-agent/files/mcollective.initd
@@ -0,0 +1,19 @@
+#!/sbin/runscript
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+MCOLLECTIVE_PID_DIR="${MCOLLECTIVE_PID_DIR:-/var/run/puppetlabs}"
+
+command="/usr/sbin/mcollectived"
+pidfile="${MCOLLECTIVE_PID_DIR}/mcollectived.pid"
+
+command_args="--pidfile ${pidfile} --config=/etc/puppetlabs/mcollective/server.cfg --daemonize"
+
+depend() {
+ need net
+}
+
+start_pre() {
+ checkpath --directory "${MCOLLECTIVE_PID_DIR}"
+}
diff --git a/app-admin/puppet-agent/files/mcollective.service b/app-admin/puppet-agent/files/mcollective.service
new file mode 100644
index 000000000000..9e90c9e67280
--- /dev/null
+++ b/app-admin/puppet-agent/files/mcollective.service
@@ -0,0 +1,14 @@
+[Unit]
+Description=The Marionette Collective
+After=network.target
+
+[Service]
+Type=forking
+StandardOutput=syslog
+StandardError=syslog
+ExecStart=/usr/sbin/bin/mcollectived --config=/etc/puppetlabs/mcollective/server.cfg --pidfile=/var/run/puppetlabs/mcollective.pid --daemonize
+ExecReload=/bin/kill -USR1 $MAINPID
+PIDFile=/var/run/puppetlabs/mcollective.pid
+
+[Install]
+WantedBy=multi-user.target
diff --git a/app-admin/puppet-agent/files/puppet-agent.conf.tmpfilesd b/app-admin/puppet-agent/files/puppet-agent.conf.tmpfilesd
new file mode 100644
index 000000000000..42d082111940
--- /dev/null
+++ b/app-admin/puppet-agent/files/puppet-agent.conf.tmpfilesd
@@ -0,0 +1 @@
+d /var/run/puppetlabs 0755 root root -
diff --git a/app-admin/puppet-agent/files/puppet.initd b/app-admin/puppet-agent/files/puppet.initd
new file mode 100644
index 000000000000..693ab1496c61
--- /dev/null
+++ b/app-admin/puppet-agent/files/puppet.initd
@@ -0,0 +1,30 @@
+#!/sbin/runscript
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+PUPPET_PID_DIR="${PUPPET_PID_DIR:-/var/run/puppet}"
+
+pidfile="${PUPPET_PID_DIR}/puppet.pid"
+PUPPET_LOG_DIR="/var/log/puppetlabs/puppet"
+
+command="/usr/bin/puppet"
+extra_started_commands="reload"
+
+command_args="agent --pidfile ${pidfile} --confdir /etc/puppetlabs/puppet ${PUPPET_EXTRA_OPTS}"
+
+depend() {
+ need localmount
+ use dns logger puppetserver netmount nfsmount
+}
+
+start_pre() {
+ checkpath --directory --owner puppet:puppet "${PUPPET_PID_DIR}"
+ checkpath --directory --owner puppet:puppet --mode 750 ${PUPPET_LOG_DIR}
+}
+
+reload() {
+ ebegin "Reloading $RC_SVCNAME"
+ start-stop-daemon --signal HUP --pidfile "${pidfile}"
+ eend $?
+}
diff --git a/app-admin/puppet-agent/files/puppet.service b/app-admin/puppet-agent/files/puppet.service
new file mode 100644
index 000000000000..61b03134b331
--- /dev/null
+++ b/app-admin/puppet-agent/files/puppet.service
@@ -0,0 +1,14 @@
+[Unit]
+Description=Puppet agent
+Wants=basic.target
+After=basic.target network.target
+
+[Service]
+EnvironmentFile=-/etc/sysconfig/puppetagent
+EnvironmentFile=-/etc/sysconfig/puppet
+EnvironmentFile=-/etc/default/puppet
+ExecStart=/opt/puppetlabs/puppet/bin/puppet agent $PUPPET_EXTRA_OPTS --no-daemonize
+KillMode=process
+
+[Install]
+WantedBy=multi-user.target
diff --git a/app-admin/puppet-agent/metadata.xml b/app-admin/puppet-agent/metadata.xml
new file mode 100644
index 000000000000..e0523b408eb0
--- /dev/null
+++ b/app-admin/puppet-agent/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <use>
+ <flag name="puppetdb">Adds puppetdb support</flag>
+ </use>
+ <longdescription lang="en">
+ Collection of puppet utils, clients and batteries included.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-admin/puppet-agent/puppet-agent-1.2.2-r1.ebuild b/app-admin/puppet-agent/puppet-agent-1.2.2-r1.ebuild
new file mode 100644
index 000000000000..f9888cf28fd0
--- /dev/null
+++ b/app-admin/puppet-agent/puppet-agent-1.2.2-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils systemd unpacker
+
+DESCRIPTION="general puppet client utils along with mcollective hiera and facter"
+HOMEPAGE="https://puppetlabs.com/"
+SRC_BASE="http://apt.puppetlabs.com/pool/wheezy/PC1/${PN:0:1}/${PN}/${PN}_${PV}-1wheezy"
+SRC_URI="
+ amd64? ( ${SRC_BASE}_amd64.deb )
+ x86? ( ${SRC_BASE}_i386.deb )
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="puppetdb"
+RESTRICT="strip"
+
+CDEPEND="!app-admin/puppet
+ !app-admin/mcollective
+ !dev-ruby/hiera
+ !dev-ruby/facter"
+
+DEPEND="
+ ${DEPEND}
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}
+ puppetdb? ( >=dev-ruby/puppetdb-termini-3.0.1-r2 )"
+
+S=${WORKDIR}
+
+src_install() {
+ # conf.d
+ doconfd etc/default/puppet
+ doconfd etc/default/mcollective
+ # logrotate.d
+ insinto /etc/logrotate.d
+ doins etc/logrotate.d/mcollective
+ # puppet itself
+ insinto /etc/puppetlabs
+ doins -r etc/puppetlabs/*
+ # logdir for systemd
+ dodir var/log/puppetlabs/puppet/
+ fperms 0750 var/log/puppetlabs/puppet/
+ # the rest
+ insinto /opt
+ doins -r opt/*
+ fperms 0750 /opt/puppetlabs/puppet/cache
+ # init
+ newinitd "${FILESDIR}/puppet.initd" puppet
+ newinitd "${FILESDIR}/mcollective.initd" mcollective
+ systemd_dounit "${FILESDIR}/puppet.service"
+ systemd_dounit "${FILESDIR}/mcollective.service"
+ systemd_newtmpfilesd "${FILESDIR}/puppet-agent.conf.tmpfilesd" puppet-agent.conf
+ # symlinks
+ chmod 0755 -R "${D}/opt/puppetlabs/puppet/bin/"
+ dosym /opt/puppetlabs/bin/facter /usr/bin/facter
+ dosym /opt/puppetlabs/bin/hiera /usr/bin/hiera
+ dosym /opt/puppetlabs/bin/mco /usr/bin/mco
+ dosym /opt/puppetlabs/bin/puppet /usr/bin/puppet
+ dosym /opt/puppetlabs/puppet/bin/mcollectived /usr/sbin/mcollectived
+}
diff --git a/app-admin/puppet-agent/puppet-agent-1.2.2-r2.ebuild b/app-admin/puppet-agent/puppet-agent-1.2.2-r2.ebuild
new file mode 100644
index 000000000000..2af998ef77bd
--- /dev/null
+++ b/app-admin/puppet-agent/puppet-agent-1.2.2-r2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils systemd unpacker
+
+DESCRIPTION="general puppet client utils along with mcollective hiera and facter"
+HOMEPAGE="https://puppetlabs.com/"
+SRC_BASE="http://apt.puppetlabs.com/pool/wheezy/PC1/${PN:0:1}/${PN}/${PN}_${PV}-1wheezy"
+SRC_URI="
+ amd64? ( ${SRC_BASE}_amd64.deb )
+ x86? ( ${SRC_BASE}_i386.deb )
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="puppetdb selinux"
+RESTRICT="strip"
+
+CDEPEND="!app-admin/augeas
+ !app-admin/mcollective
+ !app-admin/puppet
+ !dev-ruby/hiera
+ !dev-ruby/facter
+ !app-emulation/virt-what"
+
+DEPEND="
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}
+ sys-apps/dmidecode
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ puppetdb? ( >=dev-ruby/puppetdb-termini-3.0.1-r2 )"
+
+S=${WORKDIR}
+
+src_install() {
+ # conf.d
+ doconfd etc/default/puppet
+ doconfd etc/default/mcollective
+ # logrotate.d
+ insinto /etc/logrotate.d
+ doins etc/logrotate.d/mcollective
+ # puppet itself
+ insinto /etc/puppetlabs
+ doins -r etc/puppetlabs/*
+ # logdir for systemd
+ dodir var/log/puppetlabs/puppet/
+ fperms 0750 var/log/puppetlabs/puppet/
+ # the rest
+ insinto /opt
+ doins -r opt/*
+ fperms 0750 /opt/puppetlabs/puppet/cache
+ # init
+ newinitd "${FILESDIR}/puppet.initd" puppet
+ newinitd "${FILESDIR}/mcollective.initd" mcollective
+ systemd_dounit "${FILESDIR}/puppet.service"
+ systemd_dounit "${FILESDIR}/mcollective.service"
+ systemd_newtmpfilesd "${FILESDIR}/puppet-agent.conf.tmpfilesd" puppet-agent.conf
+ # symlinks
+ chmod 0755 -R "${D}/opt/puppetlabs/puppet/bin/"
+ chmod 0755 "${D}//opt/puppetlabs/puppet/lib/virt-what/virt-what-cpuid-helper"
+ dosym /opt/puppetlabs/bin/facter /usr/bin/facter
+ dosym /opt/puppetlabs/bin/hiera /usr/bin/hiera
+ dosym /opt/puppetlabs/bin/mco /usr/bin/mco
+ dosym /opt/puppetlabs/bin/puppet /usr/bin/puppet
+ dosym /opt/puppetlabs/puppet/bin/mcollectived /usr/sbin/mcollectived
+ dosym /opt/puppetlabs/puppet/bin/virt-what /usr/bin/virt-what
+ dosym /opt/puppetlabs/puppet/bin/augparse /usr/bin/augparse
+ dosym /opt/puppetlabs/puppet/bin/augtool /usr/bin/augtool
+ dosym /opt/puppetlabs/puppet/bin/extlookup2hiera /usr/bin/extlookup2hiera
+}