summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-12-29 19:19:45 +0100
committerDavid Seifert <soap@gentoo.org>2017-12-29 23:31:35 +0100
commitf02fd345af8723ded889d886328c1e5fbf176190 (patch)
tree3af1b0864e4025ee0213bb0d61630cff50f3ad5b /app-admin
parentapp-admin/aws-cw-tools: Port to EAPI 6 (diff)
downloadgentoo-f02fd345af8723ded889d886328c1e5fbf176190.tar.gz
gentoo-f02fd345af8723ded889d886328c1e5fbf176190.tar.bz2
gentoo-f02fd345af8723ded889d886328c1e5fbf176190.zip
app-admin/aws-as-tools: Port to EAPI 6
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/aws-as-tools/aws-as-tools-1.0.49.1.ebuild40
1 files changed, 20 insertions, 20 deletions
diff --git a/app-admin/aws-as-tools/aws-as-tools-1.0.49.1.ebuild b/app-admin/aws-as-tools/aws-as-tools-1.0.49.1.ebuild
index 38450b0e2f07..a9b3692c2a2a 100644
--- a/app-admin/aws-as-tools/aws-as-tools-1.0.49.1.ebuild
+++ b/app-admin/aws-as-tools/aws-as-tools-1.0.49.1.ebuild
@@ -1,44 +1,43 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="2"
+EAPI=6
DESCRIPTION="The API tools serve as the client interface to the Auto Scaling web service"
HOMEPAGE="http://aws.amazon.com/developertools/2535"
# SRC_URI="http://ec2-downloads.s3.amazonaws.com/AutoScaling-2011-01-01.zip"
SRC_URI="mirror://sabayon/app-admin/AutoScaling-1.0.49.1.zip"
-S="${WORKDIR}/AutoScaling-${PV}"
-
LICENSE="Amazon"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
+RESTRICT="mirror"
+
DEPEND="app-arch/unzip"
RDEPEND="virtual/jre"
-RESTRICT="mirror"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+S="${WORKDIR}/AutoScaling-${PV}"
+
+src_prepare() {
+ default
+
find . -name '*.cmd' -delete || die
- rm bin/as-cmd-2009-05-15
- rm bin/service-2009-05-15
+ rm bin/{as-cmd,service}-2009-05-15 || die
}
src_install() {
- dodir /opt/${PN}
insinto /opt/${PN}/lib
- doins -r "${S}"/lib/*
+ doins -r lib/.
+
exeinto /opt/${PN}/bin
- doexe "${S}"/bin/*
-
- dodir /etc/env.d
- cat - > "${T}"/99${PN} <<EOF
-AWS_AUTO_SCALING_HOME=/opt/${PN}
-PATH=/opt/${PN}/bin
-ROOTPATH=/opt/${PN}/bin
-EOF
+ doexe bin/*
+
+ cat > "${T}"/99${PN} <<- EOF || die
+ AWS_AUTO_SCALING_HOME=/opt/${PN}
+ PATH=/opt/${PN}/bin
+ ROOTPATH=/opt/${PN}/bin
+ EOF
doenvd "${T}"/99${PN}
dodoc "THIRDPARTYLICENSE.TXT"
@@ -48,6 +47,7 @@ pkg_postinst() {
ewarn "Remember to run: env-update && source /etc/profile if you plan"
ewarn "to use these tools in a shell before logging out (or restarting"
ewarn "your login manager)"
+
elog
elog "You need to put the following in your ~/.bashrc replacing the"
elog "values with the full path to your AWS credentials file."