summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2017-04-08 23:00:46 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2017-04-08 23:01:05 +0200
commitb9e23fef4a950169e3b800fd50e4bd698af7b910 (patch)
tree2729694a9c162e0cb85ccc87153418934e0cdd4f /app-arch/bsdsfv
parentdev-php/pecl-ssh2: new v0.13 revision supporting PHP_TARGETS=php7-1. (diff)
downloadgentoo-b9e23fef4a950169e3b800fd50e4bd698af7b910.tar.gz
gentoo-b9e23fef4a950169e3b800fd50e4bd698af7b910.tar.bz2
gentoo-b9e23fef4a950169e3b800fd50e4bd698af7b910.zip
app-arch/bsdsfv: EAPI bump, see bug 605728
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'app-arch/bsdsfv')
-rw-r--r--app-arch/bsdsfv/bsdsfv-1.18-r2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-arch/bsdsfv/bsdsfv-1.18-r2.ebuild b/app-arch/bsdsfv/bsdsfv-1.18-r2.ebuild
new file mode 100644
index 000000000000..58010f9828fa
--- /dev/null
+++ b/app-arch/bsdsfv/bsdsfv-1.18-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="all-in-one SFV checksum utility"
+HOMEPAGE="http://bsdsfv.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~m68k ~ppc ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+S=${WORKDIR}/${PN}
+
+PATCHES=( "${FILESDIR}"/${P}-64bit.patch )
+
+src_compile() {
+ emake STRIP=true CC=$(tc-getCC)
+}
+
+src_install() {
+ dobin bsdsfv
+ dodoc README MANUAL
+}