summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-arch/dump
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-arch/dump')
-rw-r--r--app-arch/dump/Manifest1
-rw-r--r--app-arch/dump/dump-0.4.44-r1.ebuild64
-rw-r--r--app-arch/dump/files/dump-0.4.44-fix-pointers-aliasing.patch126
-rw-r--r--app-arch/dump/files/dump-0.4.44-rl_completion_matches-detection.patch24
-rw-r--r--app-arch/dump/files/dump-0.4.44-underlinking.patch31
-rw-r--r--app-arch/dump/metadata.xml14
6 files changed, 260 insertions, 0 deletions
diff --git a/app-arch/dump/Manifest b/app-arch/dump/Manifest
new file mode 100644
index 000000000000..8c184d0f4459
--- /dev/null
+++ b/app-arch/dump/Manifest
@@ -0,0 +1 @@
+DIST dump-0.4b44.tar.gz 296691 SHA256 78cb75632ac5e99dca38af3a2574303eee3c5a7af464011d279421d8b0e64f96 SHA512 3db828bac026d872913f0e010378366919fbb523d22f1863c06017581e4f4a1c5a239199794ca1158b04e7e3ecbb596d77b131b3278bed29fcfcd3835a3351d4 WHIRLPOOL 43dfc8fb996b443b9d9a9d9ecbf7d01f3db6eaba7acc92ab35ee0930ebdc7666855fc6b78b25450ae3790c6f10093036e0fc733385d7e8dc808bb614b681135a
diff --git a/app-arch/dump/dump-0.4.44-r1.ebuild b/app-arch/dump/dump-0.4.44-r1.ebuild
new file mode 100644
index 000000000000..641d0475eeea
--- /dev/null
+++ b/app-arch/dump/dump-0.4.44-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+inherit eutils autotools
+
+MY_P=${P/4./4b}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Dump/restore ext2fs backup utilities"
+HOMEPAGE="http://dump.sourceforge.net/"
+SRC_URI="mirror://sourceforge/dump/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 ~hppa ia64 ppc ppc64 sparc x86"
+IUSE="debug ermt readline selinux static"
+
+RDEPEND=">=sys-fs/e2fsprogs-1.27
+ >=app-arch/bzip2-1.0.2
+ >=sys-libs/zlib-1.1.4
+ ermt? ( dev-libs/openssl )
+ readline? ( sys-libs/readline
+ sys-libs/ncurses
+ static? ( sys-libs/ncurses[static-libs] ) )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ virtual/os-headers"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-underlinking.patch"
+ epatch "${FILESDIR}/${P}-rl_completion_matches-detection.patch"
+ epatch "${FILESDIR}/${P}-fix-pointers-aliasing.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-dumpdatespath=/etc/dumpdates \
+ --with-{bin,man}owner=root \
+ --with-{bin,man}grp=root \
+ --enable-largefile \
+ $(use_enable selinux transselinux) \
+ $(use_enable ermt) \
+ $(use_enable static) \
+ $(use_enable readline) \
+ $(use_enable debug)
+}
+
+src_install() {
+ # built on old autotools, no DESTDIR support
+ einstall MANDIR="${D}"/usr/share/man/man8
+ mv "${ED}"/usr/sbin/{,dump-}rmt || die
+ mv "${ED}"/usr/share/man/man8/{,dump-}rmt.8 || die
+ use ermt && newsbin rmt/ermt dump-ermt
+
+ dodoc CHANGES KNOWNBUGS MAINTAINERS README REPORTING-BUGS THANKS TODO
+ dodoc -r examples/*
+}
+
+pkg_postinst() {
+ ewarn "app-arch/dump installs 'rmt' as 'dump-rmt'."
+ ewarn "This is to avoid conflicts with app-arch/tar 'rmt'."
+}
diff --git a/app-arch/dump/files/dump-0.4.44-fix-pointers-aliasing.patch b/app-arch/dump/files/dump-0.4.44-fix-pointers-aliasing.patch
new file mode 100644
index 000000000000..6e3290085470
--- /dev/null
+++ b/app-arch/dump/files/dump-0.4.44-fix-pointers-aliasing.patch
@@ -0,0 +1,126 @@
+https://sourceforge.net/tracker/?func=detail&aid=3322910&group_id=1306&atid=301306
+
+=== modified file 'dump/tape.c'
+--- dump/tape.c 2011-06-20 07:22:40 +0000
++++ dump/tape.c 2011-06-20 07:57:11 +0000
+@@ -1281,9 +1281,9 @@
+ compresult = 1;
+ #ifdef HAVE_ZLIB
+ if (zipflag == COMPRESS_ZLIB) {
+- compresult = compress2(comp_buf->buf,
++ compresult = compress2((Bytef *)comp_buf->buf,
+ &worklen,
+- (char *)slp->tblock[0],
++ (Bytef *)slp->tblock[0],
+ writesize,
+ compressed);
+ if (compresult == Z_OK)
+@@ -1313,8 +1313,9 @@
+ #ifdef HAVE_LZO
+ if (zipflag == COMPRESS_LZO) {
+ lzo_uint worklen2 = worklen;
+- compresult = lzo1x_1_compress((char *)slp->tblock[0],writesize,
+- comp_buf->buf,
++ compresult = lzo1x_1_compress((lzo_bytep)slp->tblock[0],
++ writesize,
++ (lzo_bytep)comp_buf->buf,
+ &worklen2,
+ LZO_WorkMem);
+ worklen = worklen2;
+
+=== modified file 'dump/traverse.c'
+--- dump/traverse.c 2011-06-20 07:22:40 +0000
++++ dump/traverse.c 2011-06-20 07:57:11 +0000
+@@ -782,13 +782,13 @@
+ for (i = p->next_block; i < blockcnt; i++) {
+ p->buf[p->cnt++] = 0;
+ if (p->cnt == p->max) {
+- blksout (p->buf, p->cnt, p->ino);
++ blksout ((blk_t *)p->buf, p->cnt, p->ino);
+ p->cnt = 0;
+ }
+ }
+ p->buf[p->cnt++] = *blocknr;
+ if (p->cnt == p->max) {
+- blksout (p->buf, p->cnt, p->ino);
++ blksout ((blk_t *)p->buf, p->cnt, p->ino);
+ p->cnt = 0;
+ }
+ p->next_block = blockcnt + 1;
+@@ -868,14 +868,15 @@
+ void
+ dumpino(struct dinode *dp, dump_ino_t ino, int metaonly)
+ {
++ fsizeT remaining;
++ char buf[TP_BSIZE];
++ struct new_bsd_inode nbi;
++ int i;
++#ifdef __linux__
++ struct block_context bc;
++#else
+ unsigned long cnt;
+- fsizeT size, remaining;
+- char buf[TP_BSIZE];
+- struct new_bsd_inode nbi;
+- int i;
+-#ifdef __linux__
+- struct block_context bc;
+-#else
++ fsizeT size;
+ int ind_level;
+ #endif
+ u_quad_t i_size;
+@@ -1001,13 +1002,13 @@
+ for (i = 0; i < (int)howmany(remaining, sblock->fs_fsize); i++) {
+ bc.buf[bc.cnt++] = 0;
+ if (bc.cnt == bc.max) {
+- blksout (bc.buf, bc.cnt, bc.ino);
++ blksout ((blk_t *)bc.buf, bc.cnt, bc.ino);
+ bc.cnt = 0;
+ }
+ }
+ }
+ if (bc.cnt > 0) {
+- blksout (bc.buf, bc.cnt, bc.ino);
++ blksout ((blk_t *)bc.buf, bc.cnt, bc.ino);
+ }
+ free(bc.buf);
+ dump_xattr(ino, dp);
+@@ -1016,7 +1017,7 @@
+ cnt = NDADDR * sblock->fs_frag;
+ else
+ cnt = howmany(i_size, sblock->fs_fsize);
+- blksout(&dp->di_db[0], cnt, ino);
++ blksout((blk_t *)&dp->di_db[0], cnt, ino);
+ if ((quad_t) (size = i_size - NDADDR * sblock->fs_bsize) <= 0) {
+ dump_xattr(ino, dp);
+ return;
+
+=== modified file 'restore/tape.c'
+--- restore/tape.c 2011-06-20 07:22:40 +0000
++++ restore/tape.c 2011-06-20 07:57:11 +0000
+@@ -2335,8 +2335,10 @@
+ #ifndef HAVE_ZLIB
+ errx(1,"This restore version doesn't support zlib decompression");
+ #else
+- cresult = uncompress(comprbuf, &worklen,
+- tpbin->buf, blocklen);
++ cresult = uncompress((Bytef *)comprbuf,
++ &worklen,
++ (Bytef *)tpbin->buf,
++ blocklen);
+ output = comprbuf;
+ switch (cresult) {
+ case Z_OK:
+@@ -2397,8 +2399,8 @@
+ errx(1,"This restore version doesn't support lzo decompression");
+ #else
+ lzo_uint worklen2 = worklen;
+- cresult = lzo1x_decompress(tpbin->buf, blocklen,
+- comprbuf, &worklen2, NULL);
++ cresult = lzo1x_decompress((lzo_bytep)tpbin->buf, blocklen,
++ (lzo_bytep)comprbuf, &worklen2, NULL);
+ worklen = worklen2;
+ output = comprbuf;
+ switch (cresult) {
+
diff --git a/app-arch/dump/files/dump-0.4.44-rl_completion_matches-detection.patch b/app-arch/dump/files/dump-0.4.44-rl_completion_matches-detection.patch
new file mode 100644
index 000000000000..6f968f549d7c
--- /dev/null
+++ b/app-arch/dump/files/dump-0.4.44-rl_completion_matches-detection.patch
@@ -0,0 +1,24 @@
+https://sourceforge.net/tracker/?func=detail&aid=3322906&group_id=1306&atid=301306
+
+=== modified file 'configure.in'
+--- configure.in 2011-06-20 07:22:40 +0000
++++ configure.in 2011-06-20 07:56:19 +0000
+@@ -516,7 +516,7 @@
+ dnl
+ dnl Check for rl_completion_matches
+ dnl
+-AC_CHECK_LIB(readline, rl_completion_matches, [rlcm=yes], [rlcm=no], "-ltermcap")
++AC_CHECK_LIB(readline, rl_completion_matches, [rlcm=yes], [rlcm=no], [$rdllib])
+ if test "$rlcm" = yes; then
+ AC_DEFINE([HAVE_READLINE_RLCM],1,[Define this if your readline libs have the rl_completion_matches library.])
+ fi
+@@ -524,7 +524,7 @@
+ dnl
+ dnl Check for rl_completion_append_character
+ dnl
+-AC_CHECK_LIB(readline, rl_completion_append_character, [rcac=yes], [rcac=no], "-ltermcap")
++AC_CHECK_LIB(readline, rl_completion_append_character, [rcac=yes], [rcac=no], [$rdllib])
+ if test "$rcac" = yes; then
+ AC_DEFINE([HAVE_READLINE_CAC],1,[Define this if your readline libs have the rl_completion_append_character variable.])
+ fi
+
diff --git a/app-arch/dump/files/dump-0.4.44-underlinking.patch b/app-arch/dump/files/dump-0.4.44-underlinking.patch
new file mode 100644
index 000000000000..b211f0079769
--- /dev/null
+++ b/app-arch/dump/files/dump-0.4.44-underlinking.patch
@@ -0,0 +1,31 @@
+diff --git a/MCONFIG.in b/MCONFIG.in
+index 64cb016..f5d1012 100644
+--- a/MCONFIG.in
++++ b/MCONFIG.in
+@@ -40,7 +40,7 @@ GINC+= @EXT2FS_CFLAGS@
+ # indicate where the ext2fs library can be found (this is not needed if you
+ # have run `make install-libs' in the e2fsprogs source directory).
+ #GLIBDIR= -L/usr/src/e2fsprogs-0.5c/lib
+-GLIBS= $(GLIBDIR) -L../compat/lib -lcompat @EXT2FS_LIBS@
++GLIBS= $(GLIBDIR) -L../compat/lib -lcompat @EXT2FS_LIBS@ @COM_ERR_LIBS@
+
+ #
+ # Definitions (don't change them unless you know what you are doing)
+diff --git a/configure.in b/configure.in
+index 2d69157..c8a9e04 100644
+--- a/configure.in
++++ b/configure.in
+@@ -414,11 +414,12 @@ fi
+ if test "$ext2fs_h" = no -o "x$EXT2FS_LIBS" = "x"; then
+ AC_MSG_ERROR(You need to install the Ext2fs libraries from the E2fsprogs distribution first - hint: make install-libs)
+ fi
++PKG_CHECK_MODULES(COM_ERR, [com_err])
+
+ dnl
+ dnl Check for ext2fs_read_inode_full
+ dnl
+-AC_CHECK_LIB(ext2fs, ext2fs_read_inode_full, [rif=yes], [rif=no], [-lcom_err])
++AC_CHECK_LIB(ext2fs, ext2fs_read_inode_full, [rif=yes], [rif=no], [$COM_ERR_LIBS])
+ if test "$rif" = yes; then
+ AC_DEFINE([HAVE_EXT2FS_READ_INODE_FULL],1,[Define this if your ext2fs libs have the ext2fs_read_inode_full function.])
+ fi
diff --git a/app-arch/dump/metadata.xml b/app-arch/dump/metadata.xml
new file mode 100644
index 000000000000..1d2ab7dac1e1
--- /dev/null
+++ b/app-arch/dump/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>base-system</herd>
+ <longdescription>
+ A utility to help backup and restore files on a harddrive.
+ </longdescription>
+ <use>
+ <flag name="ermt">encrypted rmt support</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">dump</remote-id>
+ </upstream>
+</pkgmetadata>