summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristophe Lermytte <gentoo@lermytte.be>2020-03-25 21:38:44 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-04-05 17:26:44 +0300
commit97d66bfc5b69fdbfb1d511831456766725839c90 (patch)
tree1862d279d5de13457c3e994d0d8cb0a2caa5acac /app-arch/engrampa
parentdev-python/tqdm: 4.45.0 (diff)
downloadgentoo-97d66bfc5b69fdbfb1d511831456766725839c90.tar.gz
gentoo-97d66bfc5b69fdbfb1d511831456766725839c90.tar.bz2
gentoo-97d66bfc5b69fdbfb1d511831456766725839c90.zip
app-arch/engrampa: bump to 1.22.2, fixing glib compatibility issue
- Dropping keywords as 1.22.1-r1 is still working on stable arches (older glib) - Dropping non-existent blocker app-arch/mate-file-archiver - Replace use of readme.gentoo-r1.eclass with eutils (optfeature) - Update copyright Package-Manager: Portage-2.3.94, Repoman-2.3.21 Closes: https://bugs.gentoo.org/714482 Signed-off-by: Christophe Lermytte <gentoo@lermytte.be> Closes: https://github.com/gentoo/gentoo/pull/15115 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-arch/engrampa')
-rw-r--r--app-arch/engrampa/Manifest1
-rw-r--r--app-arch/engrampa/engrampa-1.22.2.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/app-arch/engrampa/Manifest b/app-arch/engrampa/Manifest
index bf03ebd11e92..920bb8b9ee97 100644
--- a/app-arch/engrampa/Manifest
+++ b/app-arch/engrampa/Manifest
@@ -1 +1,2 @@
DIST engrampa-1.22.1.tar.xz 1363488 BLAKE2B 0f71e94af50443f9f562b0eed461ca1160fab0a5a3cd02c845fac09ee2466cb8634a458a6a4488ff5ac6674b0f525eccf754b8b1cc7e3f1729d4eb6ac224e025 SHA512 111eeb470555ae8edb7754159bb2e70b03cbbc7b1c9d61c253d9d67e50d84ff0e0654e16547883c39aeeb223e8ba58201d45b50819784fc6cf7a21f0cf176c70
+DIST engrampa-1.22.2.tar.xz 1379564 BLAKE2B 4193fe3cc06f48e333a37af02ecef9c8e501dabe9a0a43ed07ead543279cc9edb77ea31c4b35490edb8ecaf12fea7f14059ba4ccfc591c1a3727076d9bd5c8bc SHA512 7d57d863a7e6236fdff8c9925647438056474cc7fed32a4ba6a2ba6121a856aa070b47292edb0db447369082cddff9b40978c7c92aecc3d8c2ebc17a4cf3ea99
diff --git a/app-arch/engrampa/engrampa-1.22.2.ebuild b/app-arch/engrampa/engrampa-1.22.2.ebuild
new file mode 100644
index 000000000000..55531d81dec1
--- /dev/null
+++ b/app-arch/engrampa/engrampa-1.22.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+
+inherit mate eutils
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="Engrampa archive manager for MATE"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="caja magic packagekit"
+
+RDEPEND="
+ >=dev-libs/glib-2.50:2
+ >=dev-libs/json-glib-0.14
+ virtual/libintl
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3[X]
+ x11-libs/pango
+ caja? ( >=mate-base/caja-1.17.1 )
+ magic? ( sys-apps/file )
+ packagekit? ( app-admin/packagekit-base )"
+
+DEPEND="${RDEPEND}
+ app-text/yelp-tools
+ dev-util/glib-utils
+ >=dev-util/intltool-0.50.1
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DISABLE_AUTOFORMATTING="yes"
+
+src_configure() {
+ mate_src_configure \
+ --disable-run-in-place \
+ $(use_enable caja caja-actions) \
+ $(use_enable magic) \
+ $(use_enable packagekit)
+}
+
+pkg_postinst() {
+ mate_pkg_postinst
+ optfeature "Support for 7-zip" app-arch/p7zip
+ optfeature "Support for ace" app-arch/unace
+ optfeature "Support for arj" app-arch/arj
+ optfeature "Support for cpio" app-arch/cpio
+ optfeature "Support for deb" app-arch/dpkg
+ optfeature "Support for iso" app-cdr/cdrtools
+ optfeature "Support for jar,zip" app-arch/zip app-arch/unzip
+ optfeature "Support for lha" app-arch/lha
+ optfeature "Support for lzma" app-arch/xz-utils
+ optfeature "Support for lzop" app-arch/lzop
+ optfeature "Support for rar" app-arch/unrar
+ optfeature "Support for rpm" app-arch/rpm
+ optfeature "Support for unstuff" app-arch/stuffit
+ optfeature "Support for zoo" app-arch/zoo
+}