summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Feldman <NP-Hardass@gentoo.org>2020-04-06 16:25:20 -0400
committerAdam Feldman <NP-Hardass@gentoo.org>2020-04-06 18:14:35 -0400
commited34e81d8408b12cbb9af76ffec61996706dce73 (patch)
tree32e5436239fe8e8c0ab87c361b42c1485ecf1a42 /app-arch/engrampa
parentwww-client/firefox-bin: bump to v75.0 (diff)
downloadgentoo-ed34e81d8408b12cbb9af76ffec61996706dce73.tar.gz
gentoo-ed34e81d8408b12cbb9af76ffec61996706dce73.tar.bz2
gentoo-ed34e81d8408b12cbb9af76ffec61996706dce73.zip
app-arch/engrampa: Fix #707298
Closes: https://bugs.gentoo.org/707298 Package-Manager: Portage-2.3.96, Repoman-2.3.21 Signed-off-by: Adam Feldman <NP-Hardass@gentoo.org>
Diffstat (limited to 'app-arch/engrampa')
-rw-r--r--app-arch/engrampa/engrampa-1.22.3-r1.ebuild (renamed from app-arch/engrampa/engrampa-1.22.3.ebuild)5
-rw-r--r--app-arch/engrampa/files/engrampa-1.22.3-gcc-10-fno-common.patch22
2 files changed, 26 insertions, 1 deletions
diff --git a/app-arch/engrampa/engrampa-1.22.3.ebuild b/app-arch/engrampa/engrampa-1.22.3-r1.ebuild
index d5caa2ad5aac..92299844e0fa 100644
--- a/app-arch/engrampa/engrampa-1.22.3.ebuild
+++ b/app-arch/engrampa/engrampa-1.22.3-r1.ebuild
@@ -45,6 +45,10 @@ src_configure() {
$(use_enable packagekit)
}
+PATCHES=(
+ "${FILESDIR}/${P}-gcc-10-fno-common.patch"
+)
+
src_install() {
mate_src_install
}
@@ -66,4 +70,3 @@ pkg_postinst() {
optfeature "Support for unstuff" app-arch/stuffit
optfeature "Support for zoo" app-arch/zoo
}
-
diff --git a/app-arch/engrampa/files/engrampa-1.22.3-gcc-10-fno-common.patch b/app-arch/engrampa/files/engrampa-1.22.3-gcc-10-fno-common.patch
new file mode 100644
index 000000000000..61e23e087cf6
--- /dev/null
+++ b/app-arch/engrampa/files/engrampa-1.22.3-gcc-10-fno-common.patch
@@ -0,0 +1,22 @@
+From 623bd665371e3afd9dc6fa29f9e1cfe735681358 Mon Sep 17 00:00:00 2001
+From: rbuj <robert.buj@gmail.com>
+Date: Wed, 29 Jan 2020 15:52:44 +0100
+Subject: [PATCH] Fix build using gcc 10 -fno-common flag
+
+---
+ src/main.c | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/src/main.c b/src/main.c
+index 56e75ea0..a9e297dc 100644
+--- a/src/main.c
++++ b/src/main.c
+@@ -33,8 +33,6 @@
+
+ #include "fr-init.h"
+
+-gint ForceDirectoryCreation;
+-
+ static char **remaining_args;
+ static char *add_to = NULL;
+ static int add;